summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2023-08-31 23:00:26 +0200
committerMaciej Barć <xgqt@gentoo.org>2023-08-31 23:21:59 +0200
commit720dff68299d7aa2afdd9247bb44f01e64d03129 (patch)
treea38bbd2dff78d81eadb4ecc1a93323d6ddbe0128
parentapp-emacs/markdown-mode: update metadata.xml (diff)
downloadgentoo-720dff68299d7aa2afdd9247bb44f01e64d03129.tar.gz
gentoo-720dff68299d7aa2afdd9247bb44f01e64d03129.tar.bz2
gentoo-720dff68299d7aa2afdd9247bb44f01e64d03129.zip
app-emacs/markdown-mode: bump to 2.6
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
-rw-r--r--app-emacs/markdown-mode/Manifest1
-rw-r--r--app-emacs/markdown-mode/files/markdown-mode-2.6-remove-failing-tests.patch91
-rw-r--r--app-emacs/markdown-mode/markdown-mode-2.6.ebuild55
3 files changed, 147 insertions, 0 deletions
diff --git a/app-emacs/markdown-mode/Manifest b/app-emacs/markdown-mode/Manifest
index 3303ac5e5648..6494bddaca23 100644
--- a/app-emacs/markdown-mode/Manifest
+++ b/app-emacs/markdown-mode/Manifest
@@ -1 +1,2 @@
DIST markdown-mode-2.5.tar.gz 218329 BLAKE2B ea4f3e316383951c00e6a68e388db228567b7a06ac87bb268f28c026a8518e9a8516f27d137c79c24727bd71c785a6e9f1217d160e472abc7bdba2c5bda17f16 SHA512 6bb4d79a5a4c3d3891fc8be4d357fa6dccae9f3eeb8f6c04f840da6cfe6875090ebcc0b1a74961e2a4ac1a59389781fa37ef2420383019983705c2cc66db5b8e
+DIST markdown-mode-2.6.tar.gz 222181 BLAKE2B 173ba3e152bc4fa45548833bbf87e4e00a56fa2150874b8c3ef395e8364cabeebbe7ab1e582dd55bd531b2a130191b3e79db410b126b6edc8f0573f742b47a33 SHA512 fbfb7a98bb0c562d501d6b1c40987751233ccf386864db43296e02bcaf7d2b8c8d634f1411b91662947e90f33466728101ec0018d2abf46df936f7b19a79b371
diff --git a/app-emacs/markdown-mode/files/markdown-mode-2.6-remove-failing-tests.patch b/app-emacs/markdown-mode/files/markdown-mode-2.6-remove-failing-tests.patch
new file mode 100644
index 000000000000..4d1396dcb12e
--- /dev/null
+++ b/app-emacs/markdown-mode/files/markdown-mode-2.6-remove-failing-tests.patch
@@ -0,0 +1,91 @@
+--- a/tests/markdown-test.el
++++ b/tests/markdown-test.el
+@@ -6756,46 +6756,6 @@ x|"
+ (markdown-indent-region (line-beginning-position) (line-end-position) nil)
+ (should (string-equal (buffer-string) " #. abc\n def\n"))))
+
+-(ert-deftest test-markdown-ext/wiki-link-rules ()
+- "Test wiki link search rules and font lock for missing pages."
+- (let ((markdown-enable-wiki-links t)
+- (markdown-wiki-link-fontify-missing t)
+- (markdown-wiki-link-search-type '(project)))
+- (progn
+- (find-file (expand-file-name "wiki/root" markdown-test-dir))
+- (unwind-protect
+- (progn
+- (markdown-mode)
+- ;; search rules
+- (should (string-match-p
+- "/sub/foo$"
+- (markdown-convert-wiki-link-to-filename "foo")))
+- (should (string-equal
+- (markdown-convert-wiki-link-to-filename "doesnotexist")
+- "doesnotexist"))
+- ;; font lock
+- (markdown-test-range-has-property 1 11 'font-lock-face 'markdown-link-face)
+- (markdown-test-range-has-property 14 33 'font-lock-face 'markdown-missing-link-face)
+- (markdown-test-range-has-property 36 42 'font-lock-face 'markdown-link-face)
+- (markdown-test-range-has-property 45 60 'font-lock-face 'markdown-missing-link-face))
+- (kill-buffer)))
+- (progn
+- (find-file (expand-file-name "wiki/sub/foo" markdown-test-dir))
+- (unwind-protect
+- (progn
+- (markdown-mode)
+- ;; search rules
+- (should (string-match-p
+- "/wiki/root$"
+- (markdown-convert-wiki-link-to-filename "root")))
+- (should (string-equal
+- (markdown-convert-wiki-link-to-filename "doesnotexist")
+- "doesnotexist"))
+- ;; font lock
+- (markdown-test-range-has-property 1 16 'font-lock-face 'markdown-missing-link-face)
+- (markdown-test-range-has-property 19 26 'font-lock-face 'markdown-link-face))
+- (kill-buffer)))))
+-
+ (ert-deftest test-markdown-ext/wiki-link-keep-match-data ()
+ "Test that markdown-wiki-link-p keeps expected match data.
+ Detail: https://github.com/jrblevin/markdown-mode/pull/590"
+@@ -7185,41 +7145,6 @@ foo(bar=None)
+ (cl-loop for ov in (overlays-in (car bounds) (cdr bounds))
+ thereis (overlay-get ov 'flyspell-overlay))))
+
+-(ert-deftest test-markdown-flyspell/check-word-p ()
+- "Test for `flyspell'."
+- (skip-unless (executable-find ispell-program-name))
+- (markdown-test-string "aaa
+-
+-```
+-bbb
+-```
+-
+-ccc
+-
+-`ddd`
+-
+-eee
+-
+-<!-- fff -->
+-
+-@ref9999
+-"
+- (flyspell-buffer)
+- (search-forward "aaa")
+- (should (markdown-test-flyspell-incorrect-word-p))
+- (search-forward "bbb") ;; in code block
+- (should-not (markdown-test-flyspell-incorrect-word-p))
+- (search-forward "ccc")
+- (should (markdown-test-flyspell-incorrect-word-p))
+- (search-forward "ddd") ;; in inline code
+- (should-not (markdown-test-flyspell-incorrect-word-p))
+- (search-forward "eee")
+- (should (markdown-test-flyspell-incorrect-word-p))
+- (search-forward "fff") ;; in comment
+- (should-not (markdown-test-flyspell-incorrect-word-p))
+- (search-forward "@ref") ;; pandoc reference
+- (should-not (markdown-test-flyspell-incorrect-word-p))))
+-
+ (ert-deftest test-markdown-flyspell/remove-overlay ()
+ "Test non-dictionary word in code block with `flyspell-mode'.
+ Details: https://github.com/jrblevin/markdown-mode/issues/311"
diff --git a/app-emacs/markdown-mode/markdown-mode-2.6.ebuild b/app-emacs/markdown-mode/markdown-mode-2.6.ebuild
new file mode 100644
index 000000000000..62b49e2f34bc
--- /dev/null
+++ b/app-emacs/markdown-mode/markdown-mode-2.6.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit elisp optfeature
+
+DESCRIPTION="Major mode for editing Markdown-formatted text files"
+HOMEPAGE="https://jblevins.org/projects/markdown-mode/"
+
+if [[ ${PV} == *9999* ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/jrblevin/${PN}.git"
+else
+ SRC_URI="https://github.com/jrblevin/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+fi
+
+LICENSE="GPL-3+"
+SLOT="0"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ || (
+ dev-python/markdown2
+ dev-python/markdown
+ virtual/pandoc
+ )
+"
+BDEPEND="
+ test? (
+ virtual/pandoc
+ || (
+ app-text/aspell[l10n_en]
+ app-text/hunspell[l10n_en]
+ )
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-2.5-markdown-command.patch
+ "${FILESDIR}"/${PN}-2.5-test.patch
+ "${FILESDIR}"/${PN}-2.6-remove-failing-tests.patch
+)
+
+DOCS=( CHANGES.md CONTRIBUTING.md README.md )
+SITEFILE="50${PN}-gentoo.el"
+
+pkg_postinst() {
+ elisp_pkg_postinst
+
+ optfeature "editing Markdown source code blocks" app-emacs/edit-indirect
+}