summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-03-18 16:54:32 +0000
committerSam James <sam@gentoo.org>2024-03-18 16:54:32 +0000
commit7215cac725118dc0afc8fd0489b33404e21ca22a (patch)
tree3c4b22bdebf05da029895f3c8cf81c02d5ac756f
parentmedia-libs/quirc: fix src_prepare (diff)
downloadgentoo-7215cac7.tar.gz
gentoo-7215cac7.tar.bz2
gentoo-7215cac7.zip
media-libs/libxmp: add 4.6.0
Closes: https://bugs.gentoo.org/859928 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--media-libs/libxmp/Manifest1
-rw-r--r--media-libs/libxmp/libxmp-4.6.0.ebuild28
-rw-r--r--media-libs/libxmp/libxmp-9999.ebuild9
3 files changed, 34 insertions, 4 deletions
diff --git a/media-libs/libxmp/Manifest b/media-libs/libxmp/Manifest
index cd7d0e9d567f..42c8b59f01ee 100644
--- a/media-libs/libxmp/Manifest
+++ b/media-libs/libxmp/Manifest
@@ -1 +1,2 @@
DIST libxmp-4.5.0.tar.gz 652983 BLAKE2B f583c309b4c4349eec73352d16bbd9b2b20fb48be101f0cba34a3597fce903442fbc203be50f940a7e3b8f53cc1bbf6ff91236fc27c6ec70b21ec17ad71bd6fb SHA512 71a57c7fcd696267c6e2d3cc12b43fe09adce9ed83f9f130755d3b2c2b984eb52e4ae4fad115ffeb07397c7cc4886fc3c4e01cbb1f047449228f7a557760cb1a
+DIST libxmp-4.6.0.tar.gz 738532 BLAKE2B d383cb2e8c15c27e9f55954a4ae2ead6978b7e073e647ab667a2c0bb15848ff582626611b3f274ac5075bcdb7b5cfdc1a4f95d2ea76dc0ea64dab595ba8ca1b8 SHA512 d287544c9b569515f1a3fa92d8d930097b252e84f86cba5dd70e9b4460d0fa70754ece45dcc7ec314e434d821b43207d700afb12c9df80b467d73e9d029baafe
diff --git a/media-libs/libxmp/libxmp-4.6.0.ebuild b/media-libs/libxmp/libxmp-4.6.0.ebuild
new file mode 100644
index 000000000000..3c9163a049d7
--- /dev/null
+++ b/media-libs/libxmp/libxmp-4.6.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Library that renders module files to PCM data"
+HOMEPAGE="https://github.com/libxmp/libxmp"
+
+if [[ ${PV} == *9999 ]] ; then
+ inherit autotools git-r3
+ EGIT_REPO_URI="https://github.com/libxmp/libxmp.git"
+else
+ SRC_URI="https://github.com/libxmp/${PN}/releases/download/${P}/${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+# bzip2 depacker code is 0BSD
+LICENSE="LGPL-2.1+ MIT 0BSD"
+SLOT="0"
+
+src_prepare() {
+ default
+ [[ ${PV} == *9999 ]] && eautoreconf
+}
+
+src_compile() {
+ emake V=1
+}
diff --git a/media-libs/libxmp/libxmp-9999.ebuild b/media-libs/libxmp/libxmp-9999.ebuild
index f0deadcf7930..3c9163a049d7 100644
--- a/media-libs/libxmp/libxmp-9999.ebuild
+++ b/media-libs/libxmp/libxmp-9999.ebuild
@@ -1,10 +1,11 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
DESCRIPTION="Library that renders module files to PCM data"
HOMEPAGE="https://github.com/libxmp/libxmp"
+
if [[ ${PV} == *9999 ]] ; then
inherit autotools git-r3
EGIT_REPO_URI="https://github.com/libxmp/libxmp.git"
@@ -12,10 +13,10 @@ else
SRC_URI="https://github.com/libxmp/${PN}/releases/download/${P}/${P}.tar.gz"
KEYWORDS="~amd64"
fi
-LICENSE="LGPL-2.1+"
-SLOT="0"
-IUSE=""
+# bzip2 depacker code is 0BSD
+LICENSE="LGPL-2.1+ MIT 0BSD"
+SLOT="0"
src_prepare() {
default