summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-06-03 19:57:23 +0200
committerAlexis Ballier <aballier@gentoo.org>2017-06-03 19:57:23 +0200
commit721b89d83474b1a2747fd9d923016eaa4a584ebc (patch)
tree53dbdac5f423b587fff01b65abac6e95f879ed29
parentdev-ml/ocaml-uri: remove spurious blank line (diff)
downloadgentoo-721b89d8.tar.gz
gentoo-721b89d8.tar.bz2
gentoo-721b89d8.zip
dev-python/nnpy: bump to 1.4.1
Package-Manager: Portage-2.3.6, Repoman-2.3.2
-rw-r--r--dev-python/nnpy/Manifest1
-rw-r--r--dev-python/nnpy/files/py3.patch19
-rw-r--r--dev-python/nnpy/nnpy-1.4.1.ebuild29
3 files changed, 49 insertions, 0 deletions
diff --git a/dev-python/nnpy/Manifest b/dev-python/nnpy/Manifest
index f7d2c0defea7..de54e2c03ed2 100644
--- a/dev-python/nnpy/Manifest
+++ b/dev-python/nnpy/Manifest
@@ -1,2 +1,3 @@
DIST nnpy-1.2.tar.gz 3781 SHA256 0b3a894dd0be0f5b6f967e3cacf5ec3399e4fbc9ef83fdc3e7c6b17fa3284094 SHA512 ae88d52289c1b4e9853e81342aec94feee004f46e6b5801764ed1fc50f7e249cf45b8d24e85ae9f69003304052505cd9242f43ee33de42ab4f862b3f9cb20b3f WHIRLPOOL 09ab1e11bea3f163d78860ac69e604bb176f17e1e3049af139627e6baa4572bd9d40f38a29b0eb5a352e5279504652994003d84eb8f3a5c248f0fe96aad4c4ee
DIST nnpy-1.3.tar.gz 4384 SHA256 50daf80693f355096a4926e8b5a8ec5f216a3ca28f0eb14ff819b218a3691f4e SHA512 66ec80169f4c107f2c9ea870153824a84f5bfdecbb0b40a455061a926b43ff61a723b4e62d9b0e9f5361cf6b486f706a5ff111681bbb4083180988337416e0f6 WHIRLPOOL 76ef6210c028cd83bb98fb89e452bec82a7b6cfb3a19bac37e8306a18b2e4d9f1a801624e3db31b525a831ad2ddee5d3dd87017eebeb20241e323037ab688e0d
+DIST nnpy-1.4.1.tar.gz 4826 SHA256 2b947d097b19e9d4182d77f542dccb93da543a325b2eb616cc9e0e90cfed50a9 SHA512 26e1393fdca77cc9385eff0622f9a5b4987eeca533c57478ba873a1ea96f312a2d535fd3eaa883c47746157a9d692b4b0f6c52d51ea5b4fea5fb885cfdadc2a2 WHIRLPOOL bb3082484ac0f2829ad39a0592c8944827bdb30cd097fc73e020570d770513d802608732e14ae47a565669060388e20d7684631d6d0da83da4dd48fba123f373
diff --git a/dev-python/nnpy/files/py3.patch b/dev-python/nnpy/files/py3.patch
new file mode 100644
index 000000000000..8a39044bb7f1
--- /dev/null
+++ b/dev-python/nnpy/files/py3.patch
@@ -0,0 +1,19 @@
+commit 98ee46a4034ca94d6123b854e79f1dc3f35fff4a
+Author: Alexis Ballier <aballier@gentoo.org>
+Date: Sat Jun 3 19:55:10 2017 +0200
+
+ Fix tests under python3.
+
+diff --git a/nnpy/tests.py b/nnpy/tests.py
+index ba2a3fe..7f9f6e0 100644
+--- a/nnpy/tests.py
++++ b/nnpy/tests.py
+@@ -17,7 +17,7 @@ class Tests(unittest.TestCase):
+ poller = nnpy.PollSet((sub, nnpy.POLLIN))
+ self.assertEqual(len(poller.poll()), 1)
+ self.assertEqual(poller.poll()[0], 1)
+- self.assertEqual(sub.recv(), 'FLUB')
++ self.assertEqual(sub.recv().decode(), 'FLUB')
+ self.assertEqual(pub.get_statistic(nnpy.STAT_MESSAGES_SENT), 1)
+ pub.close()
+ sub.shutdown(sub_conn)
diff --git a/dev-python/nnpy/nnpy-1.4.1.ebuild b/dev-python/nnpy/nnpy-1.4.1.ebuild
new file mode 100644
index 000000000000..f4810a9336cd
--- /dev/null
+++ b/dev-python/nnpy/nnpy-1.4.1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+
+inherit distutils-r1
+
+DESCRIPTION="cffi-based Python bindings for nanomsg"
+HOMEPAGE="https://github.com/nanomsg/nnpy"
+SRC_URI="https://github.com/nanomsg/nnpy/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm"
+IUSE=""
+
+DEPEND="
+ dev-python/cffi:=[${PYTHON_USEDEP}]
+ dev-libs/nanomsg:=
+"
+RDEPEND="${DEPEND}"
+
+PATCHES=( "${FILESDIR}/py3.patch" )
+
+python_test() {
+ PYTHONPATH="${S}:${PYTHONPATH}" "${PYTHON}" "${S}/nnpy/tests.py" || die
+}