summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Smith <matthew@gentoo.org>2022-02-20 08:56:24 +0000
committerMatthew Smith <matthew@gentoo.org>2022-02-20 09:33:14 +0000
commit721ddf8a739c38c06a2df1ec804bee4e6535b8c7 (patch)
treec1d1674fe9ffa5f8da1c2987c4c38724cf424d3f
parentvala.eclass: Support EAPI 8 (diff)
downloadgentoo-721ddf8a739c38c06a2df1ec804bee4e6535b8c7.tar.gz
gentoo-721ddf8a739c38c06a2df1ec804bee4e6535b8c7.tar.bz2
gentoo-721ddf8a739c38c06a2df1ec804bee4e6535b8c7.zip
app-emacs/flycheck-inline: initial import at 0_pre20200808
Signed-off-by: Matthew Smith <matthew@gentoo.org>
-rw-r--r--app-emacs/flycheck-inline/Manifest1
-rw-r--r--app-emacs/flycheck-inline/files/50flycheck-inline-gentoo.el3
-rw-r--r--app-emacs/flycheck-inline/flycheck-inline-0_pre20200808.ebuild22
-rw-r--r--app-emacs/flycheck-inline/metadata.xml12
4 files changed, 38 insertions, 0 deletions
diff --git a/app-emacs/flycheck-inline/Manifest b/app-emacs/flycheck-inline/Manifest
new file mode 100644
index 000000000000..51b3b89af42a
--- /dev/null
+++ b/app-emacs/flycheck-inline/Manifest
@@ -0,0 +1 @@
+DIST flycheck-inline-0_pre20200808.tar.gz 112922 BLAKE2B 2fffd7801d5a882145703e5e24ce46bb9546a5dd797f348597abe8977c130762fc8e68af44f25d1b4bc5f57623ada87314f43949eae4d5795d7d34f76e3b7850 SHA512 7fefacc9913a484ddad3043d49130700bfb5f55d6fb04c3020170fc74c74ebca888a602ff6f0574bd3759552f677357d3eb479cd3600d57bf7e96e0491f93e40
diff --git a/app-emacs/flycheck-inline/files/50flycheck-inline-gentoo.el b/app-emacs/flycheck-inline/files/50flycheck-inline-gentoo.el
new file mode 100644
index 000000000000..df56a9af63a7
--- /dev/null
+++ b/app-emacs/flycheck-inline/files/50flycheck-inline-gentoo.el
@@ -0,0 +1,3 @@
+(add-to-list 'load-path "@SITELISP@")
+(autoload 'flycheck-inline-mode "flycheck-inline" nil t)
+(autoload 'global-flycheck-inline-mode "flycheck-inline" nil t)
diff --git a/app-emacs/flycheck-inline/flycheck-inline-0_pre20200808.ebuild b/app-emacs/flycheck-inline/flycheck-inline-0_pre20200808.ebuild
new file mode 100644
index 000000000000..c884d36a537c
--- /dev/null
+++ b/app-emacs/flycheck-inline/flycheck-inline-0_pre20200808.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+NEED_EMACS=25
+MY_COMMIT="8e00b4c5951a9515a450a14aefe92e9f6ddcfbde"
+
+inherit elisp
+
+DESCRIPTION="Display Flycheck errors inline"
+HOMEPAGE="https://github.com/flycheck/flycheck-inline"
+SRC_URI="https://github.com/flycheck/flycheck-inline/archive/${MY_COMMIT}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}"/${PN}-${MY_COMMIT}
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64"
+
+SITEFILE="50${PN}-gentoo.el"
+
+DEPEND="app-emacs/flycheck"
+RDEPEND="${DEPEND}"
diff --git a/app-emacs/flycheck-inline/metadata.xml b/app-emacs/flycheck-inline/metadata.xml
new file mode 100644
index 000000000000..d1d388c5d8ba
--- /dev/null
+++ b/app-emacs/flycheck-inline/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>gnu-emacs@gentoo.org</email>
+ <name>Gentoo GNU Emacs project</name>
+</maintainer>
+<stabilize-allarches/>
+<upstream>
+ <remote-id type="github">flycheck/flycheck-inline</remote-id>
+</upstream>
+</pkgmetadata>