summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2018-11-22 22:47:47 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2018-11-22 22:48:36 +0100
commit7222b3663c3654fb3159fefff328cbc003733e5d (patch)
tree34e146d5e44f0c5e973dfe7c5461776061b1143c
parentapp-office/libreoffice: QA: Don't install compressed manpages (diff)
downloadgentoo-7222b366.tar.gz
gentoo-7222b366.tar.bz2
gentoo-7222b366.zip
media-sound/lmms: Fix build with Qt 5.11.0
Using upstream patch from git master (>1.2.0_rc7). Closes: https://bugs.gentoo.org/670250 Package-Manager: Portage-2.3.52, Repoman-2.3.12 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
-rw-r--r--media-sound/lmms/files/lmms-1.2.0_rc4-qt-5.11.patch22
-rw-r--r--media-sound/lmms/lmms-1.2.0_rc4.ebuild4
2 files changed, 25 insertions, 1 deletions
diff --git a/media-sound/lmms/files/lmms-1.2.0_rc4-qt-5.11.patch b/media-sound/lmms/files/lmms-1.2.0_rc4-qt-5.11.patch
new file mode 100644
index 000000000000..ee1328e8c962
--- /dev/null
+++ b/media-sound/lmms/files/lmms-1.2.0_rc4-qt-5.11.patch
@@ -0,0 +1,22 @@
+From daa3f535158f321e7a01ea531fc3085f2d26ab37 Mon Sep 17 00:00:00 2001
+From: Hyunjin Song <tteu.ingog@gmail.com>
+Date: Wed, 23 May 2018 14:59:45 +0900
+Subject: [PATCH] Fix compilation with Qt 5.11 (#4374)
+
+Add extends attribute for custom widget RowTableView per upstream uic change http://code.qt.io/cgit/qt/qtbase.git/commit/?id=058474884c2505a8a00d4c59b4922bfcd3597c2f
+---
+ src/gui/Forms/EffectSelectDialog.ui | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/src/gui/Forms/EffectSelectDialog.ui b/src/gui/Forms/EffectSelectDialog.ui
+index a9c6de0191..f8e7734862 100644
+--- a/src/gui/Forms/EffectSelectDialog.ui
++++ b/src/gui/Forms/EffectSelectDialog.ui
+@@ -102,6 +102,7 @@
+ <customwidgets>
+ <customwidget>
+ <class>RowTableView</class>
++ <extends>QTableView</extends>
+ <header>RowTableView.h</header>
+ </customwidget>
+ </customwidgets>
diff --git a/media-sound/lmms/lmms-1.2.0_rc4.ebuild b/media-sound/lmms/lmms-1.2.0_rc4.ebuild
index 354ba7ece7b3..a85c255a0f3e 100644
--- a/media-sound/lmms/lmms-1.2.0_rc4.ebuild
+++ b/media-sound/lmms/lmms-1.2.0_rc4.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -61,6 +61,8 @@ RDEPEND="${COMMON_DEPEND}
DOCS=( README.md doc/AUTHORS )
+PATCHES=( "${FILESDIR}/${P}-qt-5.11.patch" )
+
src_configure() {
local mycmakeargs+=(
-DUSE_WERROR=FALSE