summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-11-03 08:50:42 +0100
committerMichał Górny <mgorny@gentoo.org>2020-11-03 09:23:57 +0100
commit7231a8efa3d075e0debbca5fc37a9f3376d3234c (patch)
tree9eb8335d99c179fcc0ed0fce44e8a2c06d69a3d8
parentdev-python/hypothesis: Bump to 5.41.1 (diff)
downloadgentoo-7231a8ef.tar.gz
gentoo-7231a8ef.tar.bz2
gentoo-7231a8ef.zip
dev-python/pycryptodome: Bump to 3.9.9
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/pycryptodome/Manifest1
-rw-r--r--dev-python/pycryptodome/pycryptodome-3.9.9.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/dev-python/pycryptodome/Manifest b/dev-python/pycryptodome/Manifest
index ddeadc268fc5..03927272fd7d 100644
--- a/dev-python/pycryptodome/Manifest
+++ b/dev-python/pycryptodome/Manifest
@@ -1 +1,2 @@
DIST pycryptodome-3.9.8.tar.gz 15633268 BLAKE2B 8c4f8d4839be0fb09556677514ee6c7f832684f20eb4e355cee87eb5b52a5c09e12712c1865ff89fb5dd6c628ca027374c7cab8a2287aafa4eecedf1095f1a12 SHA512 894e763720df284804fd686d5805980853b86773bb3097bf03d929818b9944e5a257e47414275f302966864751e50ae34dea19ad749910f1ceac31833a53ef7c
+DIST pycryptodome-3.9.9.tar.gz 15551299 BLAKE2B ac89bcc2bbe707cb2a9cf2496a2eb74ff5685f11017d60d67558de7ac6cad5c24c43b4074bff01e99378d7c88462e88e88f363c5329fb800e1a7872ad8a34dab SHA512 a1aad4d52256220fe3d5d7f399c2c5e7338d6eb88058da0571fe1c686d74d33ff4bc1c275d4b9373e0ff22f4ddcded75a25387e76fc65047f8612f8856c1bd4d
diff --git a/dev-python/pycryptodome/pycryptodome-3.9.9.ebuild b/dev-python/pycryptodome/pycryptodome-3.9.9.ebuild
new file mode 100644
index 000000000000..db3ad5cb9dd4
--- /dev/null
+++ b/dev-python/pycryptodome/pycryptodome-3.9.9.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6..9} pypy3 )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="A self-contained cryptographic library for Python"
+HOMEPAGE="https://www.pycryptodome.org
+ https://github.com/Legrandin/pycryptodome/
+ https://pypi.org/project/pycryptodome/"
+SRC_URI="
+ https://github.com/Legrandin/pycryptodome/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="BSD-2 Unlicense"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~ppc-aix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+DEPEND="
+ dev-libs/gmp:0"
+BDEPEND="
+ virtual/python-cffi[${PYTHON_USEDEP}]"
+RDEPEND="
+ ${DEPEND}
+ ${BDEPEND}
+ !dev-python/pycrypto"
+
+PATCHES=(
+ "${FILESDIR}/pycryptodome-3.9.4-parallel-make.patch"
+)
+
+distutils_enable_tests setup.py
+
+python_prepare_all() {
+ # parallel make fixes
+ # Multiple targets were compiling the same file, setuptools doesn't
+ # understand this and you get race conditions where a file gets
+ # overwritten while it's linking. This makes the files look like separate
+ # files so this race won't happen
+ ln src/blowfish.c src/blowfish_eks.c || die
+ ln src/mont.c src/mont_math.c || die
+
+ distutils-r1_python_prepare_all
+}