summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-02-02 23:36:25 +0100
committerMichał Górny <mgorny@gentoo.org>2022-02-03 00:20:56 +0100
commit723e94e9d1d936508935478889be96ac552db3ab (patch)
tree5d6352f74354d00699f0bd7427976a119951bb11
parentdev-python/botocore: Bump to 1.23.47 (diff)
downloadgentoo-723e94e9.tar.gz
gentoo-723e94e9.tar.bz2
gentoo-723e94e9.zip
dev-python/boto3: Bump to 1.20.47
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/boto3/Manifest1
-rw-r--r--dev-python/boto3/boto3-1.20.47.ebuild60
2 files changed, 61 insertions, 0 deletions
diff --git a/dev-python/boto3/Manifest b/dev-python/boto3/Manifest
index c745dda40cd2..567eeb6eaa4c 100644
--- a/dev-python/boto3/Manifest
+++ b/dev-python/boto3/Manifest
@@ -8,3 +8,4 @@ DIST boto3-1.20.43.tar.gz 463424 BLAKE2B 6d67a86d4d0577b2e9d30335ddb1286f25bc866
DIST boto3-1.20.44.tar.gz 463921 BLAKE2B 1276bbddbf1be9e30142ef1ccc24a69e885d1bdf35ce1c136105d1c08b6a24820c965827c6bc569c747efb5dbb8e64b611b3ac2bc63bcb714f8d6748e424f927 SHA512 de223aa34efd81d26287204e9159368ee77bd91e3fd457896d801bc1517ed4b32f5a16d1441f053f90e232beb473c51bee88f591db5746cf5b8049f044c29811
DIST boto3-1.20.45.tar.gz 464557 BLAKE2B f021696e14a2bd82325c666a3ef8266ae3e19564cda9792a2436079b24810949af86f6d1a328850f58c9f53be261ee67c6282adc1cd846df0a37d686835c92fa SHA512 293e89a96601c15f78efc2a7c9dd91bf1db6944deebdb50e093b075540bafd1da5ea82d9719bfc36b205b0cfdb5052f3f69cc504bef089e980ead68f39326d85
DIST boto3-1.20.46.tar.gz 464857 BLAKE2B 40eb0f2c298821530028c84f90d8acd9757a4b6c74e8355ca644ee2a87297d7ba3b70a2614e83c83befe0f6e3b64e0f1e023cc2fc3edbf3deb40f86382265338 SHA512 3ad8808ace2ce24eba54c60aa1ece5b904a2138a1497ec5c180a9aa1bef95cd61e2eabf26614d35690ae790cb56400afb6e32d0c005911e0eb42deaee7dc2602
+DIST boto3-1.20.47.tar.gz 465774 BLAKE2B ab615d29d79b209671808770968c38c2ef26b83ae48d1e18c3129c2886a274ae8a9fc7680fa851f205c28161bd16b20eef075c1a6cdbc5cfaf835c7ead974313 SHA512 c3a84ba9df6670879605e9085ea7aa15077d9f1c30117de6e9cd9cbb427a6a06097a388feb80a0ebc7ad1f422a40df402986d3dc9b004abf5252dab16524c761
diff --git a/dev-python/boto3/boto3-1.20.47.ebuild b/dev-python/boto3/boto3-1.20.47.ebuild
new file mode 100644
index 000000000000..48ea5aa483a1
--- /dev/null
+++ b/dev-python/boto3/boto3-1.20.47.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="The AWS SDK for Python"
+HOMEPAGE="https://github.com/boto/boto3"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/boto/boto3"
+ inherit git-r3
+ BOTOCORE_PV=${PV}
+else
+ SRC_URI="https://github.com/boto/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+ # botocore is x.(y+3).z
+ BOTOCORE_PV="$(ver_cut 1).$(( $(ver_cut 2) + 3)).$(ver_cut 3-)"
+fi
+
+RDEPEND="
+ >=dev-python/botocore-${BOTOCORE_PV}[${PYTHON_USEDEP}]
+ >=dev-python/jmespath-0.7.1[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.3.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx docs/source \
+ 'dev-python/guzzle_sphinx_theme'
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # don't lock versions to narrow ranges
+ sed -e '/botocore/ d' \
+ -e '/jmespath/ d' \
+ -e '/s3transfer/ d' \
+ -i setup.py || die
+
+ # do not rely on bundled deps in botocore (sic!)
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ epytest tests/{functional,unit}
+}