summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-01-19 10:04:58 +0100
committerMichał Górny <mgorny@gentoo.org>2022-01-19 10:06:48 +0100
commit723ea685745758ebe4f7c9dd769ad8a0db9904da (patch)
treec4525894d2d7b5b40fcff2dc40eb585001457c39
parentnet-analyzer/zabbix: removed obsolete and vulnerable versions (diff)
downloadgentoo-723ea685.tar.gz
gentoo-723ea685.tar.bz2
gentoo-723ea685.zip
dev-python/google-api-python-client: Bump to 2.36.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/google-api-python-client/Manifest1
-rw-r--r--dev-python/google-api-python-client/google-api-python-client-2.36.0.ebuild45
2 files changed, 46 insertions, 0 deletions
diff --git a/dev-python/google-api-python-client/Manifest b/dev-python/google-api-python-client/Manifest
index b7a968d1f3a4..6925c3156afb 100644
--- a/dev-python/google-api-python-client/Manifest
+++ b/dev-python/google-api-python-client/Manifest
@@ -1,2 +1,3 @@
DIST google-api-python-client-2.34.0.tar.gz 28469433 BLAKE2B aa2c8849b629fe489cf39cddd410a40a0af0bddfa5f370a4a41c1446aeadf69cd4592eeb1d76e6c63da9737906801aea9c8a4d706328b63a7bf5b34a43b83e00 SHA512 321dfdd3ba821beabc6c3a96575afd06c75a0c8e3db61b1ff5fa9db472e62de81b037c435a1051d6294c2a37e471bcaa068cd27ad7434a3416231d31931dd74e
DIST google-api-python-client-2.35.0.tar.gz 28553015 BLAKE2B 8ff92145f280e090b8f43c10e425dd4a8fe65b4cf565c5b5a0df2813cdb8ba1bcea50e37556efb9dd0b270a21fe11b7d6d1b445c8fdaa83326c7dc6230ee1fdb SHA512 4d0325b79250a26ae252568759e8345d31d692aa1d8f1d7aae623bb9a1a950efae654cd689d39f30450789c6d4fa9ca264111f8a9e798820cf6d0c3acba904f6
+DIST google-api-python-client-2.36.0.tar.gz 28624616 BLAKE2B 738d89e740ded848683a4bc5c1d4b27f57acb817c54397ed563de376fa395d1202c47fd4b42046f313b31c826fb3d0fc2e3761c0779bf9c9718b3b2923fc63a3 SHA512 bdca303fa84f5cb510102265ebb7629b48b939c8d7a01420e61635ef4c461f62b6dfa6f29e96060a80d86baf0ea6587d88b0ec64a7b4c6b32563921c3a1a53ca
diff --git a/dev-python/google-api-python-client/google-api-python-client-2.36.0.ebuild b/dev-python/google-api-python-client/google-api-python-client-2.36.0.ebuild
new file mode 100644
index 000000000000..13b520b44abe
--- /dev/null
+++ b/dev-python/google-api-python-client/google-api-python-client-2.36.0.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..9} )
+inherit distutils-r1
+
+DESCRIPTION="Google API Client for Python"
+HOMEPAGE="https://github.com/googleapis/google-api-python-client"
+SRC_URI="https://github.com/googleapis/google-api-python-client/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+RDEPEND="
+ >=dev-python/httplib2-0.15[${PYTHON_USEDEP}]
+ <dev-python/httplib2-1[${PYTHON_USEDEP}]
+ dev-python/google-api-core[${PYTHON_USEDEP}]
+ >=dev-python/google-auth-1.35.0[${PYTHON_USEDEP}]
+ >=dev-python/google-auth-httplib2-0.1.0[${PYTHON_USEDEP}]
+ >=dev-python/uritemplate-3.0.0[${PYTHON_USEDEP}]
+ <dev-python/uritemplate-5[${PYTHON_USEDEP}]
+ "
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/oauth2client[${PYTHON_USEDEP}]
+ dev-python/pandas[${PYTHON_USEDEP}]
+ dev-python/parameterized[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # require Internet access (and credentials)
+ tests/test_discovery.py::DiscoveryErrors::test_credentials_and_credentials_file_mutually_exclusive
+ tests/test_discovery.py::DiscoveryFromDocument::test_api_endpoint_override_from_client_options_mapping_object
+ )
+
+ epytest tests
+}