summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@gentoo.org>2023-06-14 22:04:28 +0200
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2023-06-14 22:04:35 +0200
commit7268dc6ab1c9a33ec2dc8c09eac2b98405f7b050 (patch)
tree5c563ebf5071c5a7a087e021c6d6589db6eec54f
parentmate-base/mate-applets: Stabilize 1.26.1 x86, #908503 (diff)
downloadgentoo-7268dc6ab1c9a33ec2dc8c09eac2b98405f7b050.tar.gz
gentoo-7268dc6ab1c9a33ec2dc8c09eac2b98405f7b050.tar.bz2
gentoo-7268dc6ab1c9a33ec2dc8c09eac2b98405f7b050.zip
media-libs/oneVPL-intel-gpu: add 23.2.3
Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
-rw-r--r--media-libs/oneVPL-intel-gpu/Manifest1
-rw-r--r--media-libs/oneVPL-intel-gpu/oneVPL-intel-gpu-23.2.3.ebuild46
2 files changed, 47 insertions, 0 deletions
diff --git a/media-libs/oneVPL-intel-gpu/Manifest b/media-libs/oneVPL-intel-gpu/Manifest
index e6ef282b0c06..8689c26a37c7 100644
--- a/media-libs/oneVPL-intel-gpu/Manifest
+++ b/media-libs/oneVPL-intel-gpu/Manifest
@@ -1,2 +1,3 @@
DIST oneVPL-intel-gpu-23.2.1.tar.gz 6987103 BLAKE2B f4634aecfe3baba96b230d56915f864c1655c725fd05c72be9033406794afa7f501c42c13c442d676367a0ddbe176fcec9c1df6ec3013320fe3af2e348879ab8 SHA512 c097b0eb1879303d9138f8e92110216cd2e703ab3ad0ef2890678734b26b73037abc4724531f3ce4628993790f8de12bde82a9097df0f42e12a88b10ba5a9ae5
DIST oneVPL-intel-gpu-23.2.2.tar.gz 6989173 BLAKE2B 5e0d65f320df1b7c7bba4524b51f525a71595a33e6954b0f74e1b913e0e001e55321c93c43d18dc915fc29ae4c73d408852d993084564e74ea85a75d0e959fa9 SHA512 d419519c2369444ad0daf4ff6f12ddd57e4ffb6dcba05f686490adff65c693db563d306ab9ce76fa9d21d3c4b1b01717d0a8a1d63f595d6ceb43c11657dde7af
+DIST oneVPL-intel-gpu-23.2.3.tar.gz 6989464 BLAKE2B 3e58be00fec9c7c8bb296e79a8910035b3423ce2baea73f3f9b96c7b88e9df37e86f6622a97f6cbe234495f54db2b764edb5bd088168abb6e9b47f041b3f991a SHA512 45039f16116053ab4d7b0b2081f267187105ce728c15236b90b835e1f70f97c3d2905b04b42d5b7ea2147ad4a305e15c705935a93a3252afc57bafc865e425c2
diff --git a/media-libs/oneVPL-intel-gpu/oneVPL-intel-gpu-23.2.3.ebuild b/media-libs/oneVPL-intel-gpu/oneVPL-intel-gpu-23.2.3.ebuild
new file mode 100644
index 000000000000..6d87d22aff64
--- /dev/null
+++ b/media-libs/oneVPL-intel-gpu/oneVPL-intel-gpu-23.2.3.ebuild
@@ -0,0 +1,46 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="oneAPI Video Processing Library Intel GPU implementation"
+HOMEPAGE="https://github.com/oneapi-src/oneVPL-intel-gpu"
+SRC_URI="https://github.com/oneapi-src/oneVPL-intel-gpu/archive/refs/tags/intel-onevpl-${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${PN}-intel-onevpl-${PV}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+DEPEND="
+ media-libs/libva
+ x11-libs/libdrm[video_cards_intel]
+"
+# At runtime we need a dispatcher, oneVPL is preferred but mediasdk also works
+RDEPEND="${DEPEND}
+ >=media-libs/libva-intel-media-driver-${PV}
+ || (
+ media-libs/oneVPL[drm,vaapi]
+ media-libs/intel-mediasdk
+ )
+"
+BDEPEND="virtual/pkgconfig"
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_RUNTIME=ON
+ # To build the kernels we need to package the cm-compiler, use pre-built instead
+ -DBUILD_KERNELS=OFF
+ -DBUILD_TESTS="$(usex test)"
+ # This only seems to do something if we BUILD_KERNELS=ON
+ #-DBUILD_TOOLS="$(usex tools)"
+ # OpenCL only has an effect if we build kernels
+ -DENABLE_OPENCL=OFF
+ )
+ cmake_src_configure
+}