summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2023-12-15 02:25:54 +0100
committerMaciej Barć <xgqt@gentoo.org>2023-12-15 02:25:54 +0100
commit7288f8f83ff285389fe4599fbb393283dde2d5e0 (patch)
tree62f282d9ad824bb4dd2cb0a3c0c06f77cd48bb8f
parentapp-emacs/yaml: drop old 0.5.3 (diff)
downloadgentoo-7288f8f83ff285389fe4599fbb393283dde2d5e0.tar.gz
gentoo-7288f8f83ff285389fe4599fbb393283dde2d5e0.tar.bz2
gentoo-7288f8f83ff285389fe4599fbb393283dde2d5e0.zip
app-emacs/yaml: bump to 0.5.5
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
-rw-r--r--app-emacs/yaml/Manifest1
-rw-r--r--app-emacs/yaml/yaml-0.5.5.ebuild23
2 files changed, 24 insertions, 0 deletions
diff --git a/app-emacs/yaml/Manifest b/app-emacs/yaml/Manifest
index 2a36224d018a..faa79ed3acdf 100644
--- a/app-emacs/yaml/Manifest
+++ b/app-emacs/yaml/Manifest
@@ -1 +1,2 @@
DIST yaml-0.5.4.tar.gz 44606 BLAKE2B 42e632f6949a981075b3734f19204d20e158da3949a8c8499d09e024b208e34689e966681018ef6d2021e26bf17686abfc4600c5819cb02c1b7652e007727f10 SHA512 c7f543fff4fbb42766a7b39d7922738b61c60eab2b6504ed33681d45ef656b64610ba489787bb7a51138d66b31ff2ff4d7f046ab18d9f2c0a9cfa1839f07e0a1
+DIST yaml-0.5.5.tar.gz 44636 BLAKE2B d98c7b6cd94f80cd0f2fc1a1bea6c45615319c1a49f4712d48a00c6439660bc209ac1a597694478d4978ebf5e0bc60e3a6363ee5c0bccabb1b5bf1b2bdc8fc58 SHA512 9ab5eacc26fe44c49f52a4ab05c11e35c605b456b2f54420924388df52855b61adc1586ec7915363811a499c4c749355954e0de2c795bb2a4f51ebcb693758eb
diff --git a/app-emacs/yaml/yaml-0.5.5.ebuild b/app-emacs/yaml/yaml-0.5.5.ebuild
new file mode 100644
index 000000000000..c553097ceca3
--- /dev/null
+++ b/app-emacs/yaml/yaml-0.5.5.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit elisp
+
+DESCRIPTION="YAML parser in Emacs Lisp"
+HOMEPAGE="https://github.com/zkry/yaml.el/"
+SRC_URI="https://github.com/zkry/yaml.el/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}"/yaml.el-${PV}
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DOCS=( README.md )
+SITEFILE="50${PN}-gentoo.el"
+
+src_test() {
+ # "test/string-inflection-test.el" calls "(ert-run-tests-batch t)"
+ ${EMACS} ${EMACSFLAGS} -L . -l yaml-tests.el || die
+}