summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron Bauman <bman@gentoo.org>2020-09-17 19:32:42 -0400
committerAaron Bauman <bman@gentoo.org>2020-09-17 19:39:27 -0400
commit728fb909cf86618ebcec7e0f1e6a4dbcfc984c15 (patch)
treea5f7f03d66f2d6ecd969f710bfd7319025f1726e
parentdev-libs/stb: security cleanup (diff)
downloadgentoo-728fb909cf86618ebcec7e0f1e6a4dbcfc984c15.tar.gz
gentoo-728fb909cf86618ebcec7e0f1e6a4dbcfc984c15.tar.bz2
gentoo-728fb909cf86618ebcec7e0f1e6a4dbcfc984c15.zip
mail-filter/exim-geoip: port to EAPI=7
Signed-off-by: Aaron Bauman <bman@gentoo.org>
-rw-r--r--mail-filter/exim-geoip/exim-geoip-0.1-r1.ebuild8
1 files changed, 5 insertions, 3 deletions
diff --git a/mail-filter/exim-geoip/exim-geoip-0.1-r1.ebuild b/mail-filter/exim-geoip/exim-geoip-0.1-r1.ebuild
index 9c12f98603f6..194427736d92 100644
--- a/mail-filter/exim-geoip/exim-geoip-0.1-r1.ebuild
+++ b/mail-filter/exim-geoip/exim-geoip-0.1-r1.ebuild
@@ -1,8 +1,9 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=4
-inherit eutils flag-o-matic ltprune
+EAPI=7
+
+inherit flag-o-matic
DESCRIPTION="This is an IPv4 and IPv6 capable GeoIP dlfunc library for Exim"
HOMEPAGE="https://dist.epipe.com/exim/"
@@ -16,6 +17,7 @@ IUSE=""
DEPEND="dev-libs/geoip
mail-mta/exim[dlfunc]"
RDEPEND="${DEPEND}"
+
S="${WORKDIR}/exim-geoipv6-dlfunc-${PV}"
src_configure() {
@@ -25,5 +27,5 @@ src_configure() {
src_install() {
default
- prune_libtool_files --all
+ find "${D}" -name '*.la' -delete || die "Failed to prune libtool files"
}