summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-08-24 01:46:31 +0100
committerSam James <sam@gentoo.org>2022-08-24 01:46:31 +0100
commit72d910d7dd53fa1e24dfa51fc6df626cd214946b (patch)
treed0a43c255d52ef5e33bd1e94601ffa940fb31f32
parentapp-editors/vile: add 9.8w (diff)
downloadgentoo-72d910d7.tar.gz
gentoo-72d910d7.tar.bz2
gentoo-72d910d7.zip
app-editors/xvile: add 9.8w
Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--app-editors/xvile/Manifest1
-rw-r--r--app-editors/xvile/xvile-9.8w.ebuild48
2 files changed, 49 insertions, 0 deletions
diff --git a/app-editors/xvile/Manifest b/app-editors/xvile/Manifest
index b58629ecdc25..00935df1403b 100644
--- a/app-editors/xvile/Manifest
+++ b/app-editors/xvile/Manifest
@@ -1,2 +1,3 @@
DIST vile-9.8t.tgz 2352119 BLAKE2B fc1c75eba09e8be99945ba0d178fd150576d8108f906afb20dba265adaee9e5bea4869415d3ebceabf0b6b56c147add79e9c7e4fe34d7f4744930c3728e4a4a4 SHA512 4be4e37c7231395cae9236796073c2c3e428f1945283785a931c5d4cce94e0f970efa6634b0f9053679a00f4b4577704ea38ded2129e444b26ee9935a1c3d229
DIST vile-9.8v.tgz 2405398 BLAKE2B cd8753c57ff95c9b420026128fd19b7c689c99500da7cae91d3160dded46aa101b0cae32daeaf0377d4d72a5e526e8e4f25422bbbff2cc5ecdef10b7f04c8b39 SHA512 b752f26148bd4411ab6b31697459a16d8168f79ffad6b3509d6cf5d40611176b833e56f4bac21fe18ecdd256be467ba96ea98149daceab671002df49508eb8d2
+DIST vile-9.8w.tgz 2407322 BLAKE2B 824142c2d081db7c74ab4ce36db63e2d26e82954b32d274477f920b3519c75a249745365f7fb4f117f613c04fddd468394b4636d5f84d9f024eee3cb9c8332ba SHA512 54a96b400f479c633b917691fdab5ec5098ff1d6a6f5390c085635b4449ee7f02988e52c6b442918917455d02d5d74781ed57e4f944422576cf6532caaa446af
diff --git a/app-editors/xvile/xvile-9.8w.ebuild b/app-editors/xvile/xvile-9.8w.ebuild
new file mode 100644
index 000000000000..b3a06afe19e8
--- /dev/null
+++ b/app-editors/xvile/xvile-9.8w.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# Bump with app-editors/vile
+
+MY_P="${PN/x/}-${PV}"
+DESCRIPTION="VI Like Emacs -- yet another full-featured vi clone"
+HOMEPAGE="https://invisible-island.net/vile/"
+SRC_URI="https://invisible-island.net/archives/vile/current/${MY_P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~riscv ~sparc ~x86"
+IUSE="perl"
+
+RDEPEND="~app-editors/vile-${PV}
+ virtual/libcrypt:=
+ >=x11-libs/libX11-1.0.0
+ >=x11-libs/libXt-1.0.0
+ >=x11-libs/libICE-1.0.0
+ >=x11-libs/libSM-1.0.0
+ >=x11-libs/libXaw-1.0.1
+ >=x11-libs/libXpm-3.5.4.2
+ perl? ( dev-lang/perl:= )"
+DEPEND="${RDEPEND}
+ x11-base/xorg-proto
+ sys-devel/flex"
+BDEPEND="virtual/pkgconfig"
+
+S="${WORKDIR}"/${MY_P}
+
+src_configure() {
+ econf \
+ --disable-stripping \
+ --with-ncurses \
+ --with-pkg-config \
+ --with-x \
+ $(use_with perl)
+}
+
+src_install() {
+ dobin xvile
+ dodoc CHANGES* README doc/*.doc
+ docinto html
+ dodoc doc/*.html
+}