summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFlorian Schmaus <flow@gentoo.org>2022-02-04 16:47:14 +0100
committerFlorian Schmaus <flow@gentoo.org>2022-02-04 16:47:33 +0100
commit72e7436bcdefdff03a14eee0a42f89b6eed01b74 (patch)
tree6ffc45b26f3b05d9050e2777783ac12fdb67cb81
parentnet-misc/bridge-utils-1.7.1-r1: fix compilation on musl (diff)
downloadgentoo-72e7436bcdefdff03a14eee0a42f89b6eed01b74.tar.gz
gentoo-72e7436bcdefdff03a14eee0a42f89b6eed01b74.tar.bz2
gentoo-72e7436bcdefdff03a14eee0a42f89b6eed01b74.zip
dev-util/cdecl: initial import, migrated from ::guru
Signed-off-by: Florian Schmaus <flow@gentoo.org>
-rw-r--r--dev-util/cdecl/Manifest1
-rw-r--r--dev-util/cdecl/cdecl-11.11.ebuild36
-rw-r--r--dev-util/cdecl/metadata.xml13
3 files changed, 50 insertions, 0 deletions
diff --git a/dev-util/cdecl/Manifest b/dev-util/cdecl/Manifest
new file mode 100644
index 000000000000..4be916cd12de
--- /dev/null
+++ b/dev-util/cdecl/Manifest
@@ -0,0 +1 @@
+DIST cdecl-11.11.tar.gz 765023 BLAKE2B c8847740339f0d9c977c43d9cbf4ea05061a428cef47bfa0cbf908548162eb328483a477e86b60525e39c3e59dc32a21fb093c3afecafb17da1943945c875d98 SHA512 32b95c51af4b1eaa2833777c3a63a807d63f754a766a5dbb215508c11bca99be0b3d3ef260b6bc52a9cbae7f99d82c27fe034f4c9acfcb0447ba1d1c9dba14f4
diff --git a/dev-util/cdecl/cdecl-11.11.ebuild b/dev-util/cdecl/cdecl-11.11.ebuild
new file mode 100644
index 000000000000..7e715e918523
--- /dev/null
+++ b/dev-util/cdecl/cdecl-11.11.ebuild
@@ -0,0 +1,36 @@
+# Copyright 2021-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION='Composing and deciphering C (or C++) declarations or casts, aka "gibberish."'
+HOMEPAGE="https://github.com/paul-j-lucas/cdecl"
+SRC_URI="https://github.com/paul-j-lucas/${PN}/archive/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+readline"
+
+DEPEND="
+ sys-libs/ncurses:0=
+ readline? ( sys-libs/readline:0= )
+"
+RDEPEND="${DEPEND}"
+BDEPEND="
+ sys-devel/bison
+ sys-devel/flex
+"
+
+S="${WORKDIR}/${PN}-${P}"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf $(use_with readline)
+}
diff --git a/dev-util/cdecl/metadata.xml b/dev-util/cdecl/metadata.xml
new file mode 100644
index 000000000000..c51407642daa
--- /dev/null
+++ b/dev-util/cdecl/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <name>Florian Schmaus</name>
+ <email>flow@gentoo.org</email>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">paul-j-lucas/cdecl</remote-id>
+ <bugs-to>https://github.com/paul-j-lucas/cdecl/issues</bugs-to>
+ <changelog>https://github.com/paul-j-lucas/cdecl/releases</changelog>
+ </upstream>
+</pkgmetadata>