summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Wright <gienah@gentoo.org>2020-10-13 17:06:20 +1100
committerMark Wright <gienah@gentoo.org>2020-10-13 23:53:30 +1100
commit72e9d070bbdb2ba684cba44e067417bc0da0c91a (patch)
tree2cadee9e461e4e59134a762b2694e702b4b730d3
parentdev-ml/opam-core: Dependency of dev-ml/opam-format (diff)
downloadgentoo-72e9d070bbdb2ba684cba44e067417bc0da0c91a.tar.gz
gentoo-72e9d070bbdb2ba684cba44e067417bc0da0c91a.tar.bz2
gentoo-72e9d070bbdb2ba684cba44e067417bc0da0c91a.zip
dev-ml/opam-file-format: Dependency of dev-ml/opam-client
Co-Author: Alexis Ballier <aballier@gentoo.org> Package-Manager: Portage-3.0.8, Repoman-3.0.1 Signed-off-by: Mark Wright <gienah@gentoo.org>
-rw-r--r--dev-ml/opam-file-format/Manifest1
-rw-r--r--dev-ml/opam-file-format/metadata.xml11
-rw-r--r--dev-ml/opam-file-format/opam-file-format-2.1.0.ebuild30
3 files changed, 42 insertions, 0 deletions
diff --git a/dev-ml/opam-file-format/Manifest b/dev-ml/opam-file-format/Manifest
new file mode 100644
index 000000000000..a0c353046409
--- /dev/null
+++ b/dev-ml/opam-file-format/Manifest
@@ -0,0 +1 @@
+DIST opam-file-format-2.1.0.tar.gz 23233 BLAKE2B 34d832c5ee13a0db43e77f3b33e7728faa7dccccc8daed50dca89630ab11d6f307413b8fecfef5a7c3e0f7ea04ef27105c8f42d8b5227d2587bdc2c2defe59d3 SHA512 b948545497de0386457a9b5772924572249e38164aa49d5ab2ac9442d1231a56a3b8132a95197d74cbbe34336a7edc04eaca351a8763c4a009a512085ca0ab25
diff --git a/dev-ml/opam-file-format/metadata.xml b/dev-ml/opam-file-format/metadata.xml
new file mode 100644
index 000000000000..bd15aa2f0672
--- /dev/null
+++ b/dev-ml/opam-file-format/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>gienah@gentoo.org</email>
+ <name>Mark Wright</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">ocaml/opam-file-format</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ml/opam-file-format/opam-file-format-2.1.0.ebuild b/dev-ml/opam-file-format/opam-file-format-2.1.0.ebuild
new file mode 100644
index 000000000000..3adeb20ac869
--- /dev/null
+++ b/dev-ml/opam-file-format/opam-file-format-2.1.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit findlib
+
+MY_PV="${PV/_beta/-beta}"
+MY_PV="${MY_PV/_rc/-rc}"
+S="${WORKDIR}/${PN}-${MY_PV}"
+
+DESCRIPTION="Parser and printer for the opam file syntax"
+HOMEPAGE="https://github.com/ocaml/opam-file-format"
+SRC_URI="https://github.com/ocaml/opam-file-format/archive/${MY_PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~x86"
+IUSE="+ocamlopt"
+
+DEPEND="dev-lang/ocaml:=[ocamlopt?]"
+RDEPEND="${DEPEND}"
+
+src_compile() {
+ emake byte $(usex ocamlopt native "")
+}
+
+src_install() {
+ emake DESTDIR="${D}" PREFIX="${EPREFIX}/usr" LIBDIR="$(ocamlc -where)" install
+}