summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Pagano <mpagano@gentoo.org>2021-06-20 18:29:53 -0400
committerMike Pagano <mpagano@gentoo.org>2021-06-20 18:29:53 -0400
commit72ec2529ccb83d961127640fdc4ba8cd918774a9 (patch)
tree169b8398dfdd5a548c9b941b060359fd2cc6ab91
parentmedia-sound/pulseaudio: add initial PA 14.x ebuild (diff)
downloadgentoo-72ec2529.tar.gz
gentoo-72ec2529.tar.bz2
gentoo-72ec2529.zip
sys-kernel/git-sources: Linux patch 5.13-rc7
Package-Manager: Portage-3.0.20, Repoman-3.0.2 Signed-off-by: Mike Pagano <mpagano@gentoo.org>
-rw-r--r--sys-kernel/git-sources/Manifest1
-rw-r--r--sys-kernel/git-sources/git-sources-5.13_rc7.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/sys-kernel/git-sources/Manifest b/sys-kernel/git-sources/Manifest
index d51b2d60dbd2..19cc0b035e69 100644
--- a/sys-kernel/git-sources/Manifest
+++ b/sys-kernel/git-sources/Manifest
@@ -5,3 +5,4 @@ DIST patch-5.13-rc3.patch 60916953 BLAKE2B 1a1a40b91cbe8ed65151931b1e309068c69ef
DIST patch-5.13-rc4.patch 61427853 BLAKE2B 7ce34ed0d43f79a193e549208114e0d5c648c965ed584b84959535867088c083227784b3db6b2072b238f73f10c39ce5e4ea8451dbeb107e0c24bcbb7ccac988 SHA512 39d352e6a32c47006492667aa552b92ca45a5a5919443dc00ee1b7ca2947398a4a2db59185df9e779a1b1a75ba93ea3d88ac07005e3072f24b31d1a6284bc131
DIST patch-5.13-rc5.patch 61681306 BLAKE2B 541567d285b56080a572b3b62118288a4f1d817152512a89483043973bad89a64e27354a174b5ec6809df58b992e2a001c2e50d8d330ba356e41452f3304ed1e SHA512 47e03e9825c6ecc37778050319a58b5081ed562e2f8aa1bdc74bfb3a59422d2a81d3267603e5cdcad87dffe9ea2e434c453d4eb8a022fb9b12a3e8bd9ebf343f
DIST patch-5.13-rc6.patch 61861957 BLAKE2B 95c185f46705f1e55fcd0d54c72b5520080780dcae087f1ab1ff195c62b5ad4a0a318c4094c3c942e85889808341fdce7aca8a823a4c2f4320c671217ea07b65 SHA512 8fb742686847e0fa0b920af523c8dfcc6fd4af54abf68ead6dc4105911d18229431079b03e2190aafe2cd2322176138ece51e514a0f9b6049e4026fb2e0440d4
+DIST patch-5.13-rc7.patch 62091807 BLAKE2B 1aad8503208b9d77033c3259b867a34507710c3d03f9980c9e451b7ea04e93a450ebdce4282c8b416403d53a099c6ea236904556a0d9b1fc59fe19019b00b3e3 SHA512 af9c1f41dec5d0d186d92f1a905338511c94fa0e7accc994a0fb0bd95d096a5a6a10952eb7f22362987d74977e535cd9ff88c3d22a07971366cbc1c539b92ead
diff --git a/sys-kernel/git-sources/git-sources-5.13_rc7.ebuild b/sys-kernel/git-sources/git-sources-5.13_rc7.ebuild
new file mode 100644
index 000000000000..5279e1b05efd
--- /dev/null
+++ b/sys-kernel/git-sources/git-sources-5.13_rc7.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+UNIPATCH_STRICTORDER="yes"
+K_NOUSENAME="yes"
+K_NOSETEXTRAVERSION="yes"
+K_NOUSEPR="yes"
+K_SECURITY_UNSUPPORTED="1"
+K_BASE_VER="5.12"
+K_EXP_GENPATCHES_NOUSE="1"
+K_FROM_GIT="yes"
+ETYPE="sources"
+CKV="${PVR/-r/-git}"
+
+# only use this if it's not an _rc/_pre release
+[ "${PV/_pre}" == "${PV}" ] && [ "${PV/_rc}" == "${PV}" ] && OKV="${PV}"
+inherit kernel-2
+detect_version
+
+DESCRIPTION="The very latest -git version of the Linux kernel"
+HOMEPAGE="https://www.kernel.org"
+SRC_URI="${KERNEL_URI}"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86"
+IUSE=""
+
+K_EXTRAEINFO="This kernel is not supported by Gentoo due to its unstable and
+experimental nature. If you have any issues, try a matching vanilla-sources
+ebuild -- if the problem is not there, please contact the upstream kernel
+developers at https://bugzilla.kernel.org and on the linux-kernel mailing list to
+report the problem so it can be fixed in time for the next kernel release."
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ >=sys-devel/patch-2.7.5"
+
+pkg_postinst() {
+ postinst_sources
+}