summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-01-08 18:47:46 +0200
committerArthur Zamarin <arthurzam@gentoo.org>2022-01-08 18:57:07 +0200
commit72f585909a723038432a599d409627bbe57233c5 (patch)
tree2e9b4a8c1cb2364061285394c1b33e6449e9116a
parentdev-python/weasyprint: add 54.0 (diff)
downloadgentoo-72f58590.tar.gz
gentoo-72f58590.tar.bz2
gentoo-72f58590.zip
dev-python/hypothesis: add 6.35.0
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
-rw-r--r--dev-python/hypothesis/Manifest1
-rw-r--r--dev-python/hypothesis/hypothesis-6.35.0.ebuild66
2 files changed, 67 insertions, 0 deletions
diff --git a/dev-python/hypothesis/Manifest b/dev-python/hypothesis/Manifest
index 4a839711e785..a6441b835ebf 100644
--- a/dev-python/hypothesis/Manifest
+++ b/dev-python/hypothesis/Manifest
@@ -4,3 +4,4 @@ DIST hypothesis-python-6.32.1.tar.gz 9176925 BLAKE2B 0b57c8b46b766055a19c8831620
DIST hypothesis-python-6.33.0.tar.gz 9177426 BLAKE2B ad1b1a358345f9b92bf41cee196c7bba5374054c84b7ca96500cf41b095e7ae6df12499dcb3b656907df30b360d167630d3d4c640c9d5d903125158af6db3089 SHA512 0165b7c431980d7758be50e834dbe04356478590d5fc54656ea9d31508bbae81f9fbb53b38178862b2d4959e17fa3564bc6971d466ba95555c8e80a6fb208639
DIST hypothesis-python-6.34.1.tar.gz 9178792 BLAKE2B 72cbb1b372fb23da8ecf4eb8355cb054216c78b6464b5ddbc7ee5534652d69e4f3cc094241c0434bc0d80cc555c87699504f87bcf4659724f77d70deaa19b871 SHA512 234b8a814994b0e93cae24233cc30ab8eba853a081d4cce4309b4af5e13234a3de8d704f3255cce11195603645c2641fa1985529d64631df90a61cfd1c4a7f06
DIST hypothesis-python-6.34.2.tar.gz 9178843 BLAKE2B 24bbc19ea5c207880d577a3c451f6e90c4b124a934aa1cd103c11ec77cbb5076d75e3860abd2b9bd2fc75640ba562b81d3fa038cc7752109625990e0ac0e1039 SHA512 a03233a2b84b1e009ad246663b0c7f6b56f2c04d08d69297ff50b02b8af292fdee37f877ca2f709e6ef64192d31e3d9bf18f78a6f5c92b8f03bf04ba398d063c
+DIST hypothesis-python-6.35.0.tar.gz 9178905 BLAKE2B 7cb55da84b979d8a075361674bbfa00cfeb5276e0ae25c153794fd876d1f65c7a88c5cc16e8b0c085560be937be14a113ba4854b734808b592f3d7c0be30215f SHA512 b390272ac471b23d8de1414cb7e2fd9d814318bc1063e4ad2bb2d61ba3b3af0c92701fa7a737117dc894a71e8d0473f52c11caf70fbb35d0837a4927537daaf5
diff --git a/dev-python/hypothesis/hypothesis-6.35.0.ebuild b/dev-python/hypothesis/hypothesis-6.35.0.ebuild
new file mode 100644
index 000000000000..0d2f0a38a35b
--- /dev/null
+++ b/dev-python/hypothesis/hypothesis-6.35.0.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+PYTHON_REQ_USE="threads(+),sqlite"
+
+inherit distutils-r1 multiprocessing optfeature
+
+DESCRIPTION="A library for property based testing"
+HOMEPAGE="https://github.com/HypothesisWorks/hypothesis https://pypi.org/project/hypothesis/"
+SRC_URI="https://github.com/HypothesisWorks/${PN}/archive/${PN}-python-${PV}.tar.gz"
+S="${WORKDIR}/${PN}-${PN}-python-${PV}/${PN}-python"
+
+LICENSE="MPL-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+IUSE="cli"
+
+RDEPEND="
+ >=dev-python/attrs-19.2.0[${PYTHON_USEDEP}]
+ >=dev-python/sortedcontainers-2.1.0[${PYTHON_USEDEP}]
+ cli? (
+ $(python_gen_cond_dep '
+ dev-python/black[${PYTHON_USEDEP}]
+ dev-python/click[${PYTHON_USEDEP}]
+ ' python3_{8..9})
+ )
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pexpect[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ !!<dev-python/typing-3.7.4.1
+ )
+"
+
+distutils_enable_tests --install pytest
+
+python_prepare() {
+ if ! use cli || ! has "${EPYTHON}" python3.{8..9}; then
+ sed -i -e '/console_scripts/d' setup.py || die
+ fi
+}
+
+python_test() {
+ # subtests are broken by warnings from random plugins
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ local -x PYTEST_PLUGINS=xdist.plugin,pytest_forked,_hypothesis_pytestplugin
+
+ distutils_install_for_testing
+ epytest tests/cover tests/pytest tests/quality \
+ -x \
+ -n "$(makeopts_jobs "${MAKEOPTS}" "$(get_nproc)")"
+}
+
+pkg_postinst() {
+ optfeature "datetime support" dev-python/pytz
+ optfeature "dateutil support" dev-python/python-dateutil
+ optfeature "numpy support" dev-python/numpy
+ optfeature "django support" dev-python/django dev-python/pytz
+ optfeature "pandas support" dev-python/pandas
+ optfeature "pytest support" dev-python/pytest
+}