summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2020-12-02 22:17:59 +0100
committerConrad Kostecki <conikost@gentoo.org>2020-12-02 22:22:43 +0100
commit72f68d5a58d652b5d18603b4b82263caa6169e9e (patch)
treeada58c03a039114932f3c0684870e4b0b55cc38c
parentgames-fps/eduke32: drop old version (diff)
downloadgentoo-72f68d5a.tar.gz
gentoo-72f68d5a.tar.bz2
gentoo-72f68d5a.zip
sys-auth/AusweisApp2: bump to version 1.22.0
Package-Manager: Portage-3.0.9, Repoman-3.0.2 Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
-rw-r--r--sys-auth/AusweisApp2/AusweisApp2-1.22.0.ebuild48
-rw-r--r--sys-auth/AusweisApp2/Manifest1
2 files changed, 49 insertions, 0 deletions
diff --git a/sys-auth/AusweisApp2/AusweisApp2-1.22.0.ebuild b/sys-auth/AusweisApp2/AusweisApp2-1.22.0.ebuild
new file mode 100644
index 000000000000..869fe92ebae0
--- /dev/null
+++ b/sys-auth/AusweisApp2/AusweisApp2-1.22.0.ebuild
@@ -0,0 +1,48 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake xdg-utils
+
+DESCRIPTION="Official authentication app for German ID cards and residence permits"
+HOMEPAGE="https://www.ausweisapp.bund.de/"
+SRC_URI="https://github.com/Governikus/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="EUPL-1.2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND="
+ dev-qt/linguist-tools:5
+ virtual/pkgconfig"
+
+RDEPEND="
+ dev-libs/openssl:0=
+ dev-qt/qtconcurrent:5
+ dev-qt/qtcore:5
+ dev-qt/qtdeclarative:5
+ dev-qt/qtgui:5
+ dev-qt/qtnetwork:5
+ dev-qt/qtquickcontrols2:5
+ dev-qt/qtsvg:5
+ dev-qt/qtwebsockets:5[qml]
+ dev-qt/qtwidgets:5
+ net-libs/http-parser:0=
+ sys-apps/pcsc-lite
+ virtual/udev"
+
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ local mycmakeargs=( -DBUILD_SHARED_LIBS=OFF )
+ cmake_src_configure
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}
diff --git a/sys-auth/AusweisApp2/Manifest b/sys-auth/AusweisApp2/Manifest
index 62ea43e7f1f5..76cb4ec17c34 100644
--- a/sys-auth/AusweisApp2/Manifest
+++ b/sys-auth/AusweisApp2/Manifest
@@ -1 +1,2 @@
DIST AusweisApp2-1.20.2.tar.gz 10110603 BLAKE2B cb3063decb3a5aacbc1d7690c58566914776032cd305d29f6352df659a27dcf81e07550613809849822ee20d7aaa467303f33602c40aaa39a99501daa7d1e887 SHA512 4a968d3d9043f9eba5927f049155e203448a27034f0c051c10fbaa262bb7b4257c5a6de4763c1fa470a1c46d51bf67636f14c136c7e7c8038eab7e929dcb38c2
+DIST AusweisApp2-1.22.0.tar.gz 10845370 BLAKE2B 2b35bece49c96f7aca391a918539115351737b9cc6bcb913121f7f44db7ff88fb615bd3a3822d7d5670e83c81ac7c409fffb1696d6dd9310fdbd595c3f7fa88f SHA512 c2340625f4792afccde2f09d54e050efed0e78a7d921f545ec73f4bf23746b7b0c422fffbc87822abe2dc8b69a8439615f3d43179a98a64fa4165503c2e74079