summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Mair-Keimberger <mmk@levelnine.at>2023-07-05 10:30:22 +0200
committerConrad Kostecki <conikost@gentoo.org>2023-07-05 22:48:58 +0200
commit730ebd5f8e7a565f46e411c173317ca336a34915 (patch)
tree8da6bcbcd3329c17031d1b27a2d209bdc94edc8a
parentwww-client/netsurf: clean up build flags and depencencies (live ebuild). (diff)
downloadgentoo-730ebd5f8e7a565f46e411c173317ca336a34915.tar.gz
gentoo-730ebd5f8e7a565f46e411c173317ca336a34915.tar.bz2
gentoo-730ebd5f8e7a565f46e411c173317ca336a34915.zip
dev-util/lockrun: EAPI8 bump
Signed-off-by: Michael Mair-Keimberger <mmk@levelnine.at> Closes: https://github.com/gentoo/gentoo/pull/31761 Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
-rw-r--r--dev-util/lockrun/lockrun-20120508-r2.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-util/lockrun/lockrun-20120508-r2.ebuild b/dev-util/lockrun/lockrun-20120508-r2.ebuild
new file mode 100644
index 000000000000..b102465e2395
--- /dev/null
+++ b/dev-util/lockrun/lockrun-20120508-r2.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="Lockrun - runs cronjobs with overrun protection"
+HOMEPAGE="http://www.unixwiz.net/tools/lockrun.html"
+S="${WORKDIR}"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~x86"
+
+src_unpack() {
+ cp -v "${FILESDIR}"/${PN}.c-${PV} "${S}"/${PN}.c || die
+ cp -v "${FILESDIR}"/${PN}.c-${PV} "${S}"/README || die
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" ${PN}
+ sed -i README -e '60q;s|^ \*||g' || die
+}
+
+src_install() {
+ dobin ${PN}
+ einstalldocs
+}