summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2022-01-20 12:13:41 -0500
committerIonen Wolkens <ionen@gentoo.org>2022-01-20 13:10:05 -0500
commit732752644bee2ef95565cd0533c89ee1da2fa947 (patch)
treeeeddae18e8cd6675dd7fa5f987ebeb217f75a9b4
parentnet-wireless/kismet: add 2022.01.2 (diff)
downloadgentoo-73275264.tar.gz
gentoo-73275264.tar.bz2
gentoo-73275264.zip
www-client/qutebrowser: tidy live ebuild and use pep517
QtWebKit test was fixed to properly ignore that we don't have it, albeit may still be present in a potential 2.4.1 release on a separate branch. Remove typing-extensions, was only needed for <python-3.8. Also move asciidoc dep to live-only (it is getting tempting to just maintain live and releases separately given the increasing amount of PV == 9999 blocks, which may get worse given considering adding verify-sig support too). Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
-rw-r--r--www-client/qutebrowser/qutebrowser-9999.ebuild26
1 files changed, 12 insertions, 14 deletions
diff --git a/www-client/qutebrowser/qutebrowser-9999.ebuild b/www-client/qutebrowser/qutebrowser-9999.ebuild
index f3fcf16be9a4..6e52913c8194 100644
--- a/www-client/qutebrowser/qutebrowser-9999.ebuild
+++ b/www-client/qutebrowser/qutebrowser-9999.ebuild
@@ -1,9 +1,10 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
DISTUTILS_SINGLE_IMPL=1
+DISTUTILS_USE_PEP517=setuptools
PYTHON_COMPAT=( python3_{8..10} )
inherit distutils-r1 optfeature xdg
@@ -27,20 +28,17 @@ RDEPEND="
dev-qt/qtgui:5[png]
$(python_gen_cond_dep 'dev-python/importlib_resources[${PYTHON_USEDEP}]' python3_8)
$(python_gen_cond_dep '
- >=dev-python/colorama-0.4.4[${PYTHON_USEDEP}]
+ dev-python/colorama[${PYTHON_USEDEP}]
>=dev-python/jinja-3.0.2[${PYTHON_USEDEP}]
>=dev-python/markupsafe-2.0.1[${PYTHON_USEDEP}]
dev-python/pygments[${PYTHON_USEDEP}]
dev-python/PyQt5[${PYTHON_USEDEP},dbus,declarative,multimedia,gui,network,opengl,printsupport,sql,widgets]
dev-python/PyQtWebEngine[${PYTHON_USEDEP}]
- >=dev-python/pyyaml-5.4.1[${PYTHON_USEDEP},libyaml(+)]
- >=dev-python/typing-extensions-3.10.0.2[${PYTHON_USEDEP}]
- >=dev-python/zipp-3.6.0[${PYTHON_USEDEP}]
- adblock? ( >=dev-python/adblock-0.5.0[${PYTHON_USEDEP}] )
- ')
+ dev-python/pyyaml[${PYTHON_USEDEP},libyaml(+)]
+ dev-python/zipp[${PYTHON_USEDEP}]
+ adblock? ( dev-python/adblock[${PYTHON_USEDEP}] )')
widevine? ( www-plugins/chrome-binary-plugins )"
BDEPEND="
- app-text/asciidoc
$(python_gen_cond_dep '
test? (
dev-python/beautifulsoup4[${PYTHON_USEDEP}]
@@ -53,8 +51,8 @@ BDEPEND="
dev-python/pytest-rerunfailures[${PYTHON_USEDEP}]
dev-python/pytest-xvfb[${PYTHON_USEDEP}]
dev-python/tldextract[${PYTHON_USEDEP}]
- )
- ')"
+ )')"
+[[ ${PV} != 9999 ]] || BDEPEND+=" app-text/asciidoc"
distutils_enable_tests pytest
@@ -62,10 +60,12 @@ python_prepare_all() {
distutils-r1_python_prepare_all
if use widevine; then
- sed "/yield from _qtwebengine_settings_args/a\ yield '--widevine-path=${EPREFIX}/usr/$(get_libdir)/chromium-browser/WidevineCdm/_platform_specific/linux_x64/libwidevinecdm.so'" \
+ local widevine=${EPREFIX}/usr/$(get_libdir)/chromium-browser/WidevineCdm/_platform_specific/linux_x64/libwidevinecdm.so
+ sed "/yield from _qtwebengine_settings_args/a\ yield '--widevine-path=${widevine}'" \
-i ${PN}/config/qtargs.py || die
fi
+ # let eclass handle python
sed -i '/setup.py/d' misc/Makefile || die
[[ ${PV} != 9999 ]] || ${EPYTHON} scripts/asciidoc2html.py || die
@@ -88,8 +88,6 @@ python_test() {
# tests that don't know about our newer qtwebengine
tests/unit/browser/webengine/test_webenginedownloads.py::TestDataUrlWorkaround
tests/unit/utils/test_version.py::TestChromiumVersion
- # needs qtwebkit and isn't skipped by default
- tests/unit/config/test_websettings.py::test_config_init
# may misbehave depending on installed old python versions
tests/unit/misc/test_checkpyver.py::test_old_python
# bug 819393
@@ -102,7 +100,7 @@ python_test() {
}
python_install_all() {
- emake -f misc/Makefile DESTDIR="${D}" PREFIX="${EPREFIX}/usr" install
+ emake -f misc/Makefile DESTDIR="${D}" PREFIX="${EPREFIX}"/usr install
rm "${ED}"/usr/share/${PN}/scripts/{mkvenv,utils}.py || die
fperms -x /usr/share/${PN}/{scripts/cycle-inputs.js,userscripts/README.md}