summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-05-03 10:01:19 +0200
committerMichał Górny <mgorny@gentoo.org>2022-05-03 10:26:07 +0200
commit73303afadc0ab41779778c5b9d97fac00232c408 (patch)
treeb98794ce5228d8d83c14a7afcce16022aea92854
parentdev-python/suds-community: Bump to 1.1.1 (diff)
downloadgentoo-73303afa.tar.gz
gentoo-73303afa.tar.bz2
gentoo-73303afa.zip
dev-python/PyPDF2: Bump to 1.27.12
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/PyPDF2/Manifest1
-rw-r--r--dev-python/PyPDF2/PyPDF2-1.27.12.ebuild51
2 files changed, 52 insertions, 0 deletions
diff --git a/dev-python/PyPDF2/Manifest b/dev-python/PyPDF2/Manifest
index 9067657b017d..51f0ebfd945a 100644
--- a/dev-python/PyPDF2/Manifest
+++ b/dev-python/PyPDF2/Manifest
@@ -1,4 +1,5 @@
DIST PyPDF2-1.27.11.gh.tar.gz 3431028 BLAKE2B 4917d40f3b896e086ea1deac43b9a3d4391d758ff2eb4e2ab731d632d24478781ca862ceffd707b26ae7bb0295c922089ca9a9a90e0878d2e0aef466d1464346 SHA512 cd1578295fafd480016b838a865a658e8996c04a0e22817f8e45d8c00dbdf6dcac2e8c80a8de878e8db4a2984022382f74e8a56af5e305acfb8e3de5f965d207
+DIST PyPDF2-1.27.12.gh.tar.gz 3430850 BLAKE2B a0cb344f616d628b7c39dc360234057ce68595ffa554a8588990ef0a1239ade2db6415caefb84bc058d89067ed04ba66ba149f6f106bbf9a55a13f523dd826fc SHA512 ee00c975881b7e6716656b1cecb83c3e1f7bffa4ed9fb0d8c8be45c7d951b2b79f0be4f9098569bad783703fbc00f0797e73b970b02adad1ed3a4cf3b6ab7b73
DIST PyPDF2-1.27.5.gh.tar.gz 2053469 BLAKE2B 1a01289145574a4551f1fa237e4c790dd866088787f5bc9afb529ea99424f4d211f1913737cf4a2c744ceae90568ca26612cc4956ff1eda5840624e41df76d78 SHA512 c1f77c7ea46e866da104cf05421ccf15870db07923ff5860a6b44c944d599b38e98d33d6042a155b0698ecd100d1c6f57aa7bb8904dd08e679f6560a578d4488
DIST PyPDF2-1.27.6.gh.tar.gz 2092950 BLAKE2B 786d5102275d6c04628d76fd0225d453aa8f74cb0a6e135f3d56ed1143c114144aa9daef17e5971ce9e4c14cc01016125107717296d76cf7eb34c1cadbdd42cd SHA512 bf1c60453e6a98a50c382cf967fc7aa1fb8dffc14d426f97bc0e41c34a6534930849fe053c8debe585b3877eadca9f8b43f803b1f01586f6c693a1eefe43e3dd
DIST PyPDF2-1.27.7.gh.tar.gz 2093013 BLAKE2B 5637094972228ad1a5790f36f71e3fd8a694c9fd99bad7874a03f299ca0bb6198064f6756552cac41127fd67a827ca191e6de56281b25c13629a99edcdac7685 SHA512 dbcb944f3bafb0c0e81842e92e8a72609c85c271eba83841ee5bc901119178a6a4ff503a4796014854a75137b9f8f25a245d55a550e770b9f78daf8e1e92dcba
diff --git a/dev-python/PyPDF2/PyPDF2-1.27.12.ebuild b/dev-python/PyPDF2/PyPDF2-1.27.12.ebuild
new file mode 100644
index 000000000000..0314e035bd9b
--- /dev/null
+++ b/dev-python/PyPDF2/PyPDF2-1.27.12.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+SAMPLE_COMMIT=41b5cd4f774f8fbd8ac42d93b9962f0376352a15
+DESCRIPTION="Python library to work with PDF files"
+HOMEPAGE="
+ https://pypi.org/project/PyPDF2/
+ https://github.com/py-pdf/PyPDF2/
+"
+SRC_URI="
+ https://github.com/py-pdf/PyPDF2/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+ test? (
+ https://github.com/py-pdf/sample-files/archive/${SAMPLE_COMMIT}.tar.gz
+ -> ${PN}-sample-files-${SAMPLE_COMMIT}.tar.gz
+ )
+"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86"
+IUSE="examples"
+
+BDEPEND="
+ dev-python/pillow[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+src_unpack() {
+ default
+ if use test; then
+ mv "sample-files-${SAMPLE_COMMIT}"/* "${P}"/sample-files/ || die
+ fi
+}
+
+src_install() {
+ if use examples; then
+ docinto examples
+ dodoc -r Sample_Code/.
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+ distutils-r1_src_install
+}