summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-12-28 17:55:46 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2019-12-29 14:22:56 +0100
commit7333792fb2b8eec921d892e69bcbc8ec06176618 (patch)
tree7aae70a2da900231dbcb3173faae509b4a9ac276
parentsci-biology/biopython: Drop python2_7 (diff)
downloadgentoo-7333792f.tar.gz
gentoo-7333792f.tar.bz2
gentoo-7333792f.zip
sys-cluster/cinder: Drop python2_7
Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
-rw-r--r--sys-cluster/cinder/cinder-13.0.7.ebuild3
-rw-r--r--sys-cluster/cinder/cinder-14.0.1.ebuild3
-rw-r--r--sys-cluster/cinder/cinder-15.0.0.ebuild3
-rw-r--r--sys-cluster/cinder/cinder-2018.2.9999.ebuild3
-rw-r--r--sys-cluster/cinder/cinder-2019.1.9999.ebuild3
-rw-r--r--sys-cluster/cinder/cinder-2019.2.9999.ebuild4
6 files changed, 6 insertions, 13 deletions
diff --git a/sys-cluster/cinder/cinder-13.0.7.ebuild b/sys-cluster/cinder/cinder-13.0.7.ebuild
index 4c8eb939d671..54947395723c 100644
--- a/sys-cluster/cinder/cinder-13.0.7.ebuild
+++ b/sys-cluster/cinder/cinder-13.0.7.ebuild
@@ -2,8 +2,8 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=6
-PYTHON_COMPAT=( python2_7 python3_{5,6} )
+PYTHON_COMPAT=( python3_{5,6} )
inherit distutils-r1 eutils linux-info user
DESCRIPTION="Cinder is the OpenStack Block storage service, a spin out of nova-volumes"
@@ -38,7 +38,6 @@ RDEPEND="
!~dev-python/Babel-2.4.0[${PYTHON_USEDEP}]
>=dev-python/decorator-3.4.0[${PYTHON_USEDEP}]
>=dev-python/defusedxml-0.5.0[${PYTHON_USEDEP}]
- dev-python/enum34[$(python_gen_usedep 'python2_7')]
>=dev-python/eventlet-0.18.4[${PYTHON_USEDEP}]
!~dev-python/eventlet-0.20.1[${PYTHON_USEDEP}]
>=dev-python/greenlet-0.4.1[${PYTHON_USEDEP}]
diff --git a/sys-cluster/cinder/cinder-14.0.1.ebuild b/sys-cluster/cinder/cinder-14.0.1.ebuild
index fda10c627766..13f95db99b4c 100644
--- a/sys-cluster/cinder/cinder-14.0.1.ebuild
+++ b/sys-cluster/cinder/cinder-14.0.1.ebuild
@@ -2,8 +2,8 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python2_7 python3_{5,6,7} )
+PYTHON_COMPAT=( python3_{5,6,7} )
inherit distutils-r1 eutils linux-info user
DESCRIPTION="Cinder is the OpenStack Block storage service, a spin out of nova-volumes"
@@ -36,7 +36,6 @@ RDEPEND="
${CDEPEND}
>=dev-python/decorator-3.4.0[${PYTHON_USEDEP}]
>=dev-python/defusedxml-0.5.0[${PYTHON_USEDEP}]
- dev-python/enum34[$(python_gen_usedep 'python2_7')]
>=dev-python/eventlet-0.18.4[${PYTHON_USEDEP}]
!~dev-python/eventlet-0.20.1[${PYTHON_USEDEP}]
>=dev-python/greenlet-0.4.1[${PYTHON_USEDEP}]
diff --git a/sys-cluster/cinder/cinder-15.0.0.ebuild b/sys-cluster/cinder/cinder-15.0.0.ebuild
index 1debd3eab15e..6b69bfb292a1 100644
--- a/sys-cluster/cinder/cinder-15.0.0.ebuild
+++ b/sys-cluster/cinder/cinder-15.0.0.ebuild
@@ -2,8 +2,8 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python2_7 python3_{5,6,7} )
+PYTHON_COMPAT=( python3_{5,6,7} )
inherit distutils-r1 eutils linux-info user
DESCRIPTION="Cinder is the OpenStack Block storage service, a spin out of nova-volumes"
@@ -36,7 +36,6 @@ RDEPEND="
${CDEPEND}
>=dev-python/decorator-3.4.0[${PYTHON_USEDEP}]
>=dev-python/defusedxml-0.5.0[${PYTHON_USEDEP}]
- $(python_gen_cond_dep 'dev-python/enum34[${PYTHON_USEDEP}]' 'python2_7')
>=dev-python/eventlet-0.22.0[${PYTHON_USEDEP}]
!~dev-python/eventlet-0.23.0[${PYTHON_USEDEP}]
!~dev-python/eventlet-0.25.0[${PYTHON_USEDEP}]
diff --git a/sys-cluster/cinder/cinder-2018.2.9999.ebuild b/sys-cluster/cinder/cinder-2018.2.9999.ebuild
index 23e3164d8658..8629b837e15d 100644
--- a/sys-cluster/cinder/cinder-2018.2.9999.ebuild
+++ b/sys-cluster/cinder/cinder-2018.2.9999.ebuild
@@ -2,8 +2,8 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=6
-PYTHON_COMPAT=( python2_7 python3_{5,6} )
+PYTHON_COMPAT=( python3_{5,6} )
inherit distutils-r1 eutils linux-info user
DESCRIPTION="Cinder is the OpenStack Block storage service, a spin out of nova-volumes"
@@ -38,7 +38,6 @@ RDEPEND="
!~dev-python/Babel-2.4.0[${PYTHON_USEDEP}]
>=dev-python/decorator-3.4.0[${PYTHON_USEDEP}]
>=dev-python/defusedxml-0.5.0[${PYTHON_USEDEP}]
- dev-python/enum34[$(python_gen_usedep 'python2_7')]
>=dev-python/eventlet-0.18.4[${PYTHON_USEDEP}]
!~dev-python/eventlet-0.20.1[${PYTHON_USEDEP}]
>=dev-python/greenlet-0.4.1[${PYTHON_USEDEP}]
diff --git a/sys-cluster/cinder/cinder-2019.1.9999.ebuild b/sys-cluster/cinder/cinder-2019.1.9999.ebuild
index bf4f9da51b43..d741fd9132cc 100644
--- a/sys-cluster/cinder/cinder-2019.1.9999.ebuild
+++ b/sys-cluster/cinder/cinder-2019.1.9999.ebuild
@@ -2,8 +2,8 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python2_7 python3_{5,6,7} )
+PYTHON_COMPAT=( python3_{5,6,7} )
inherit distutils-r1 eutils linux-info user
DESCRIPTION="Cinder is the OpenStack Block storage service, a spin out of nova-volumes"
@@ -36,7 +36,6 @@ RDEPEND="
${CDEPEND}
>=dev-python/decorator-3.4.0[${PYTHON_USEDEP}]
>=dev-python/defusedxml-0.5.0[${PYTHON_USEDEP}]
- dev-python/enum34[$(python_gen_usedep 'python2_7')]
>=dev-python/eventlet-0.18.4[${PYTHON_USEDEP}]
!~dev-python/eventlet-0.20.1[${PYTHON_USEDEP}]
>=dev-python/greenlet-0.4.1[${PYTHON_USEDEP}]
diff --git a/sys-cluster/cinder/cinder-2019.2.9999.ebuild b/sys-cluster/cinder/cinder-2019.2.9999.ebuild
index e9c432edc272..09e2c94c85a8 100644
--- a/sys-cluster/cinder/cinder-2019.2.9999.ebuild
+++ b/sys-cluster/cinder/cinder-2019.2.9999.ebuild
@@ -2,8 +2,8 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python2_7 python3_{5,6,7} )
+PYTHON_COMPAT=( python3_{5,6,7} )
inherit distutils-r1 eutils linux-info user
DESCRIPTION="Cinder is the OpenStack Block storage service, a spin out of nova-volumes"
@@ -36,8 +36,6 @@ RDEPEND="
${CDEPEND}
>=dev-python/decorator-3.4.0[${PYTHON_USEDEP}]
>=dev-python/defusedxml-0.5.0[${PYTHON_USEDEP}]
- dev-python/enum34[$(python_gen_usedep 'python2_7')]
- $(python_gen_cond_dep 'dev-python/enum34[${PYTHON_USEDEP}]' 'python2_7')
>=dev-python/eventlet-0.22.0[${PYTHON_USEDEP}]
!~dev-python/eventlet-0.23.0[${PYTHON_USEDEP}]
!~dev-python/eventlet-0.25.0[${PYTHON_USEDEP}]