summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2022-01-08 00:20:35 +0200
committerMart Raudsepp <leio@gentoo.org>2022-01-08 00:36:15 +0200
commit73356b3d7c3a015b9879c9513d93941e46dd89c3 (patch)
tree052a91bd6f8f452151a8ad9d9d69dc41d8caa303
parentmedia-libs/freetype: fix GCC usage during configure (diff)
downloadgentoo-73356b3d.tar.gz
gentoo-73356b3d.tar.bz2
gentoo-73356b3d.zip
gui-libs/gtk: bump to 4.6.0
* Drop USE=gtk-doc and unconditionally ship pregenerated API docs instead, in a location where our dev-util/devhelp will actually find them * Require libXi-1.8 to ensure new xinput features for touchpad gestures on X11 to work * Drop legacy font test deps that don't seem to affect anything * Stop installing gtk4-update-icon-theme * Standard version bump necessitated updates: - GTK grew direct unconditional libpng, tiff and jpeg deps - pango minimum dependency increased to 1.50.0 - docutils is now used instead of xsltproc and co for manpages, which needs a sed to change program search from rst2man to rst2man.py - Workaround writable+executable ELF sections issue in the 4.6.0 release One testsuite reftest fails for me, which may be system-dependent. Package-Manager: Portage-3.0.20, Repoman-3.0.2 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
-rw-r--r--gui-libs/gtk/Manifest1
-rw-r--r--gui-libs/gtk/gtk-4.6.0.ebuild192
2 files changed, 193 insertions, 0 deletions
diff --git a/gui-libs/gtk/Manifest b/gui-libs/gtk/Manifest
index ce6a1090c6bf..4b95b13eb58b 100644
--- a/gui-libs/gtk/Manifest
+++ b/gui-libs/gtk/Manifest
@@ -1,3 +1,4 @@
DIST gtk-4.2.1.tar.xz 25809520 BLAKE2B 63183950703375b092ce451be93d16d1149eb2095b5f304578a064422821546ae161235b46617647cd67a7d8898e2c3854d87bf31ede0cd6db2138d7e5c36c30 SHA512 a2721d6b9a72be481460081aedfbd713842cb5abdb24d810ec48e346342d0d91271f4ace321a9697214477ad4829d0b0ca67754ea316e719784f01c43f0fe732
DIST gtk-4.4.0.tar.xz 30008844 BLAKE2B 5fa6e8236772847961e09f282efed5386017e6ea7d0c78f310c90c93cc42b1c27fbc6c1a93f624b38365ecca8d6632af9b191ba2a3a4bcd8aa07907e842c85c9 SHA512 de0b6508df3fa4523a7e54cf417ac31292c833346409ff89fd4daf886edad16ffe60b6ed77a85451bd36b96098c8437d56c6fd42daca33c52db8dc57a25753b6
DIST gtk-4.4.1.tar.xz 30031924 BLAKE2B c64d8c015e7cc2a0f21274af70be856bb37ef771af5df8ab8698455c70d25a02d6535a06718307c5c312915b4c3218c4d86f4d799d27e1b8ae4c0e877e218ee8 SHA512 4edf9c5c24a1853713dfabdf9a8853eca4477fdd64b391f55c25d8937bfa7e78fb2e357067dee30aebbc245a099244c637d07965a34a0bff51f090b8f45e3d16
+DIST gtk-4.6.0.tar.xz 22655868 BLAKE2B 197766af8b874cd0598eab1b2289ca329a61990240be55a07be13e25f1d35740ca220d099e1afa57a9c927818f4d2033ab287ea146d52567e696cf5db3f24e88 SHA512 9531d7183c46bd89e213eae6cfd64821536d1f4fe7371a5fef835e31cf2c8b3d5152baebe44633d0a69d3e1ddc34ef1e90123d6e7de9aa3f44d6e70dc83369fa
diff --git a/gui-libs/gtk/gtk-4.6.0.ebuild b/gui-libs/gtk/gtk-4.6.0.ebuild
new file mode 100644
index 000000000000..bc4022bf2b84
--- /dev/null
+++ b/gui-libs/gtk/gtk-4.6.0.ebuild
@@ -0,0 +1,192 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit gnome.org gnome2-utils meson optfeature virtualx xdg
+
+DESCRIPTION="GTK is a multi-platform toolkit for creating graphical user interfaces"
+HOMEPAGE="https://www.gtk.org/ https://gitlab.gnome.org/GNOME/gtk/"
+
+LICENSE="LGPL-2+"
+SLOT="4"
+IUSE="aqua broadway colord cups examples ffmpeg gstreamer +introspection sysprof test vulkan wayland +X cpu_flags_x86_f16c"
+REQUIRED_USE="
+ || ( aqua wayland X )
+ test? ( introspection )
+"
+
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
+
+COMMON_DEPEND="
+ >=dev-libs/fribidi-0.19.7
+ >=dev-libs/glib-2.66.0:2
+ >=media-libs/graphene-1.9.1[introspection?]
+ >=media-libs/libepoxy-1.4[X(+)?]
+ >=x11-libs/cairo-1.14[aqua?,glib,svg,X?]
+ >=x11-libs/gdk-pixbuf-2.30:2[introspection?]
+ >=x11-libs/pango-1.50.0[introspection?]
+ media-libs/libpng:0=
+ media-libs/tiff:0=
+ virtual/jpeg:0=
+ >=media-libs/harfbuzz-2.1.0:=
+ x11-misc/shared-mime-info
+
+ colord? ( >=x11-misc/colord-0.1.9:0= )
+ cups? ( >=net-print/cups-2.0 )
+ ffmpeg? ( media-video/ffmpeg )
+ gstreamer? ( >=media-libs/gst-plugins-bad-1.12.3 )
+ introspection? ( >=dev-libs/gobject-introspection-1.39:= )
+ vulkan? ( media-libs/vulkan-loader:= )
+ wayland? (
+ >=dev-libs/wayland-1.16.91
+ >=dev-libs/wayland-protocols-1.21
+ media-libs/mesa[wayland]
+ >=x11-libs/libxkbcommon-0.2
+ )
+ X? (
+ >=app-accessibility/at-spi2-atk-2.5.3
+ media-libs/fontconfig
+ media-libs/mesa[X(+)]
+ x11-libs/libX11
+ >=x11-libs/libXi-1.8
+ x11-libs/libXext
+ >=x11-libs/libXrandr-1.5
+ x11-libs/libXcursor
+ x11-libs/libXfixes
+ x11-libs/libXdamage
+ x11-libs/libXinerama
+ )
+"
+DEPEND="${COMMON_DEPEND}
+ sysprof? ( >=dev-util/sysprof-capture-3.40.1:4 )
+ X? ( x11-base/xorg-proto )
+"
+RDEPEND="${COMMON_DEPEND}
+ >=dev-util/gtk-update-icon-cache-3
+"
+# librsvg for svg icons (PDEPEND to avoid circular dep), bug #547710
+PDEPEND="
+ gnome-base/librsvg
+ >=x11-themes/adwaita-icon-theme-3.14
+"
+BDEPEND="
+ dev-libs/gobject-introspection-common
+ dev-python/docutils
+ >=dev-util/gdbus-codegen-2.48
+ dev-util/glib-utils
+ >=sys-devel/gettext-0.19.7
+ virtual/pkgconfig
+ test? (
+ dev-libs/glib:2
+ wayland? ( dev-libs/weston[headless] )
+ )
+"
+
+src_prepare() {
+ xdg_src_prepare
+ # dev-python/docutils installs rst2man.py, not rst2man
+ sed -i -e "s/'rst2man'/'rst2man.py'/" docs/reference/gtk/meson.build || die
+ # Nothing should use gtk4-update-icon-cache and an unversioned one is shipped by dev-util/gtk-update-icon-cache
+ sed -i -e '/gtk4-update-icon-cache/d' tools/meson.build || die
+ # Workaround RWX ELF sections, https://gitlab.gnome.org/GNOME/gtk/-/issues/4598
+ sed -i -e 's/^ld =.*/ld = disabler()/g' gtk/meson.build demos/gtk-demo/meson.build demos/widget-factory/meson.build || die
+ sed -i -e 's/^objcopy =.*/objcopy = disabler()/g' gtk/meson.build demos/gtk-demo/meson.build demos/widget-factory/meson.build || die
+}
+
+src_configure() {
+ local emesonargs=(
+ # GDK backends
+ $(meson_use X x11-backend)
+ $(meson_use wayland wayland-backend)
+ $(meson_use broadway broadway-backend)
+ -Dwin32-backend=false
+ $(meson_use aqua macos-backend)
+
+ # Media backends
+ $(meson_feature ffmpeg media-ffmpeg)
+ $(meson_feature gstreamer media-gstreamer)
+
+ # Print backends
+ $(meson_feature cups print-cups)
+
+ # Optional dependencies
+ $(meson_feature vulkan)
+ -Dcloudproviders=disabled # cloudprovider is not packaged in Gentoo yet
+ $(meson_feature sysprof)
+ -Dtracker=disabled # tracker3 is not packaged in Gentoo yet
+ $(meson_feature colord)
+ # Expected to fail with GCC < 11
+ # See https://gcc.gnu.org/bugzilla/show_bug.cgi?id=71993
+ $(meson_feature cpu_flags_x86_f16c f16c)
+
+ # Documentation and introspection
+ -Dgtk_doc=false # we ship pregenerated API docs from tarball
+ -Dman-pages=true
+ $(meson_feature introspection)
+
+ # Demos and binaries
+ $(meson_use examples build-examples)
+ $(meson_use examples demos)
+ $(meson_use test build-tests)
+ -Dinstall-tests=false
+ )
+ meson_src_configure
+}
+
+src_test() {
+ "${BROOT}${GLIB_COMPILE_SCHEMAS}" --allow-any-name "${S}/gtk" || die
+
+ if use X; then
+ einfo "Running tests under X"
+ GSETTINGS_SCHEMA_DIR="${S}/gtk" virtx meson_src_test --setup=x11
+ fi
+
+ if use wayland; then
+ einfo "Running tests under Weston"
+
+ export XDG_RUNTIME_DIR="$(mktemp -p $(pwd) -d xdg-runtime-XXXXXX)"
+
+ weston --backend=headless-backend.so --socket=wayland-5 --idle-time=0 &
+ compositor=$!
+ export WAYLAND_DISPLAY=wayland-5
+
+ GSETTINGS_SCHEMA_DIR="${S}/gtk" meson_src_test --setup=wayland
+
+ exit_code=$?
+ kill ${compositor}
+ fi
+}
+
+src_install() {
+ meson_src_install
+
+ insinto /usr/share/gtk-doc/html
+ # This will install API docs specific to X11 and wayland regardless of USE flags, but this is intentional
+ doins -r "${S}"/docs/reference/{gtk/gtk4,gsk/gsk4,gdk/gdk4{,-wayland,-x11}}
+}
+
+pkg_preinst() {
+ xdg_pkg_preinst
+ gnome2_schemas_savelist
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+
+ if ! has_version "app-text/evince"; then
+ elog "Please install app-text/evince for print preview functionality."
+ elog "Alternatively, check \"gtk-print-preview-command\" documentation and"
+ elog "add it to your settings.ini file."
+ fi
+
+ if use examples ; then
+ optfeature "syntax highlighting in gtk4-demo" app-text/highlight
+ fi
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}