summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2024-03-22 22:51:40 +0100
committerConrad Kostecki <conikost@gentoo.org>2024-03-22 22:51:40 +0100
commit7336c5d983913656d04fc278a8dff4a73839a30c (patch)
treee36811be95d50158adc7aa567c600dae5b04b796
parentdev-php/cli-prompt: add 1.0.4 (diff)
downloadgentoo-7336c5d9.tar.gz
gentoo-7336c5d9.tar.bz2
gentoo-7336c5d9.zip
dev-php/cphplib: EAPI 6 -> 8
Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
-rw-r--r--dev-php/cphplib/cphplib-0.51-r1.ebuild29
-rw-r--r--dev-php/cphplib/cphplib-0.51-r2.ebuild26
-rw-r--r--dev-php/cphplib/files/cphplib-0.51-constructor.patch (renamed from dev-php/cphplib/files/constructor.patch)0
3 files changed, 26 insertions, 29 deletions
diff --git a/dev-php/cphplib/cphplib-0.51-r1.ebuild b/dev-php/cphplib/cphplib-0.51-r1.ebuild
deleted file mode 100644
index c79a4a612094..000000000000
--- a/dev-php/cphplib/cphplib-0.51-r1.ebuild
+++ /dev/null
@@ -1,29 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-KEYWORDS="~amd64 ~x86"
-
-DESCRIPTION="Cute PHP Library (cphplib)"
-HOMEPAGE="http://cphplib.sourceforge.net/"
-SRC_URI="mirror://sourceforge/cphplib/${P}.tar.bz2"
-LICENSE="LGPL-2.1"
-SLOT="0"
-IUSE="doc"
-
-DEPEND=">=dev-php/PEAR-DB-1.7.6-r1"
-RDEPEND="${DEPEND}"
-PATCHES=( "${FILESDIR}/constructor.patch" )
-
-src_install() {
- local DOCS=( ChangeLog README TODO )
- local -a HTML_DOCS
- insinto "/usr/share/php/${PN}"
- doins -r i18n cphplib_formular.inc cphplib.inc
- use doc && HTML_DOCS=( doc/packages.html doc/blank.html
- doc/classtrees_cphplib.html doc/index.html doc/cphplib/
- doc/errors.html doc/__filesource/ doc/elementindex.html
- doc/li_cphplib.html doc/elementindex_cphplib.html doc/media/ )
- einstalldocs
-}
diff --git a/dev-php/cphplib/cphplib-0.51-r2.ebuild b/dev-php/cphplib/cphplib-0.51-r2.ebuild
new file mode 100644
index 000000000000..d40c6df8da76
--- /dev/null
+++ b/dev-php/cphplib/cphplib-0.51-r2.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Cute PHP Library (cphplib)"
+HOMEPAGE="http://cphplib.sourceforge.net/"
+SRC_URI="https://download.sourceforge.net/cphplib/${P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="dev-php/PEAR-DB"
+RDEPEND="${DEPEND}"
+
+PATCHES=( "${FILESDIR}/${PN}-0.51-constructor.patch" )
+
+src_install() {
+ insinto "/usr/share/php/cphplib"
+ doins -r i18n cphplib_formular.inc cphplib.inc
+
+ docinto html
+ dodoc -r doc/.
+ einstalldocs
+}
diff --git a/dev-php/cphplib/files/constructor.patch b/dev-php/cphplib/files/cphplib-0.51-constructor.patch
index 1ab88d212c1f..1ab88d212c1f 100644
--- a/dev-php/cphplib/files/constructor.patch
+++ b/dev-php/cphplib/files/cphplib-0.51-constructor.patch