summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEgor Martynov <martynovegorOF@yandex.ru>2022-12-03 19:33:03 +0700
committerSergey Popov <pinkbyte@gentoo.org>2022-12-08 10:45:34 +0300
commit7345215e2b03801e6fb7f880748078e866a2f3bf (patch)
tree724f7293347b7890d922688ba3df11ecd414d99e
parentx11-libs/neXtaw: keyword 0.15.1-r4 for ~loong (diff)
downloadgentoo-7345215e2b03801e6fb7f880748078e866a2f3bf.tar.gz
gentoo-7345215e2b03801e6fb7f880748078e866a2f3bf.tar.bz2
gentoo-7345215e2b03801e6fb7f880748078e866a2f3bf.zip
net-misc/yandex-disk: add 0.1.6.1080_p1
Signed-off-by: Egor Martynov <martynovegorOF@yandex.ru> Signed-off-by: Sergey Popov <pinkbyte@gentoo.org> Closes: https://github.com/gentoo/gentoo/pull/28522
-rw-r--r--net-misc/yandex-disk/Manifest2
-rw-r--r--net-misc/yandex-disk/yandex-disk-0.1.6.1080_p1.ebuild50
2 files changed, 52 insertions, 0 deletions
diff --git a/net-misc/yandex-disk/Manifest b/net-misc/yandex-disk/Manifest
index 6c6d5524e710..80ad95aab8ea 100644
--- a/net-misc/yandex-disk/Manifest
+++ b/net-misc/yandex-disk/Manifest
@@ -2,3 +2,5 @@ DIST yandex-disk-0.1.5.1039-1.fedora.i386.rpm 4556176 BLAKE2B 5ade043c21a13e678c
DIST yandex-disk-0.1.5.1039-1.fedora.x86_64.rpm 4743384 BLAKE2B 626a7e921567640b88d33fd426cc230bb92846a252b0960c51da9367f300b8622104db14c8788749e0f5cb484dffd9c9407994568449be769c24d2730cd0936a SHA512 9128d59f426de44b8c953d61ad07ffe886b5e864c5f20ba7ab1a69a47ab3269e5d4e39f4b92675f0ccaea43db1711184892a5e3178694bc453bc96e932045fa9
DIST yandex-disk-0.1.6.1074-1.fedora.i386.rpm 4613237 BLAKE2B fa6c1643f11efb2cbbcda81cbc95c867abccf997f75352dbfcc93349e29694a0aa7c2d778847d77a6572fb4253dbb650564c5d744b3d9ea4320519d7bfc54ee5 SHA512 afb9d1e4896cecbedd005c6383bc44cc67e8b0df95dc1866e8d7540e3f9e73ad0584db93f987eb108c383f9ec6790d5cf80f804634f4d776b4b3459eb80c0bad
DIST yandex-disk-0.1.6.1074-1.fedora.x86_64.rpm 4799146 BLAKE2B e51c7f39aa9fad7ad3316629b36e917d9555290168e3e58706c6f5b88ac4443286ebf741ae5aed36f39fd433710d2010eeba53199837598ee2821afec23c2cb5 SHA512 dab523455c6355ccb0b72019c9b8ea4c3e7f07e55081ae614866ad21927eef7026b3348eb46ede30dfe492ec37c11450484bee65cce829ab972badbb54c0d4cc
+DIST yandex-disk-0.1.6.1080-1.fedora.i386.rpm 4613067 BLAKE2B 1d893b0420d6146aea7d10d4603c28fccd6e6c93eb3c6c414d5c91b3ebd77dd770fc20445b5c0e5892994a32d9fdfa18d3aa5cc011be3894381e63b833b76630 SHA512 68f8952556b822d1de0b99827f4667257caab8ff3c744c280da682d7bf9647877dcbad5547946f92d230bd8dd27b50f5695e5af6cdd6c8c4ed20ca22cbe5e914
+DIST yandex-disk-0.1.6.1080-1.fedora.x86_64.rpm 4799367 BLAKE2B cc0fabe1479c0c66b06dd7fab943de32e1ad9477b3c03bc39c0859ba5b802bad8909d721b5fc2445943e86213bcc9ce68bf5f37eb6c151d5c211243176ae126c SHA512 d0845a825b1d4db773947c1101fa6aee38df43167486e4fae1d2db1e7fc7a49326882848eb742b069b3b2f6c1e9d617f6203dd8a3f67dd136dfa1f7bc1c8bfea
diff --git a/net-misc/yandex-disk/yandex-disk-0.1.6.1080_p1.ebuild b/net-misc/yandex-disk/yandex-disk-0.1.6.1080_p1.ebuild
new file mode 100644
index 000000000000..b8c324f9da4e
--- /dev/null
+++ b/net-misc/yandex-disk/yandex-disk-0.1.6.1080_p1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit bash-completion-r1 rpm
+
+MY_P="${PN}-${PV/_p/-}"
+
+DESCRIPTION="CLI to access Yandex Disk file storage service"
+HOMEPAGE="https://disk.yandex.ru"
+SRC_URI="
+ amd64? ( https://repo.yandex.ru/yandex-disk/rpm/stable/x86_64/${MY_P}.fedora.x86_64.rpm )
+ x86? ( https://repo.yandex.ru/yandex-disk/rpm/stable/i386/${MY_P}.fedora.i386.rpm )
+"
+
+LICENSE="YDSLA"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+
+DEPEND="app-arch/gzip"
+RDEPEND="sys-libs/zlib"
+
+S="${WORKDIR}"
+
+QA_PREBUILT="opt/bin/yandex-disk"
+
+src_prepare() {
+ # bug #526312
+ sed -i \
+ -e '/have /d' \
+ -e 's/+o nospace/-o nospace/' \
+ -e '/^complete/s/-X //' \
+ etc/bash_completion.d/yandex-disk-completion.bash || die
+
+ # Uncompress man pages to prevent QA warnings, bug #731684
+ find usr/share/man -type f -name *.gz | xargs gunzip
+
+ eapply_user
+}
+
+src_install() {
+ exeinto /opt/bin
+ doexe usr/bin/yandex-disk
+ newbashcomp etc/bash_completion.d/yandex-disk-completion.bash "${PN}"
+ insinto /usr/share/man
+ doins -r usr/share/man/*
+ insinto /usr/share
+ doins -r usr/share/locale
+}