summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-08-20 08:09:10 +0200
committerMichał Górny <mgorny@gentoo.org>2020-08-20 10:34:37 +0200
commit7366a7ed16e8fe06d313edb9c6e0a1d7f63591a9 (patch)
tree3a7e2e4b0073acf847563c8991482efa30f393b1
parentdev-python/boto3: Bump to 1.14.46 (diff)
downloadgentoo-7366a7ed.tar.gz
gentoo-7366a7ed.tar.bz2
gentoo-7366a7ed.zip
dev-python/hypothesis: Bump to 5.26.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/hypothesis/Manifest1
-rw-r--r--dev-python/hypothesis/hypothesis-5.26.1.ebuild68
2 files changed, 69 insertions, 0 deletions
diff --git a/dev-python/hypothesis/Manifest b/dev-python/hypothesis/Manifest
index 9a22a3c33be2..2dda6a737485 100644
--- a/dev-python/hypothesis/Manifest
+++ b/dev-python/hypothesis/Manifest
@@ -8,3 +8,4 @@ DIST hypothesis-python-5.24.2.tar.gz 9050270 BLAKE2B 05043935afec77b23349b4973a2
DIST hypothesis-python-5.24.3.tar.gz 9050345 BLAKE2B bfb47794edb3c1c6aee22e808a6d27af52f8176d307f9a585efa0f1e0d68adf9a902ed6f67405e77c6804f18e17a76486ab42f610807f6ee97535f950318a055 SHA512 7647d14ba805ad3ff6465e1d2c6d9104560c7ea31517777ab45e07da39efefa7109215d2f4074082620554ae4aa5ce5060bca5c923d11c14718f1efdae829986
DIST hypothesis-python-5.24.4.tar.gz 9054743 BLAKE2B 5c64c86ed58d8f0e4a07390b1b1b5e405878b9632bf14233e0515ad9d98ec6ddcc57bf39be6b61f53739d34e393b3af64c0d362880019d29a649a9523a0204e3 SHA512 147f4fa47b54bf3ec4dfcebf2a6c98cee26ea6780244ef99e181bada65978375ca7731ed05cb98f1b92f7a44a357faae374d97d489ec6e2318ff94e526cd9a40
DIST hypothesis-python-5.26.0.tar.gz 9062003 BLAKE2B 7a75c6fb2205944fc64100708c38417a5d3f1dd602a7fc14a464acb79e5d91b5513e9080e23c9ec5547edc6dbbe3b6a2c0425077a697a5656c0112d65adbaefd SHA512 8fc23a5e753cffe4a6a6b1be68fa96042933ef7ec8f8c4f88fbf0901996da9de576457647bea55ff2ceca4d71db322f927847258ca9bda90e1fac9f19c79a42b
+DIST hypothesis-python-5.26.1.tar.gz 9063203 BLAKE2B 87b60395a417a811a2f4d41f10c3c2f1d77f0127d43e4cb1d5ae4deff97834623675a26134cc6579236099efa1cd84974619033ed58ef3d0fd5b0bec2e45935a SHA512 b8df15df0e3b615c3e621005a7fd1ef183b67f2fba4d16aaec22577af2b5f3dec6d98cb15d32f998d2aa185fcad16324df1d62affe7647c5e78259b42c550511
diff --git a/dev-python/hypothesis/hypothesis-5.26.1.ebuild b/dev-python/hypothesis/hypothesis-5.26.1.ebuild
new file mode 100644
index 000000000000..2ac74d435dc5
--- /dev/null
+++ b/dev-python/hypothesis/hypothesis-5.26.1.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=rdepend
+PYTHON_COMPAT=( python3_{6,7,8,9} pypy3 )
+PYTHON_REQ_USE="threads(+),sqlite"
+
+inherit distutils-r1 eutils
+
+DESCRIPTION="A library for property based testing"
+HOMEPAGE="https://github.com/HypothesisWorks/hypothesis https://pypi.org/project/hypothesis/"
+SRC_URI="https://github.com/HypothesisWorks/${PN}/archive/${PN}-python-${PV}.tar.gz"
+S="${WORKDIR}/${PN}-${PN}-python-${PV}/${PN}-python"
+
+LICENSE="MPL-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~x86"
+IUSE="cli test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-python/attrs-19.2.0[${PYTHON_USEDEP}]
+ >=dev-python/sortedcontainers-2.1.0[${PYTHON_USEDEP}]
+ cli? (
+ $(python_gen_cond_dep '
+ dev-python/black[${PYTHON_USEDEP}]
+ dev-python/click[${PYTHON_USEDEP}]
+ ' python3_{6..8})
+ )
+"
+BDEPEND="
+ test? (
+ ${RDEPEND}
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pexpect[${PYTHON_USEDEP}]
+ >=dev-python/pytest-5.3.5[${PYTHON_USEDEP}]
+ !!<dev-python/typing-3.7.4.1
+ )
+"
+
+src_prepare() {
+ # avoid pytest-xdist dep for one test
+ sed -i -e 's:test_prints_statistics_given_option_under_xdist:_&:' \
+ tests/pytest/test_statistics.py || die
+ distutils-r1_src_prepare
+}
+
+python_prepare() {
+ if ! use cli || [[ ${EPYTHON} != python3.[678] ]]; then
+ sed -i -e '/console_scripts/d' setup.py || die
+ fi
+}
+
+python_test() {
+ pytest -vv tests/cover tests/pytest tests/quality ||
+ die "Tests fail with ${EPYTHON}"
+}
+
+pkg_postinst() {
+ optfeature "datetime support" dev-python/pytz
+ optfeature "dateutil support" dev-python/python-dateutil
+ optfeature "numpy support" dev-python/numpy
+ optfeature "django support" dev-python/django dev-python/pytz
+ optfeature "pandas support" dev-python/pandas
+ optfeature "pytest support" dev-python/pytest
+}