summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-06-05 14:32:43 +0200
committerMichał Górny <mgorny@gentoo.org>2021-06-05 14:36:19 +0200
commit736859c1b8c8c7bee31db2251431f7737120e3cd (patch)
tree0deea8d5bf56c5a8f0f164ae891a20aa5175ee2e
parentdev-python/ansi: Enable py3.10 (diff)
downloadgentoo-736859c1b8c8c7bee31db2251431f7737120e3cd.tar.gz
gentoo-736859c1b8c8c7bee31db2251431f7737120e3cd.tar.bz2
gentoo-736859c1b8c8c7bee31db2251431f7737120e3cd.zip
dev-python/ansi2html: Enable py3.10
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/ansi2html/ansi2html-1.6.0.ebuild13
1 files changed, 3 insertions, 10 deletions
diff --git a/dev-python/ansi2html/ansi2html-1.6.0.ebuild b/dev-python/ansi2html/ansi2html-1.6.0.ebuild
index f6cc43ef6456..fceae73f627a 100644
--- a/dev-python/ansi2html/ansi2html-1.6.0.ebuild
+++ b/dev-python/ansi2html/ansi2html-1.6.0.ebuild
@@ -1,11 +1,9 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{7,8,9} )
-DISTUTILS_USE_SETUPTOOLS=rdepend
-
+PYTHON_COMPAT=( python3_{8..10} )
inherit distutils-r1
DESCRIPTION="Convert text with ANSI color codes to HTML"
@@ -31,18 +29,13 @@ BDEPEND="
)
"
-distutils_enable_tests pytest # for BDEPEND
+distutils_enable_tests --install pytest
python_install_all() {
use doc && doman man/${PN}.1
distutils-r1_python_install_all
}
-python_test() {
- distutils_install_for_testing
- pytest -vv || die "Tests fail with ${EPYTHON}"
-}
-
src_compile() {
# Upstream https://github.com/pycontribs/ansi2html/issues/124
use doc && emake man/ansi2html.1