summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2024-01-08 17:50:27 -0500
committerIonen Wolkens <ionen@gentoo.org>2024-01-08 18:00:16 -0500
commit737704ccd537f71f22bb98920f410f9d2ebc9b9b (patch)
treeeec88d7ea174e0c52fccac1fc3a73c59b58f9eb2
parentapp-emulation/wine-proton: use -latomic for winevulkan with clang (diff)
downloadgentoo-737704cc.tar.gz
gentoo-737704cc.tar.bz2
gentoo-737704cc.zip
www-client/qutebrowser: fix tests due to python-utils changes
Several tests fail due to `-o tmp_path_retention_policy=failed` from python-utils.eclass since commit b77499537549, so set back to the default (=all). The other setting (tmp_path_retention_count=0) does not seem to be a problem. Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
-rw-r--r--www-client/qutebrowser/qutebrowser-3.1.0.ebuild14
-rw-r--r--www-client/qutebrowser/qutebrowser-9999.ebuild14
2 files changed, 22 insertions, 6 deletions
diff --git a/www-client/qutebrowser/qutebrowser-3.1.0.ebuild b/www-client/qutebrowser/qutebrowser-3.1.0.ebuild
index 7ddeb9db71fb..6134e6cba9f4 100644
--- a/www-client/qutebrowser/qutebrowser-3.1.0.ebuild
+++ b/www-client/qutebrowser/qutebrowser-3.1.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -152,8 +152,16 @@ python_test() {
tests/unit/mainwindow/test_tabwidget.py::TestTabWidget::test_tab_text_not_edlided_for_wide_tabs
)
- # skip benchmarks (incl. _tree), and warning tests broken by -Wdefault
- epytest -p xvfb -k 'not _bench and not _matches_tree and not _warning'
+ local epytestargs=(
+ # prefer pytest-xvfb over virtx given same upstream and is expected
+ -p xvfb
+ # skip warning tests broken by -wdefault, and benchmarks
+ -k 'not _bench and not _matches_tree and not _warning'
+ # override eclass' settings, tempdirs are re-used by Qt
+ -o tmp_path_retention_policy=all
+ )
+
+ epytest "${epytestargs[@]}"
}
python_install_all() {
diff --git a/www-client/qutebrowser/qutebrowser-9999.ebuild b/www-client/qutebrowser/qutebrowser-9999.ebuild
index 23ed8b900a7c..6d2ceaa9e208 100644
--- a/www-client/qutebrowser/qutebrowser-9999.ebuild
+++ b/www-client/qutebrowser/qutebrowser-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -152,8 +152,16 @@ python_test() {
tests/unit/mainwindow/test_tabwidget.py::TestTabWidget::test_tab_text_not_edlided_for_wide_tabs
)
- # skip benchmarks (incl. _tree), and warning tests broken by -Wdefault
- epytest -p xvfb -k 'not _bench and not _matches_tree and not _warning'
+ local epytestargs=(
+ # prefer pytest-xvfb over virtx given same upstream and is expected
+ -p xvfb
+ # skip warning tests broken by -wdefault, and benchmarks
+ -k 'not _bench and not _matches_tree and not _warning'
+ # override eclass' settings, tempdirs are re-used by Qt
+ -o tmp_path_retention_policy=all
+ )
+
+ epytest "${epytestargs[@]}"
}
python_install_all() {