summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2015-08-11 13:27:58 +0000
committerPatrice Clement <monsieurp@gentoo.org>2015-08-11 14:08:31 +0000
commit737cb8ba0e804b1cf8a148a46bcdd0e5f94ef2e0 (patch)
tree8b5f33f2bf5ede0fe2f0891c825cfdc62ebb29ee
parentdev-java/slf4j-api: Remove old versions and clean up associated files. (diff)
downloadgentoo-737cb8ba0e804b1cf8a148a46bcdd0e5f94ef2e0.tar.gz
gentoo-737cb8ba0e804b1cf8a148a46bcdd0e5f94ef2e0.tar.bz2
gentoo-737cb8ba0e804b1cf8a148a46bcdd0e5f94ef2e0.zip
dev-java/slf4j-log4j12: Add build.xml for version 1.7.7. Modify ebuild accordingly. Raise {jre,jdk} required version to 1.6.
Package-Manager: portage-2.2.18 Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
-rw-r--r--dev-java/slf4j-log4j12/Manifest2
-rw-r--r--dev-java/slf4j-log4j12/files/slf4j-log4j12-1.7.7-maven-build.xml241
-rw-r--r--dev-java/slf4j-log4j12/slf4j-log4j12-1.7.5.ebuild52
-rw-r--r--dev-java/slf4j-log4j12/slf4j-log4j12-1.7.6.ebuild52
-rw-r--r--dev-java/slf4j-log4j12/slf4j-log4j12-1.7.7.ebuild7
5 files changed, 245 insertions, 109 deletions
diff --git a/dev-java/slf4j-log4j12/Manifest b/dev-java/slf4j-log4j12/Manifest
index c9f3c66a1f92..9857cc1aac43 100644
--- a/dev-java/slf4j-log4j12/Manifest
+++ b/dev-java/slf4j-log4j12/Manifest
@@ -1,3 +1 @@
-DIST slf4j-1.7.5.tar.gz 2862186 SHA256 e83f1f22f22dabce0a78bd8191fb2d6fab71dc9dc4c8bfbd7939a87b1237c92e SHA512 2ef078f505b626273bd22fe683b4a2527ce2d97b345ffb8cd9f23e7375cb11588623e67e15de90ceacfa02689e40c59749f22e5e0b44b8a9fd7492d3f120d9d7 WHIRLPOOL 4a396c81b50b186d8e582f30331f7d0a21c85bb2cc293bdc8eff8a8bc49ae7382b6b37e1b3f585d0f14e716b1b889ac17ae1acdc03799b93180539e488170820
-DIST slf4j-1.7.6.tar.gz 3051903 SHA256 9abf25b99f7c4dfc52a85b79a67b4d878831dfd79c1734b0124ad73615372323 SHA512 c274c0f1700df6b4801fa25d71127c0a35d0f30e421e8661fdaf8074ddfb84c94167bd6ff016cfceae0d062f4cf26a13426c3a9a9dd6b4fc471b18028ae37c4c WHIRLPOOL ee8a3b84a1a1809a893957d52f7a139f3b743796ca934fca0c85aad386f81182f54666000727e7582874ce6ff7a095cce39af5caaa8c415bcad13fe43661c2d4
DIST slf4j-1.7.7.tar.gz 3031017 SHA256 97717f30f263dfbfe853a00b218e3f929acb022d9b13a4723c75c31846351cf1 SHA512 aefefe049ed36e8ec938469067be8d73d2c7a28189f54cf434606fecab1d380f00fdf8349a23ed99d574067d9a613b0aec48b913705cd27524af5a4a5d887418 WHIRLPOOL a20cbc94b940f23bf61645b7ab09600651df17fedc103660996dc800af4dd7b0d82e25c7eac65aa2d7981bf4acbfdd14a8bf2885270d2b06627889129d23373f
diff --git a/dev-java/slf4j-log4j12/files/slf4j-log4j12-1.7.7-maven-build.xml b/dev-java/slf4j-log4j12/files/slf4j-log4j12-1.7.7-maven-build.xml
new file mode 100644
index 000000000000..e88e8b290cc4
--- /dev/null
+++ b/dev-java/slf4j-log4j12/files/slf4j-log4j12-1.7.7-maven-build.xml
@@ -0,0 +1,241 @@
+<?xml version="1.0" encoding="UTF-8"?>
+
+<!-- ====================================================================== -->
+<!-- Ant build file (http://ant.apache.org/) for Ant 1.6.2 or above. -->
+<!-- ====================================================================== -->
+
+<!-- ====================================================================== -->
+<!-- ===================== - DO NOT EDIT THIS FILE! - ===================== -->
+<!-- ====================================================================== -->
+<!-- -->
+<!-- Any modifications will be overwritten. -->
+<!-- -->
+<!-- Generated by Maven Ant Plugin on 3/12/14 1:54 AM -->
+<!-- See: http://maven.apache.org/plugins/maven-ant-plugin/ -->
+<!-- -->
+<!-- ====================================================================== -->
+
+<project name="slf4j-log4j12-from-maven" default="package" basedir=".">
+
+ <!-- ====================================================================== -->
+ <!-- Build environment properties -->
+ <!-- ====================================================================== -->
+
+ <property file="${user.home}/.m2/maven.properties"/>
+ <property file="maven-build.properties"/>
+
+ <property name="maven.build.finalName" value="slf4j-log4j12-1.7.7"/>
+ <property name="maven.build.dir" value="target"/>
+ <property name="maven.build.outputDir" value="${maven.build.dir}/classes"/>
+ <property name="maven.build.srcDir.0" value="src/main/java"/>
+ <property name="maven.build.resourceDir.0" value="src/main/resources"/>
+ <property name="maven.build.testOutputDir" value="${maven.build.dir}/test-classes"/>
+ <property name="maven.build.testDir.0" value="src/test/java"/>
+ <property name="maven.build.testResourceDir.0" value="src/test/resources"/>
+ <property name="maven.test.reports" value="${maven.build.dir}/test-reports"/>
+ <property name="maven.reporting.outputDirectory" value="${maven.build.dir}/site"/>
+
+ <property name="maven.repo.local" value="${user.home}/.m2/repository"/>
+ <property name="maven.settings.offline" value="false"/>
+ <property name="maven.settings.interactiveMode" value="true"/>
+
+ <!-- ====================================================================== -->
+ <!-- Defining classpaths -->
+ <!-- ====================================================================== -->
+
+ <path id="build.classpath">
+ <pathelement location="${maven.repo.local}/org/slf4j/slf4j-api/1.7.7/slf4j-api-1.7.7.jar"/>
+ <pathelement location="${maven.repo.local}/log4j/log4j/1.2.17/log4j-1.2.17.jar"/>
+ </path>
+ <path id="build.test.classpath">
+ <pathelement location="${maven.repo.local}/org/slf4j/slf4j-api/1.7.7/slf4j-api-1.7.7.jar"/>
+ <pathelement location="${maven.repo.local}/log4j/log4j/1.2.17/log4j-1.2.17.jar"/>
+ <pathelement location="${maven.repo.local}/junit/junit/4.10/junit-4.10.jar"/>
+ <pathelement location="${maven.repo.local}/org/hamcrest/hamcrest-core/1.1/hamcrest-core-1.1.jar"/>
+ </path>
+
+ <!-- ====================================================================== -->
+ <!-- Cleaning up target -->
+ <!-- ====================================================================== -->
+
+ <target name="clean" description="Clean the output directory">
+ <delete dir="${maven.build.dir}"/>
+ </target>
+
+ <!-- ====================================================================== -->
+ <!-- Compilation target -->
+ <!-- ====================================================================== -->
+
+ <target name="compile" description="Compile the code">
+ <mkdir dir="${maven.build.outputDir}"/>
+ <javac destdir="${maven.build.outputDir}"
+ nowarn="false"
+ debug="true"
+ optimize="false"
+ deprecation="true"
+ target="1.6"
+ verbose="false"
+ fork="false"
+ source="1.6">
+ <src>
+ <pathelement location="${maven.build.srcDir.0}"/>
+ </src>
+ <classpath refid="build.classpath"/>
+ </javac>
+ <copy todir="${maven.build.outputDir}">
+ <fileset dir="${maven.build.resourceDir.0}"/>
+ </copy>
+ </target>
+
+ <!-- ====================================================================== -->
+ <!-- Test-compilation target -->
+ <!-- ====================================================================== -->
+
+ <target name="compile-tests"
+ depends="compile"
+ description="Compile the test code"
+ unless="maven.test.skip">
+ <mkdir dir="${maven.build.testOutputDir}"/>
+ <javac destdir="${maven.build.testOutputDir}"
+ nowarn="false"
+ debug="true"
+ optimize="false"
+ deprecation="true"
+ target="1.6"
+ verbose="false"
+ fork="false"
+ source="1.6">
+ <src>
+ <pathelement location="${maven.build.testDir.0}"/>
+ </src>
+ <classpath>
+ <path refid="build.test.classpath"/>
+ <pathelement location="${maven.build.outputDir}"/>
+ </classpath>
+ </javac>
+ <copy todir="${maven.build.testOutputDir}">
+ <fileset dir="${maven.build.testResourceDir.0}"/>
+ </copy>
+ </target>
+
+ <!-- ====================================================================== -->
+ <!-- Run all tests -->
+ <!-- ====================================================================== -->
+
+ <target name="test"
+ depends="compile-tests, junit-missing"
+ unless="junit.skipped"
+ description="Run the test cases">
+ <mkdir dir="${maven.test.reports}"/>
+ <junit printSummary="yes" haltonerror="true" haltonfailure="true" fork="true" dir=".">
+ <sysproperty key="basedir" value="."/>
+ <formatter type="xml"/>
+ <formatter type="plain" usefile="false"/>
+ <classpath>
+ <path refid="build.test.classpath"/>
+ <pathelement location="${maven.build.outputDir}"/>
+ <pathelement location="${maven.build.testOutputDir}"/>
+ </classpath>
+ <batchtest todir="${maven.test.reports}" unless="test">
+ <fileset dir="${maven.build.testDir.0}">
+ <include name="**/Test*.java"/>
+ <include name="**/*Test.java"/>
+ <include name="**/*TestCase.java"/>
+ <exclude name="**/AllTest.java"/>
+ <exclude name="**/PackageTest.java"/>
+ </fileset>
+ </batchtest>
+ <batchtest todir="${maven.test.reports}" if="test">
+ <fileset dir="${maven.build.testDir.0}">
+ <include name="**/${test}.java"/>
+ <exclude name="**/AllTest.java"/>
+ <exclude name="**/PackageTest.java"/>
+ </fileset>
+ </batchtest>
+ </junit>
+ </target>
+
+ <target name="test-junit-present">
+ <available classname="junit.framework.Test" property="junit.present"/>
+ </target>
+
+ <target name="test-junit-status"
+ depends="test-junit-present">
+ <condition property="junit.missing">
+ <and>
+ <isfalse value="${junit.present}"/>
+ <isfalse value="${maven.test.skip}"/>
+ </and>
+ </condition>
+ <condition property="junit.skipped">
+ <or>
+ <isfalse value="${junit.present}"/>
+ <istrue value="${maven.test.skip}"/>
+ </or>
+ </condition>
+ </target>
+
+ <target name="junit-missing"
+ depends="test-junit-status"
+ if="junit.missing">
+ <echo>=================================== WARNING ===================================</echo>
+ <echo> JUnit is not present in your $ANT_HOME/lib directory. Tests not executed.</echo>
+ <echo>===============================================================================</echo>
+ </target>
+
+ <!-- ====================================================================== -->
+ <!-- Javadoc target -->
+ <!-- ====================================================================== -->
+
+ <target name="javadoc" description="Generates the Javadoc of the application">
+ <javadoc sourcepath="${maven.build.srcDir.0}"
+ packagenames="*"
+ destdir="${maven.reporting.outputDirectory}/apidocs"
+ access="protected"
+ old="false"
+ verbose="false"
+ version="true"
+ use="true"
+ author="true"
+ splitindex="false"
+ nodeprecated="false"
+ nodeprecatedlist="false"
+ notree="false"
+ noindex="false"
+ nohelp="false"
+ nonavbar="false"
+ serialwarn="false"
+ charset="ISO-8859-1"
+ linksource="false"
+ breakiterator="false"/>
+ </target>
+
+ <!-- ====================================================================== -->
+ <!-- Package target -->
+ <!-- ====================================================================== -->
+
+ <target name="package" depends="compile,test" description="Package the application">
+ <jar jarfile="${maven.build.dir}/${maven.build.finalName}.jar"
+ compress="true"
+ index="false"
+ manifest="${maven.build.resourceDir.0}/META-INF/MANIFEST.MF"
+ basedir="${maven.build.outputDir}"
+ excludes="**/package.html"/>
+ </target>
+
+ <!-- ====================================================================== -->
+ <!-- A dummy target for the package named after the type it creates -->
+ <!-- ====================================================================== -->
+
+ <target name="jar" depends="package" description="Builds the jar for the application"/>
+
+ <!-- ====================================================================== -->
+ <!-- Download dependencies target -->
+ <!-- ====================================================================== -->
+
+ <target name="test-offline">
+ <condition property="maven.mode.offline">
+ <equals arg1="${maven.settings.offline}" arg2="true"/>
+ </condition>
+ </target>
+</project>
diff --git a/dev-java/slf4j-log4j12/slf4j-log4j12-1.7.5.ebuild b/dev-java/slf4j-log4j12/slf4j-log4j12-1.7.5.ebuild
deleted file mode 100644
index 08e53b1d10b0..000000000000
--- a/dev-java/slf4j-log4j12/slf4j-log4j12-1.7.5.ebuild
+++ /dev/null
@@ -1,52 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-JAVA_PKG_IUSE="doc source"
-
-inherit java-pkg-2 java-ant-2
-
-DESCRIPTION="Simple Logging Facade for Java (SLF4J) log4j bindings"
-HOMEPAGE="http://www.slf4j.org/"
-SRC_URI="http://www.slf4j.org/dist/${P/-log4j12/}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="test"
-
-COMMON_DEPEND="
- dev-java/log4j:0
- ~dev-java/slf4j-api-${PV}:0"
-RDEPEND="${COMMON_DEPEND}
- >=virtual/jre-1.5"
-DEPEND="${COMMON_DEPEND}
- >=virtual/jdk-1.5
- test? (
- dev-java/hamcrest-core:0
- dev-java/junit:4
- dev-java/ant-junit4:0
- )"
-
-S=${WORKDIR}/${P/-log4j12/}/${PN}
-
-EANT_GENTOO_CLASSPATH="log4j,slf4j-api"
-EANT_TEST_GENTOO_CLASSPATH="${EANT_GENTOO_CLASSPATH},hamcrest-core,junit-4"
-JAVA_ANT_REWRITE_CLASSPATH="true"
-EANT_EXTRA_ARGS="-Dmaven.build.finalName=${PN}"
-
-java_prepare() {
- cp "${FILESDIR}"/${P}-maven-build.xml build.xml || die
- find "${WORKDIR}" -iname '*.jar' -delete
-}
-
-src_test() {
- java-pkg-2_src_test
-}
-
-src_install() {
- java-pkg_dojar target/${PN}.jar
- use doc && java-pkg_dojavadoc target/site/apidocs
- use source && java-pkg_dosrc src/main/java/org
-}
diff --git a/dev-java/slf4j-log4j12/slf4j-log4j12-1.7.6.ebuild b/dev-java/slf4j-log4j12/slf4j-log4j12-1.7.6.ebuild
deleted file mode 100644
index 2885081cbdc2..000000000000
--- a/dev-java/slf4j-log4j12/slf4j-log4j12-1.7.6.ebuild
+++ /dev/null
@@ -1,52 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-JAVA_PKG_IUSE="doc source"
-
-inherit java-pkg-2 java-ant-2
-
-DESCRIPTION="Simple Logging Facade for Java (SLF4J) log4j bindings"
-HOMEPAGE="http://www.slf4j.org/"
-SRC_URI="http://www.slf4j.org/dist/${P/-log4j12/}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="test"
-
-COMMON_DEPEND="
- dev-java/log4j:0
- dev-java/slf4j-api:0"
-RDEPEND="${COMMON_DEPEND}
- >=virtual/jre-1.5"
-DEPEND="${COMMON_DEPEND}
- >=virtual/jdk-1.5
- test? (
- dev-java/hamcrest-core:0
- dev-java/junit:4
- dev-java/ant-junit4:0
- )"
-
-S=${WORKDIR}/${P/-log4j12/}/${PN}
-
-EANT_GENTOO_CLASSPATH="log4j,slf4j-api"
-EANT_TEST_GENTOO_CLASSPATH="${EANT_GENTOO_CLASSPATH},hamcrest-core,junit-4"
-JAVA_ANT_REWRITE_CLASSPATH="true"
-EANT_EXTRA_ARGS="-Dmaven.build.finalName=${PN}"
-
-java_prepare() {
- cp "${FILESDIR}"/${P}-maven-build.xml build.xml || die
- find "${WORKDIR}" -iname '*.jar' -delete || die
-}
-
-src_test() {
- java-pkg-2_src_test
-}
-
-src_install() {
- java-pkg_dojar target/${PN}.jar
- use doc && java-pkg_dojavadoc target/site/apidocs
- use source && java-pkg_dosrc src/main/java/org
-}
diff --git a/dev-java/slf4j-log4j12/slf4j-log4j12-1.7.7.ebuild b/dev-java/slf4j-log4j12/slf4j-log4j12-1.7.7.ebuild
index b5b225e1673f..1a32b4013b9b 100644
--- a/dev-java/slf4j-log4j12/slf4j-log4j12-1.7.7.ebuild
+++ b/dev-java/slf4j-log4j12/slf4j-log4j12-1.7.7.ebuild
@@ -19,10 +19,11 @@ IUSE="test"
COMMON_DEPEND="
dev-java/log4j:0
dev-java/slf4j-api:0"
+
RDEPEND="${COMMON_DEPEND}
- >=virtual/jre-1.5"
+ >=virtual/jre-1.6"
DEPEND="${COMMON_DEPEND}
- >=virtual/jdk-1.5
+ >=virtual/jdk-1.6
test? (
dev-java/hamcrest-core:0
dev-java/junit:4
@@ -37,7 +38,7 @@ JAVA_ANT_REWRITE_CLASSPATH="true"
EANT_EXTRA_ARGS="-Dmaven.build.finalName=${PN}"
java_prepare() {
- cp "${FILESDIR}"/${PN}-1.7.6-maven-build.xml build.xml || die
+ cp "${FILESDIR}"/${P}-maven-build.xml build.xml || die
find "${WORKDIR}" -iname '*.jar' -delete || die
}