summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobinDX <robin9800xt@gmail.com>2016-05-02 08:59:31 +0800
committerDavide Pesavento <pesa@gentoo.org>2016-05-02 17:43:24 +0200
commit739b99a91cc2301a28cef8abbc93e504af2f79fd (patch)
treea6a436f21e325384cc07a7b7dcfcae8a65bf1bab
parentdev-qt/qtwebsockets: fix automagic dependency on qtnetwork[ssl] (diff)
downloadgentoo-739b99a91cc2301a28cef8abbc93e504af2f79fd.tar.gz
gentoo-739b99a91cc2301a28cef8abbc93e504af2f79fd.tar.bz2
gentoo-739b99a91cc2301a28cef8abbc93e504af2f79fd.zip
net-p2p/qbittorrent: Version bump
Closes: https://github.com/gentoo/gentoo/pull/1391
-rw-r--r--net-p2p/qbittorrent/Manifest1
-rw-r--r--net-p2p/qbittorrent/qbittorrent-3.3.4.ebuild85
2 files changed, 86 insertions, 0 deletions
diff --git a/net-p2p/qbittorrent/Manifest b/net-p2p/qbittorrent/Manifest
index 2cfa9cb10a31..710878d9c5fe 100644
--- a/net-p2p/qbittorrent/Manifest
+++ b/net-p2p/qbittorrent/Manifest
@@ -6,3 +6,4 @@ DIST qbittorrent-3.2.4.tar.xz 2664248 SHA256 7fc128e2809c3be4ea543cfaeefd922e032
DIST qbittorrent-3.2.5.tar.xz 2665980 SHA256 98f69c7324276c7c144738eb36b21a2d28d7f01a327104568f020887626e822b SHA512 a98c1cf8607558990d0698c50d35cd217bceeb4deffe69c590f902b1a9dabc5431496805614dbd3bb734f764c309023ede2f8a5cb014f40796301fa14ba63e90 WHIRLPOOL 6539bde802919351836d1bb2d880d5b28d51c97b109674f2ae3e54c9aa9ab52c5e58436371a34b7388d119d041cf9b2a597656e338808243309cbf631e03fe2b
DIST qbittorrent-3.3.2.tar.xz 2782172 SHA256 e9330a63e0939fef79c70d5a66dba616f00206a70386efbb82fb7c620a19af58 SHA512 2c09c1bbf18dfc181998343845e0f8164c29cb97eeccf3a7ab25753e8ccaa11cfb7372cf0ff1fc2a8c232a9ab4381a23c88aef791e37a3a7b4c0b92b537e25e6 WHIRLPOOL a2bf3f6aee46dc5bc58357ea8eb214b9a69116f470faa0a4b5aed9fc0ffdd340712a1424b128ab96273e75d6b1c83707765d01c0089ec550040bb63df236176e
DIST qbittorrent-3.3.3.tar.xz 2782616 SHA256 9c8d8bdc3fb2632019cb3ee5f811baaa41b41fe7ce542c753c6771bcc110db53 SHA512 2dd954e2518a2a99e271bf62d6db38a4e1788bb91c8b7552b94aab25dfb7b6cc7b4eb0ae49bb50d524127e8a357ea07b022c3a6e3b0593f6d2e7a2ce3abf6260 WHIRLPOOL e794a50215f33c2088b4782fd8733e11c33b42a45b5df2424bdf0fcee3c0929445f0d47b1e8b3526341f4ee9a4b8cd081da54a0c3019f79dea9b50a3bb5dcbad
+DIST qbittorrent-3.3.4.tar.xz 2841268 SHA256 c0d0d4b72c240f113b59a061146803bc1b7926d3d7f39b06b50a4d26f5ad91b8 SHA512 5cb94b6463d4baa1a994bee7dd5f9aee823d86d5428aff2719011b5f5340db5aaf35436f4f3be7c773e5560eb5f8ea12ea889505bfd40071401dd7ebf9835ec1 WHIRLPOOL 4406703fc459c9115e1d2e04e2a6a69149f7359fabaab284001bd1fec9fbd21c0aadca6836562d09d80390abf42388c864f6bc206080ee50f9c8ab4b80cca4e8
diff --git a/net-p2p/qbittorrent/qbittorrent-3.3.4.ebuild b/net-p2p/qbittorrent/qbittorrent-3.3.4.ebuild
new file mode 100644
index 000000000000..786574f54582
--- /dev/null
+++ b/net-p2p/qbittorrent/qbittorrent-3.3.4.ebuild
@@ -0,0 +1,85 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 python3_{3,4,5} )
+
+inherit eutils python-r1 qt4-r2 flag-o-matic
+
+DESCRIPTION="BitTorrent client in C++ and Qt"
+HOMEPAGE="http://www.qbittorrent.org/"
+
+MY_P=${P/_}
+if [[ ${PV} == *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/${PN}/qBittorrent.git"
+else
+ SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.xz"
+ KEYWORDS="~amd64 ~arm ~ppc64 ~x86"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="+dbus debug qt4 +qt5 webui +X"
+REQUIRED_USE="
+ ^^ ( qt4 qt5 )
+ dbus? ( X )
+"
+
+CDEPEND="
+ dev-libs/boost:=
+ >=dev-qt/qtsingleapplication-2.6.1_p20130904-r1[qt4?,qt5?,X?]
+ >=net-libs/rb_libtorrent-1.0.6
+ sys-libs/zlib
+ qt4? (
+ dev-qt/qtcore:4
+ dbus? ( dev-qt/qtdbus:4 )
+ X? ( dev-qt/qtgui:4 )
+ )
+ qt5? (
+ dev-qt/qtconcurrent:5
+ dev-qt/qtcore:5
+ dev-qt/qtnetwork:5
+ dev-qt/qtxml:5
+ dbus? ( dev-qt/qtdbus:5 )
+ X? ( dev-qt/qtgui:5
+ dev-qt/qtwidgets:5 )
+ )
+"
+DEPEND="${CDEPEND}
+ qt5? ( dev-qt/linguist-tools:5 )
+ virtual/pkgconfig
+"
+RDEPEND="${CDEPEND}
+ ${PYTHON_DEPS}"
+
+S=${WORKDIR}/${MY_P}
+DOCS=(AUTHORS Changelog README.md TODO)
+
+src_prepare() {
+ epatch_user
+ qt4-r2_src_prepare
+}
+
+src_configure() {
+ # See bug 569062
+ append-cppflags "-DBOOST_NO_CXX11_REF_QUALIFIERS"
+
+ # Custom configure script, econf fails
+ local myconf=(
+ ./configure
+ --prefix="${EPREFIX}/usr"
+ --with-qtsingleapplication=system
+ $(use dbus || echo --disable-qt-dbus)
+ $(use debug && echo --enable-debug)
+ $(use qt4 && echo --with-qt4)
+ $(use webui || echo --disable-webui)
+ $(use X || echo --disable-gui)
+ )
+
+ echo "${myconf[@]}"
+ "${myconf[@]}" || die "configure failed"
+ use qt4 && eqmake4
+ use qt5 && eqmake5
+}