summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2017-02-09 17:13:05 +0200
committerMart Raudsepp <leio@gentoo.org>2017-02-11 16:51:28 +0200
commit73a3782eb469c19e6fbdff5f77fb30e9e37b0481 (patch)
treeb5a1ac0ed0e8eb0e5a41ac01b3aa53ad3cbca1ed
parentmedia-plugins/gst-plugins-cdparanoia: bump to 1.10.3 (diff)
downloadgentoo-73a3782eb469c19e6fbdff5f77fb30e9e37b0481.tar.gz
gentoo-73a3782eb469c19e6fbdff5f77fb30e9e37b0481.tar.bz2
gentoo-73a3782eb469c19e6fbdff5f77fb30e9e37b0481.zip
media-libs/gst-plugins-good: bump to 1.10.3
Package-Manager: Portage-2.3.3, Repoman-2.3.1
-rw-r--r--media-libs/gst-plugins-good/Manifest1
-rw-r--r--media-libs/gst-plugins-good/gst-plugins-good-1.10.3.ebuild51
2 files changed, 52 insertions, 0 deletions
diff --git a/media-libs/gst-plugins-good/Manifest b/media-libs/gst-plugins-good/Manifest
index e01a7b653de2..aa191c7c0d88 100644
--- a/media-libs/gst-plugins-good/Manifest
+++ b/media-libs/gst-plugins-good/Manifest
@@ -1,2 +1,3 @@
DIST gst-plugins-good-0.10.31.tar.xz 2738016 SHA256 77a8436a7c0a15f876bad29616835046890df2bcaf72da02151bd91e3d292b64 SHA512 d153dcd5bb846450e9d76fe247f2b2e627e760feaad1bfd4c503a39af2128fad3630788463ea0d50539209236c864df0b2172ab9dac52f49cadff69ac7346809 WHIRLPOOL 952f65219d9e9645c9ab89b071c56d783e2c795fadbf59176e430ba86a5fcaeb6bfc93f0978d424158550a4526145b5567acf2ff1d59e0068241821d332fd3c9
+DIST gst-plugins-good-1.10.3.tar.xz 3426164 SHA256 4e07e93e34d4b93208f1579c21e7d91a236577b36f128a5332ffee85b4465955 SHA512 ae1523e374715b4f65509eb63d987118510fc4fe61b5ac2a98e4ec06feb2ec65899557976d796ea09644b32652f3a321aca462b8fe1621308e0c00dd6913e592 WHIRLPOOL 7c2c5fa9b21cfd35e7895beb947b6396ae55bd2f510fbe55b7696a0b68e7248e0cb04d5e4fe55e8d029ab03b5401fe20c5080a92b0b22532c9ac3dcb7167681f
DIST gst-plugins-good-1.8.3.tar.xz 3234712 SHA256 a1d6579ba203a7734927c24b90bf6590d846c5a5fcec01a48201018c8ad2827a SHA512 4f35f6e20c6a3b448bbf2690b2ad36a496b8b0efadc67e0fec218ed33856588a2b937020791f7ec4ab8a406ce82c178164349e31d4fabe8c7362716b44015f4a WHIRLPOOL 06592c3f076430422205db691c3a7fe95f46fe111ef2eeda9632c6e4004b8a7563a4a5dd8a5360ba59f22cc1e0a7d2baaecd65f7db335f141e52e24d1f667988
diff --git a/media-libs/gst-plugins-good/gst-plugins-good-1.10.3.ebuild b/media-libs/gst-plugins-good/gst-plugins-good-1.10.3.ebuild
new file mode 100644
index 000000000000..3c224f74ec9a
--- /dev/null
+++ b/media-libs/gst-plugins-good/gst-plugins-good-1.10.3.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+GST_ORG_MODULE="gst-plugins-good"
+
+inherit eutils flag-o-matic gstreamer
+
+DESCRIPTION="Basepack of plugins for GStreamer"
+HOMEPAGE="https://gstreamer.freedesktop.org/"
+
+LICENSE="LGPL-2.1+"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd"
+IUSE="+orc"
+
+RDEPEND="
+ >=dev-libs/glib-2.40.0:2[${MULTILIB_USEDEP}]
+ >=media-libs/gst-plugins-base-${PV}:${SLOT}[${MULTILIB_USEDEP}]
+ >=media-libs/gstreamer-${PV}:${SLOT}[${MULTILIB_USEDEP}]
+ >=app-arch/bzip2-1.0.6-r4[${MULTILIB_USEDEP}]
+ >=sys-libs/zlib-1.2.8-r1[${MULTILIB_USEDEP}]
+ orc? ( >=dev-lang/orc-0.4.17[${MULTILIB_USEDEP}] )
+"
+DEPEND="${RDEPEND}
+ >=dev-util/gtk-doc-am-1.12
+"
+
+multilib_src_configure() {
+ # Always enable optional bz2 support for matroska
+ # Always enable optional zlib support for qtdemux and matroska
+ # Many media files require these to work, as some container headers are often
+ # compressed, bug #291154
+ gstreamer_multilib_src_configure \
+ --enable-bz2 \
+ --enable-zlib \
+ --disable-examples \
+ --with-default-audiosink=autoaudiosink \
+ --with-default-visualizer=goom
+
+ if multilib_is_native_abi; then
+ ln -s "${S}"/docs/plugins/html docs/plugins/html || die
+ fi
+
+}
+
+multilib_src_install_all() {
+ DOCS="AUTHORS ChangeLog NEWS README RELEASE"
+ einstalldocs
+ prune_libtool_files --modules
+}