summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2020-10-01 13:06:13 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2020-10-01 13:06:31 -0500
commit73aa2c66a1aea7248280b94a1d65f52a17d91585 (patch)
tree9af4039f513ad7e400028720681dea93e46ebd70
parentapp-admin/ansible: 2.10.0 part deux (diff)
downloadgentoo-73aa2c66.tar.gz
gentoo-73aa2c66.tar.bz2
gentoo-73aa2c66.zip
sys-cluster/cinder: 16.2.0 bump
Package-Manager: Portage-3.0.4, Repoman-3.0.1 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
-rw-r--r--sys-cluster/cinder/Manifest2
-rw-r--r--sys-cluster/cinder/cinder-16.2.0.ebuild208
-rw-r--r--sys-cluster/cinder/cinder-2020.1.9999.ebuild4
3 files changed, 212 insertions, 2 deletions
diff --git a/sys-cluster/cinder/Manifest b/sys-cluster/cinder/Manifest
index 0e53d42c82bc..823fc7f95ef5 100644
--- a/sys-cluster/cinder/Manifest
+++ b/sys-cluster/cinder/Manifest
@@ -1,3 +1,5 @@
DIST cinder-16.1.0.tar.gz 5445353 BLAKE2B f7e121845b5db3de191c8782577f680cbb93fd26087113bd0c322eed4b27cf071977763a3eacb933d7b8894b56aaf042a115c2dfd20be47f89c9d45f0556c34a SHA512 97fb157eac466d869a707cd05d287a309512952e8f8267b58123b9108eb1c2df66c8d0b799a3fb83087645a09e679b7c6eb24baa4a21b751a1ce35dbb5bd3f4a
+DIST cinder-16.2.0.tar.gz 5484918 BLAKE2B f2259dd21c060280e856c053bece8fd635f289d8100710b177105227a5ce3a4c4e380b49261671294cf85975c9f665646cefe5f9d66d873e1938a7d141156f4e SHA512 586057d49f9c94daaf163dacf979e62d18be7489b43eeedfa7caa4d23a4a6060f455eea7162020319187466f308d0480a3efb047d0b34ce013f1b5c632e30755
DIST cinder.conf.sample-16.1.0 183294 BLAKE2B 5d0f28b9ad200d912c42c34ca030a5ec3660c57db332677e1b66b314a2865187862c83baf78d122fc0af7f73fbf4f0c7f04b9253882d228dcb863bfc88e37e72 SHA512 faf712a3da37af05e642b3c14f98ce8d4e3db5b736b208d7ca8a18be02ac5626c94b4ed314bd0030d5fa3771b325ba0f24ec3a45188d27fd9de79c97b56e2626
+DIST cinder.conf.sample-16.2.0 183294 BLAKE2B 5d0f28b9ad200d912c42c34ca030a5ec3660c57db332677e1b66b314a2865187862c83baf78d122fc0af7f73fbf4f0c7f04b9253882d228dcb863bfc88e37e72 SHA512 faf712a3da37af05e642b3c14f98ce8d4e3db5b736b208d7ca8a18be02ac5626c94b4ed314bd0030d5fa3771b325ba0f24ec3a45188d27fd9de79c97b56e2626
DIST cinder.conf.sample-2020.1.9999 183294 BLAKE2B 5d0f28b9ad200d912c42c34ca030a5ec3660c57db332677e1b66b314a2865187862c83baf78d122fc0af7f73fbf4f0c7f04b9253882d228dcb863bfc88e37e72 SHA512 faf712a3da37af05e642b3c14f98ce8d4e3db5b736b208d7ca8a18be02ac5626c94b4ed314bd0030d5fa3771b325ba0f24ec3a45188d27fd9de79c97b56e2626
diff --git a/sys-cluster/cinder/cinder-16.2.0.ebuild b/sys-cluster/cinder/cinder-16.2.0.ebuild
new file mode 100644
index 000000000000..3065830afe0f
--- /dev/null
+++ b/sys-cluster/cinder/cinder-16.2.0.ebuild
@@ -0,0 +1,208 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_7 )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+inherit distutils-r1 eutils linux-info
+
+DESCRIPTION="Cinder is the OpenStack Block storage service, a spin out of nova-volumes"
+HOMEPAGE="https://launchpad.net/cinder"
+
+if [[ ${PV} == *9999 ]];then
+ inherit git-r3
+ SRC_URI="https://dev.gentoo.org/~prometheanfire/dist/openstack/cinder/ussuri/cinder.conf.sample -> cinder.conf.sample-${PV}"
+ EGIT_REPO_URI="https://github.com/openstack/cinder.git"
+ EGIT_BRANCH="stable/ussuri"
+else
+ SRC_URI="https://dev.gentoo.org/~prometheanfire/dist/openstack/cinder/ussuri/cinder.conf.sample -> cinder.conf.sample-${PV}
+ https://tarballs.openstack.org/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm64 ~x86"
+fi
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE="+api +scheduler +volume infiniband iscsi lvm mysql +memcached postgres rdma sqlite +tcp test +tgt"
+RESTRICT="!test? ( test )"
+REQUIRED_USE="|| ( mysql postgres sqlite ) iscsi? ( tgt ) infiniband? ( rdma )"
+
+CDEPEND=">=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
+ !~dev-python/pbr-2.1.0"
+DEPEND="${CDEPEND}
+ app-admin/sudo"
+
+# >=dev-python/oauth2client-1.5.0[${PYTHON_USEDEP}] # do not include, upstream depricated
+RDEPEND="
+ ${CDEPEND}
+ >=dev-python/decorator-3.4.0[${PYTHON_USEDEP}]
+ >=dev-python/defusedxml-0.5.0[${PYTHON_USEDEP}]
+ >=dev-python/eventlet-0.22.0[${PYTHON_USEDEP}]
+ !~dev-python/eventlet-0.23.0[${PYTHON_USEDEP}]
+ !~dev-python/eventlet-0.25.0[${PYTHON_USEDEP}]
+ >=dev-python/greenlet-0.4.1[${PYTHON_USEDEP}]
+ >=dev-python/httplib2-0.9.1[${PYTHON_USEDEP}]
+ >=dev-python/iso8601-0.1.11[${PYTHON_USEDEP}]
+ >=dev-python/jsonschema-2.6.0[${PYTHON_USEDEP}]
+ >=dev-python/keystoneauth-3.7.0[${PYTHON_USEDEP}]
+ >=dev-python/keystonemiddleware-4.21.0[${PYTHON_USEDEP}]
+ >=dev-python/lxml-3.4.1[${PYTHON_USEDEP}]
+ !~dev-python/lxml-3.7.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-config-5.2.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-concurrency-3.26.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-context-2.19.2[${PYTHON_USEDEP}]
+ >=dev-python/oslo-db-4.35.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-log-3.36.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-messaging-6.4.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-middleware-3.31.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-policy-1.44.1[${PYTHON_USEDEP}]
+ >=dev-python/oslo-privsep-1.32.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-reports-1.18.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-rootwrap-5.8.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-serialization-2.18.0[${PYTHON_USEDEP}]
+ !~dev-python/oslo-serialization-2.19.1[${PYTHON_USEDEP}]
+ >=dev-python/oslo-service-1.24.0[${PYTHON_USEDEP}]
+ !~dev-python/oslo-service-1.28.1[${PYTHON_USEDEP}]
+ >=dev-python/oslo-upgradecheck-0.1.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-utils-3.34.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-versionedobjects-1.31.2[${PYTHON_USEDEP}]
+ >=dev-python/osprofiler-1.4.0[${PYTHON_USEDEP}]
+ >=dev-python/paramiko-2.4.0[${PYTHON_USEDEP}]
+ >=dev-python/paste-2.0.2[${PYTHON_USEDEP}]
+ >=dev-python/pastedeploy-1.5.0[${PYTHON_USEDEP}]
+ >=dev-python/psutil-3.2.2[${PYTHON_USEDEP}]
+ >=dev-python/pyparsing-2.1.0[${PYTHON_USEDEP}]
+ >=dev-python/python-barbicanclient-4.5.2[${PYTHON_USEDEP}]
+ >=dev-python/python-glanceclient-2.15.0[${PYTHON_USEDEP}]
+ >=dev-python/python-keystoneclient-3.15.0[${PYTHON_USEDEP}]
+ >=dev-python/python-novaclient-9.1.0[${PYTHON_USEDEP}]
+ >=dev-python/python-swiftclient-3.2.0[${PYTHON_USEDEP}]
+ >=dev-python/pytz-2013.6[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.14.2[${PYTHON_USEDEP}]
+ !~dev-python/requests-2.20.0[${PYTHON_USEDEP}]
+ >=dev-python/retrying-1.2.3[${PYTHON_USEDEP}]
+ !~dev-python/retrying-1.3.0[${PYTHON_USEDEP}]
+ >=dev-python/routes-2.3.1[${PYTHON_USEDEP}]
+ >=dev-python/taskflow-3.2.0[${PYTHON_USEDEP}]
+ >=dev-python/rtslib-fb-2.1.65[${PYTHON_USEDEP}]
+ >=dev-python/six-1.10.0[${PYTHON_USEDEP}]
+ sqlite? (
+ >=dev-python/sqlalchemy-1.0.10[sqlite,${PYTHON_USEDEP}]
+ !~dev-python/sqlalchemy-1.1.5[sqlite,${PYTHON_USEDEP}]
+ !~dev-python/sqlalchemy-1.1.6[sqlite,${PYTHON_USEDEP}]
+ !~dev-python/sqlalchemy-1.1.7[sqlite,${PYTHON_USEDEP}]
+ !~dev-python/sqlalchemy-1.1.8[sqlite,${PYTHON_USEDEP}]
+ )
+ mysql? (
+ >=dev-python/pymysql-0.7.6[${PYTHON_USEDEP}]
+ !~dev-python/pymysql-0.7.7[${PYTHON_USEDEP}]
+ >=dev-python/sqlalchemy-1.0.10[${PYTHON_USEDEP}]
+ !~dev-python/sqlalchemy-1.1.5[${PYTHON_USEDEP}]
+ !~dev-python/sqlalchemy-1.1.6[${PYTHON_USEDEP}]
+ !~dev-python/sqlalchemy-1.1.7[${PYTHON_USEDEP}]
+ !~dev-python/sqlalchemy-1.1.8[${PYTHON_USEDEP}]
+ )
+ postgres? (
+ >=dev-python/psycopg-2.5.0[${PYTHON_USEDEP}]
+ >=dev-python/sqlalchemy-1.0.10[${PYTHON_USEDEP}]
+ !~dev-python/sqlalchemy-1.1.5[${PYTHON_USEDEP}]
+ !~dev-python/sqlalchemy-1.1.6[${PYTHON_USEDEP}]
+ !~dev-python/sqlalchemy-1.1.7[${PYTHON_USEDEP}]
+ !~dev-python/sqlalchemy-1.1.8[${PYTHON_USEDEP}]
+ )
+ >=dev-python/sqlalchemy-migrate-0.11.0[${PYTHON_USEDEP}]
+ >=dev-python/stevedore-1.20.0[${PYTHON_USEDEP}]
+ >=dev-python/tabulate-0.8.5[${PYTHON_USEDEP}]
+ >=dev-python/webob-1.7.1[${PYTHON_USEDEP}]
+ >=dev-python/oslo-i18n-3.15.3[${PYTHON_USEDEP}]
+ >=dev-python/oslo-vmware-2.35.0[${PYTHON_USEDEP}]
+ >=dev-python/os-brick-2.2.0[${PYTHON_USEDEP}]
+ >=dev-python/os-win-3.0.0[${PYTHON_USEDEP}]
+ >=dev-python/tooz-1.58.0[${PYTHON_USEDEP}]
+ >=dev-python/google-api-python-client-1.4.2[${PYTHON_USEDEP}]
+ >=dev-python/castellan-0.16.0[${PYTHON_USEDEP}]
+ >=dev-python/cryptography-2.1[${PYTHON_USEDEP}]
+ >=dev-python/cursive-0.2.1[${PYTHON_USEDEP}]
+ iscsi? (
+ tgt? ( sys-block/tgt )
+ sys-block/open-iscsi
+ )
+ lvm? ( sys-fs/lvm2 )
+ memcached? ( net-misc/memcached )
+ app-emulation/qemu
+ sys-fs/sysfsutils
+ acct-user/cinder
+ acct-group/cinder"
+# qemu is needed for image conversion
+
+#PATCHES=(
+#)
+
+pkg_pretend() {
+ linux-info_pkg_setup
+ CONFIG_CHECK_MODULES=""
+ if use tcp; then
+ CONFIG_CHECK_MODULES+="SCSI_ISCSI_ATTRS ISCSI_TCP "
+ fi
+ if use rdma; then
+ CONFIG_CHECK_MODULES+="INFINIBAND_ISER "
+ fi
+ if use infiniband; then
+ CONFIG_CHECK_MODULES+="INFINIBAND_IPOIB INFINIBAND_USER_MAD INFINIBAND_USER_ACCESS"
+ fi
+ if linux_config_exists; then
+ for module in ${CONFIG_CHECK_MODULES}; do
+ linux_chkconfig_present ${module} || ewarn "${module} needs to be enabled"
+ done
+ fi
+}
+
+python_prepare_all() {
+ sed -i '/^hacking/d' test-requirements.txt || die
+ # only used for docs
+ sed -i '/^sphinx-feature-classification/d' requirements.txt || die
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ # Let's track progress of this # https://bugs.launchpad.net/swift/+bug/1249727
+ nosetests -I test_wsgi.py cinder/tests/ || die "tests failed under python2.7"
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+ keepdir /etc/cinder
+ dodir /etc/cinder/rootwrap.d
+
+ for svc in api scheduler volume; do
+ newinitd "${FILESDIR}/cinder.initd" cinder-${svc}
+ done
+
+ insinto /etc/cinder
+ insopts -m0640 -o cinder -g cinder
+ doins "etc/cinder/api-httpd.conf"
+ doins "etc/cinder/logging_sample.conf"
+ doins "etc/cinder/rootwrap.conf"
+ doins "etc/cinder/api-paste.ini"
+ doins "etc/cinder/resource_filters.json"
+ newins "${DISTDIR}/cinder.conf.sample-${PV}" "cinder.conf.sample"
+ insinto /etc/cinder/rootwrap.d
+ doins "etc/cinder/rootwrap.d/volume.filters"
+
+ dodir /var/log/cinder
+ fowners cinder:cinder /var/log/cinder
+
+ #add sudoers definitions for user nova
+ insinto /etc/sudoers.d/
+ insopts -m 0440 -o root -g root
+ newins "${FILESDIR}/cinder.sudoersd" cinder
+ # stupid python
+ rm -r "${ED}"/usr/etc
+}
+
+pkg_postinst() {
+ if use iscsi ; then
+ elog "Cinder needs tgtd to be installed and running to work with iscsi"
+ elog "it also needs 'include /var/lib/cinder/volumes/*' in /etc/tgt/targets.conf"
+ fi
+}
diff --git a/sys-cluster/cinder/cinder-2020.1.9999.ebuild b/sys-cluster/cinder/cinder-2020.1.9999.ebuild
index a22eb94ab54d..3065830afe0f 100644
--- a/sys-cluster/cinder/cinder-2020.1.9999.ebuild
+++ b/sys-cluster/cinder/cinder-2020.1.9999.ebuild
@@ -4,6 +4,7 @@
EAPI=7
PYTHON_COMPAT=( python3_7 )
+DISTUTILS_USE_SETUPTOOLS=rdepend
inherit distutils-r1 eutils linux-info
DESCRIPTION="Cinder is the OpenStack Block storage service, a spin out of nova-volumes"
@@ -28,8 +29,7 @@ REQUIRED_USE="|| ( mysql postgres sqlite ) iscsi? ( tgt ) infiniband? ( rdma )"
CDEPEND=">=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
!~dev-python/pbr-2.1.0"
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
- ${CDEPEND}
+DEPEND="${CDEPEND}
app-admin/sudo"
# >=dev-python/oauth2client-1.5.0[${PYTHON_USEDEP}] # do not include, upstream depricated