summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2016-12-24 09:10:13 +0100
committerHans de Graaff <graaff@gentoo.org>2016-12-24 09:21:41 +0100
commit73c4e54a84dcb90aa24d4ebd729774dd15d555be (patch)
tree7ef897e6b2e93de1a8ab5717aad523176c8327d4
parentnet-misc/openssh: drop X509 glue #603610 (diff)
downloadgentoo-73c4e54a.tar.gz
gentoo-73c4e54a.tar.bz2
gentoo-73c4e54a.zip
dev-ruby/activesupport: add Rails 5.0.1
Package-Manager: portage-2.3.0
-rw-r--r--dev-ruby/activesupport/Manifest1
-rw-r--r--dev-ruby/activesupport/activesupport-5.0.1.ebuild71
2 files changed, 72 insertions, 0 deletions
diff --git a/dev-ruby/activesupport/Manifest b/dev-ruby/activesupport/Manifest
index 41b698bf6f76..e39e66fd99a5 100644
--- a/dev-ruby/activesupport/Manifest
+++ b/dev-ruby/activesupport/Manifest
@@ -3,3 +3,4 @@ DIST rails-4.2.6.tgz 4179056 SHA256 68bf40c27e0ee75b26c7b48fbe357f024b8d6d322a4e
DIST rails-4.2.7.1.tgz 4181681 SHA256 bfa7854f1b35e449b78db2af83fe660f17b101a487728fcfc6fb623967fb4783 SHA512 b926b59822ddd0837a402d798a7f2c9152d9916805153d3cad081d47e692992cdf3c7aaf8af47b061e3d78f8f23357674c5a9ed6c945b082e2d8c909281f5527 WHIRLPOOL da253d85bdc93c500a220b7688597dcb86c192226f5532619d8bb081440326e4dba8cc78f3bf946f16fe67e28beae0274649533aaf966177295daff7c4bf1188
DIST rails-4.2.7.tgz 4181136 SHA256 31005bc5892ef4d478016f4ef66c7708d0bfc440d917dac8a5e84a461fa2a980 SHA512 89df542cac1cf31be376fff3d919860168ce5df0dcd51035411a7f82a59a6fc27d8aecdd92dc20dee59831745ecab1ff8e404756dbc85a1ec08c3f2c1721e7dc WHIRLPOOL 15653098db0702b5e76e6fc4eba0f4fa6eaf73b30a23d1bf10e08cd999452608325ebba25c87b85d790ab49cf8ba216f40ee4dc25bd072cc8be89546af378542
DIST rails-5.0.0.1.tgz 6139334 SHA256 3cbbe71d80c2813dde0d2bfa61aea57c8e6a1a3b2a81e6b211dbf2f2a4be2add SHA512 8e820f26543e8ad05b01a75e4e4df1adb229b5d90cfccd1b63d77a6ab25f232d24a875cd5630648e58c6598d741a3d35b2a76fd7e99a0f06971f84ee63ada56f WHIRLPOOL 9aed4fab1c8ea06185de5320ed85d6d51ed0babf6143c3d70df352adea5721c3074bb80c351b395752b2d8c60f5fcb8982b086e507836b9867d6597f2d72df4c
+DIST rails-5.0.1.tgz 6026895 SHA256 7ee54f0175a7738e7c169fa8dc2e4ee30ba8407768804aaa56a6889525315f4e SHA512 d5c25b284b24399f81a5a8aec9c4b581d2caeff6d1f73b71dab2a50b8f55b4a86c1d723f0bae9b40bdb3d949e3d5eb65b7522bf9ca316676cafdd2cf648abb33 WHIRLPOOL 142190cc4f8edafdc39cdbab2586127815e145f4d4fa5a89f3c9b2377e70bc29f6d410359c0498fe1c83c8f811b64884ae0d7e06b20d8ffb5ec44c6b66cde49b
diff --git a/dev-ruby/activesupport/activesupport-5.0.1.ebuild b/dev-ruby/activesupport/activesupport-5.0.1.ebuild
new file mode 100644
index 000000000000..27418ff75c52
--- /dev/null
+++ b/dev-ruby/activesupport/activesupport-5.0.1.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+USE_RUBY="ruby22 ruby23"
+
+RUBY_FAKEGEM_TASK_DOC=""
+
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.rdoc"
+
+RUBY_FAKEGEM_GEMSPEC="activesupport.gemspec"
+
+RUBY_FAKEGEM_BINWRAP=""
+
+inherit ruby-fakegem versionator
+
+DESCRIPTION="Utility Classes and Extension to the Standard Library"
+HOMEPAGE="https://github.com/rails/rails"
+SRC_URI="https://github.com/rails/rails/archive/v${PV}.tar.gz -> rails-${PV}.tgz"
+
+LICENSE="MIT"
+SLOT="$(get_version_component_range 1-2)"
+KEYWORDS="~alpha ~amd64 ~arm ~x86 ~amd64-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+RUBY_S="rails-${PV}/${PN}"
+
+ruby_add_rdepend "
+ >=dev-ruby/concurrent-ruby-1.0.2:1
+ >=dev-ruby/i18n-0.7:0.7
+ >=dev-ruby/tzinfo-1.1:1
+ >=dev-ruby/minitest-5.1:5"
+
+# memcache-client, nokogiri, and builder are not strictly
+# needed, but there are tests using this code.
+ruby_add_bdepend "test? (
+ >=dev-ruby/dalli-2.2.1
+ >=dev-ruby/nokogiri-1.4.5
+ >=dev-ruby/builder-3.1.0
+ >=dev-ruby/listen-3.0.5:3
+ dev-ruby/rack
+ dev-ruby/mocha:0.14
+ <dev-ruby/minitest-5.4
+ )"
+
+all_ruby_prepare() {
+ # Set the secure permissions that tests expect.
+ chmod 0755 "${HOME}" || die "Failed to fix permissions on home"
+
+ # Remove items from the common Gemfile that we don't need for this
+ # test run. This also requires handling some gemspecs.
+ sed -i -e "/\(system_timer\|sdoc\|w3c_validators\|pg\|execjs\|jquery-rails\|mysql\|journey\|ruby-prof\|stackprof\|benchmark-ips\|kindlerb\|turbolinks\|coffee-rails\|debugger\|sprockets-rails\|redcarpet\|bcrypt\|uglifier\|minitest\|sprockets\|stackprof\|rack-cache\|sqlite\)/ s:^:#:" \
+ -e '/:job/,/end/ s:^:#:' \
+ -e '/group :doc/,/^end/ s:^:#:' \
+ -e 's/gemspec/gemspec path: "activesupport"/' \
+ -e '5igem "builder"; gem "rack"' ../Gemfile || die
+ rm ../Gemfile.lock || die
+
+ # Avoid test not working within portage
+ sed -i -e '/test_messing_with_either_encrypted_values_causes_failure/askip "gentoo"' test/message_encryptor_test.rb || die
+
+ # Avoid tests failing since test_order cattr is also seen as a test
+ # method
+ rm -f test/xml_mini/libxml{,sax}_engine_test.rb || die
+
+ # Avoid tests that seem to trigger race conditions. This might be
+ # fixed upstream in 7bd41994480c17db71fdc07e3447ade929eaa386
+ rm -f test/evented_file_update_checker_test.rb || die
+}