summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastian Pipping <sping@gentoo.org>2023-12-25 16:05:37 +0100
committerSebastian Pipping <sping@gentoo.org>2023-12-25 16:05:37 +0100
commit73f5c0151f6519f36046a7228937ae938e42559e (patch)
tree9787e4434994997381b28a0bd6cd717c800c0d25
parentapp-forensics/honggfuzz: add missing patch for 2.6 (diff)
downloadgentoo-73f5c0151f6519f36046a7228937ae938e42559e.tar.gz
gentoo-73f5c0151f6519f36046a7228937ae938e42559e.tar.bz2
gentoo-73f5c0151f6519f36046a7228937ae938e42559e.zip
app-admin/ttyplot: 1.6.0
Signed-off-by: Sebastian Pipping <sping@gentoo.org>
-rw-r--r--app-admin/ttyplot/Manifest1
-rw-r--r--app-admin/ttyplot/ttyplot-1.6.0.ebuild25
2 files changed, 26 insertions, 0 deletions
diff --git a/app-admin/ttyplot/Manifest b/app-admin/ttyplot/Manifest
index 4da5d54ca4fd..ed12af6c503a 100644
--- a/app-admin/ttyplot/Manifest
+++ b/app-admin/ttyplot/Manifest
@@ -1,2 +1,3 @@
DIST ttyplot-1.5.1.gh.tar.gz 43629 BLAKE2B 98c46c27587a6ed98f7ed146b402dcbb6f5835f2f34780ccd706dc56b674dec3792dfb8bf84c8d260c040952ef0431341df09c16d032f32d4621c5f3971857d7 SHA512 3eb255375366bc3a773364388dc709f4f5b9961e1c99404dfd192503b20a8eb064f5089811b8c894a8214f84d24e14d040adb0b34712915311eb28972586bf0b
DIST ttyplot-1.5.2.gh.tar.gz 44023 BLAKE2B a8ebf0529f1d3e65ec5887d0fc45c51840ddb26ed982ea5bc2e47d66c03878a642576c7b3052c717f296af9b3fe0fca15080cbf252cb274238e6b664372f219e SHA512 ffdeba5d1ad4a0abbb04d76d914a2f209471ac6f601447c4693de594b0cdb1c162e42b49bb1bf0bb50e2d9b0d9b0452fb9f3d8949c5b9143cc9b6faae50ad28f
+DIST ttyplot-1.6.0.gh.tar.gz 53658 BLAKE2B fa864189902dc049eaae0fc8911e68eb7fee97282d102d61637b4f833a60bc221c791e8c75d3952d63d51187c0edcd908844fee28bbc380d0f1dd7e59eb96086 SHA512 bbdc2abc9744b73928c6af6fdd04c2856aece15b7c711bf2ac5a956c90c02f1d026f270fb5e7ff8dd72c06e6fea329a8e2e553cc620383b702e37653076875f9
diff --git a/app-admin/ttyplot/ttyplot-1.6.0.ebuild b/app-admin/ttyplot/ttyplot-1.6.0.ebuild
new file mode 100644
index 000000000000..b2ae208ee667
--- /dev/null
+++ b/app-admin/ttyplot/ttyplot-1.6.0.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+
+DESCRIPTION="Realtime plotting utility with data input from stdin"
+HOMEPAGE="https://github.com/tenox7/ttyplot"
+SRC_URI="https://github.com/tenox7/ttyplot/archive/refs/tags/${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="virtual/pkgconfig"
+DEPEND="${RDEPEND}
+ sys-libs/ncurses[tinfo]"
+
+src_install() {
+ local args=(
+ PREFIX=/usr
+ MANPREFIX=/usr/share/man
+ DESTDIR="${D}"
+ )
+ emake "${args[@]}" install
+}