summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLouis Sautier <sbraz@gentoo.org>2020-10-21 21:12:41 +0200
committerLouis Sautier <sbraz@gentoo.org>2020-10-21 21:18:55 +0200
commit73f67cfe1742a08be85abf964084425cab3d7ae9 (patch)
treec274ac38a5bc467d05ab855e3aa8610fc925a8ff
parentdev-python/dominate: bump to 2.6.0 (diff)
downloadgentoo-73f67cfe1742a08be85abf964084425cab3d7ae9.tar.gz
gentoo-73f67cfe1742a08be85abf964084425cab3d7ae9.tar.bz2
gentoo-73f67cfe1742a08be85abf964084425cab3d7ae9.zip
dev-python/MechanicalSoup: add Python 3.9 support
Also use distutils_enable_tests and remove unnecessary sed. Package-Manager: Portage-3.0.8, Repoman-3.0.1 Signed-off-by: Louis Sautier <sbraz@gentoo.org>
-rw-r--r--dev-python/MechanicalSoup/MechanicalSoup-0.12.0.ebuild18
1 files changed, 5 insertions, 13 deletions
diff --git a/dev-python/MechanicalSoup/MechanicalSoup-0.12.0.ebuild b/dev-python/MechanicalSoup/MechanicalSoup-0.12.0.ebuild
index 14b661fd6590..25a8f0174d72 100644
--- a/dev-python/MechanicalSoup/MechanicalSoup-0.12.0.ebuild
+++ b/dev-python/MechanicalSoup/MechanicalSoup-0.12.0.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( pypy3 python3_{6,7,8} )
+PYTHON_COMPAT=( pypy3 python3_{6..9} )
inherit distutils-r1
@@ -14,8 +14,7 @@ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE="examples test"
-RESTRICT="!test? ( test )"
+IUSE="examples"
RDEPEND="
>=dev-python/beautifulsoup-4.0[${PYTHON_USEDEP}]
@@ -25,26 +24,19 @@ RDEPEND="
"
BDEPEND="
test? (
- ${RDEPEND}
>=dev-python/requests-mock-1.3.0[${PYTHON_USEDEP}]
- dev-python/pytest[${PYTHON_USEDEP}]
dev-python/pytest-httpbin[${PYTHON_USEDEP}]
dev-python/pytest-mock[${PYTHON_USEDEP}]
)
"
+distutils_enable_tests pytest
distutils_enable_sphinx docs
python_prepare_all() {
- # We don't need pytest-runner to run tests via pytest
- sed -i "s/'pytest-runner'//" setup.py || die
- distutils-r1_python_prepare_all
-}
-
-python_test() {
# Override pytest options to skip coverage and flake8
- pytest -vv --override-ini="addopts=" \
- || die "tests failed with ${EPYTHON}"
+ sed -i -e '/^addopts =/d' setup.cfg || die
+ distutils-r1_python_prepare_all
}
python_install_all() {