summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-03-04 05:01:37 +0100
committerMichał Górny <mgorny@gentoo.org>2023-03-04 05:50:29 +0100
commit73fd86bc47770c60206821403ceb8016415db20c (patch)
treee878bc558c53f18fb446e2b37cd206aa0c92be4e
parentdev-python/boto3: Bump to 1.26.84 (diff)
downloadgentoo-73fd86bc.tar.gz
gentoo-73fd86bc.tar.bz2
gentoo-73fd86bc.zip
app-admin/awscli: Bump to 1.27.84
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--app-admin/awscli/Manifest1
-rw-r--r--app-admin/awscli/awscli-1.27.84.ebuild80
2 files changed, 81 insertions, 0 deletions
diff --git a/app-admin/awscli/Manifest b/app-admin/awscli/Manifest
index d4c9d39e86b7..092cf20fd665 100644
--- a/app-admin/awscli/Manifest
+++ b/app-admin/awscli/Manifest
@@ -4,3 +4,4 @@ DIST aws-cli-1.27.80.gh.tar.gz 2377306 BLAKE2B 3a0e6c66bb9c373456bb05537f20ad339
DIST aws-cli-1.27.81.gh.tar.gz 2377937 BLAKE2B 7323c06cab727066c6541772478a961bc4f7b409b0910e57c79207fad928b7ec82d1b0048983e64d8a8fa3e7ef69d1898cadf2fbd1ea560e05d7a2582e726f88 SHA512 19cff28cd4721df32079795cfab852a11b36f1a2d0335567f0f1dae48eaaf268ae04163dac960a2d543be869f39e8c55e6a0bcee746ccbab29bcf8f37881c305
DIST aws-cli-1.27.82.gh.tar.gz 2378047 BLAKE2B ca55c81431afeed336e01b7cb6840a05856d3e25f8c06a1169907fb3536aa45393f35995d1683bea3685e91d196b67bdeed487ba46e896f774caac0e63cbc9be SHA512 b760dd417a87e1804ef5bb7b4e8ca22ef750c75a63455fac7f17f564f8e591c459bfef225acb56a9a3b3ad1ac94458d4731fb4a56147a2a6fd59ec8113b2df41
DIST aws-cli-1.27.83.gh.tar.gz 2378425 BLAKE2B 7784274aa3879b59b9ac51a0d687526261c27d4285ca279004e301b156e08bfc07f89b4584521093db0a3a9f42f47c7bca607c686763044f73495623a9e6f366 SHA512 e9748ada13533ab67249806fe09261634cdc2858bcc99b818a7ff5cb1dd2ce8f9c52f344fa7a5f19464d1500e91ff35b3e0a7ce4d2ac2adaecb939c4c9a2a70d
+DIST aws-cli-1.27.84.gh.tar.gz 2378573 BLAKE2B b85d7eeb22b0a2a9264b49a27f2e3d3da9d35dbc44de205521c39522fcec31948ef8b67dfc3ce919b772ba85fa59cfc5a4d69e3c67aadd9cbb029da883ad699e SHA512 1d31d1b800b0795a8473af0dc334feb69f62d2fd8fcb88e0e4e7e4068435f6f37792d2c9382ec1b0c6b074d5eca09142e52f6e36c472145df9d57db2cc4ee078
diff --git a/app-admin/awscli/awscli-1.27.84.ebuild b/app-admin/awscli/awscli-1.27.84.ebuild
new file mode 100644
index 000000000000..62c19f3a63fb
--- /dev/null
+++ b/app-admin/awscli/awscli-1.27.84.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit bash-completion-r1 distutils-r1 multiprocessing
+
+MY_P=aws-cli-${PV}
+DESCRIPTION="Universal Command Line Environment for AWS"
+HOMEPAGE="
+ https://github.com/aws/aws-cli/
+ https://pypi.org/project/awscli/
+"
+SRC_URI="
+ https://github.com/aws/aws-cli/archive/${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+# botocore is x.(y+2).z
+BOTOCORE_PV="$(ver_cut 1).$(( $(ver_cut 2) + 2)).$(ver_cut 3-)"
+RDEPEND="
+ >=dev-python/botocore-${BOTOCORE_PV}[${PYTHON_USEDEP}]
+ dev-python/colorama[${PYTHON_USEDEP}]
+ dev-python/docutils[${PYTHON_USEDEP}]
+ dev-python/rsa[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.6.0[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ !app-admin/awscli-bin
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-forked[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ # do not rely on bundled deps in botocore (sic!)
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+ # strip overzealous upper bounds on requirements
+ sed -i -e 's:,<[0-9.]*::' -e 's:==:>=:' setup.py || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # TODO
+ tests/functional/eks/test_kubeconfig.py::TestKubeconfigLoader::test_load_simple
+ tests/unit/customizations/eks/test_update_kubeconfig.py::TestKubeconfigSelector::test_choose_env_only
+ tests/unit/customizations/eks/test_update_kubeconfig.py::TestKubeconfigSelector::test_choose_existing
+ tests/unit/customizations/eks/test_kubeconfig.py::TestKubeconfigValidator::test_valid
+ )
+
+ # integration tests require AWS credentials and Internet access
+ epytest tests/{functional,unit} -n "$(makeopts_jobs)" --forked
+}
+
+python_install_all() {
+ newbashcomp bin/aws_bash_completer aws
+
+ insinto /usr/share/zsh/site-functions
+ newins bin/aws_zsh_completer.sh _aws
+
+ distutils-r1_python_install_all
+
+ rm "${ED}"/usr/bin/{aws.cmd,aws_bash_completer,aws_zsh_completer.sh} || die
+}