summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2021-02-09 16:48:30 -0600
committerMatthew Thode <prometheanfire@gentoo.org>2021-02-09 16:52:48 -0600
commit741989bc22181ad24e32218fd42531d26f83bb64 (patch)
treecd60d988b109d05f79d7830a52f333fc2f853872
parentdev-lang/jimtcl: Stabilize 0.78-r2 amd64, #769791 (diff)
downloadgentoo-741989bc.tar.gz
gentoo-741989bc.tar.bz2
gentoo-741989bc.zip
app-admin/puppet: 7.4.0 bump
Package-Manager: Portage-3.0.13, Repoman-3.0.2 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
-rw-r--r--app-admin/puppet/Manifest1
-rw-r--r--app-admin/puppet/puppet-7.4.0.ebuild133
2 files changed, 134 insertions, 0 deletions
diff --git a/app-admin/puppet/Manifest b/app-admin/puppet/Manifest
index d0c2421fe643..aa0d629388fe 100644
--- a/app-admin/puppet/Manifest
+++ b/app-admin/puppet/Manifest
@@ -3,3 +3,4 @@ DIST puppet-5.5.22.tar.gz 2998132 BLAKE2B 8662c89190d0904fe44ffeca1cf9a9ddca40d5
DIST puppet-6.19.1.tar.gz 2917976 BLAKE2B 06019b465699494c3c5045d8d3f617046583f8bb5ebff4e72991bcf5f1ca76b4e00f56af79bbcd7ab849439fc5e627840ef08b92f586441c0cb0bb3d51805f7f SHA512 4e8a3c8d46b6aa67c31da4b510dfc32a187937af213efb9f2f0b6625b29995cdfa8cbca384ad857c19e47ae4878127564756a809c2afdff4883038249395ff01
DIST puppet-7.1.0.tar.gz 2827602 BLAKE2B 5e15c7304c7b91e40b95096482d6a71a3e9e1686f769c4c0334a533cd8b6faf31d4e126585c9b48c15bb524930e0410bff32201dd01d7faeb7487c29075f7477 SHA512 7cb5f8c472d28012a0b93893792611dd03081c7100be57e2fab60a0dabe164081fc40195d562ef8cf5e2d67f9d32f26704ecedee9cc772e568a116e12af70cda
DIST puppet-7.3.0.tar.gz 2855997 BLAKE2B 38a02a036d82be3ae727f7433b80ee1bdbb66f6fe10dd2ac37d3191fa6bcacac8cff84ae048d449564703448a87860fd9debdc043a47e7dfbcab69f6dedf479f SHA512 811e2a182af7bc8038750d99feb526b261b6c3633d5492fc2e14ab9f8902bb54d3f651730efb6f06001b96f550a9957d8604ffd30d489f038200d1359d91e98d
+DIST puppet-7.4.0.tar.gz 2857763 BLAKE2B 980180d10c3329f8c94f02c6a8b403d88a3836fcc5567fd00eb4e2b4ae63d7a03709f3f14a337cdface62be04f9bb9082436f69b95f8d37996a9a933801a163a SHA512 ffb4ffb5121fcbd4b61ab1ad51fce96c1f2415b85ec785c858721a7f5604a6a8de4d595b6806657b9b1757e70763b2c495ca4d8ee694d668532cd15dd38a9c7f
diff --git a/app-admin/puppet/puppet-7.4.0.ebuild b/app-admin/puppet/puppet-7.4.0.ebuild
new file mode 100644
index 000000000000..5b564665270e
--- /dev/null
+++ b/app-admin/puppet/puppet-7.4.0.ebuild
@@ -0,0 +1,133 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+USE_RUBY="ruby24 ruby25 ruby26 ruby27"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_TASK_DOC="doc:all"
+
+RUBY_FAKEGEM_EXTRAINSTALL="locales"
+
+inherit eutils ruby-fakegem eapi7-ver
+
+DESCRIPTION="A system automation and configuration management software."
+HOMEPAGE="https://puppet.com/"
+SRC_URI="http://downloads.puppetlabs.com/puppet/${P}.tar.gz"
+
+LICENSE="Apache-2.0 GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~x86"
+IUSE="augeas diff doc emacs ldap rrdtool selinux shadow sqlite vim-syntax"
+RESTRICT="test"
+
+ruby_add_rdepend "
+ dev-ruby/hiera
+ dev-ruby/json:=
+ dev-ruby/semantic_puppet
+ >=dev-ruby/facter-3.0.0
+ dev-ruby/concurrent-ruby
+ augeas? ( dev-ruby/ruby-augeas )
+ diff? ( dev-ruby/diff-lcs )
+ doc? ( dev-ruby/rdoc )
+ ldap? ( dev-ruby/ruby-ldap )
+ shadow? ( dev-ruby/ruby-shadow )
+ sqlite? ( dev-ruby/sqlite3 )
+ virtual/ruby-ssl
+ dev-ruby/hocon"
+
+ruby_add_bdepend "
+ doc? ( dev-ruby/yard )
+ test? (
+ dev-ruby/mocha
+ dev-ruby/rack
+ dev-ruby/rspec-its
+ )"
+# this should go in the above lists, but isn't because of test deps not being keyworded
+# dev-ruby/rspec-collection_matchers
+
+RDEPEND+=" ${RDEPEND}
+ rrdtool? ( >=net-analyzer/rrdtool-1.2.23[ruby] )
+ selinux? (
+ sys-libs/libselinux[ruby]
+ sec-policy/selinux-puppet
+ )
+ vim-syntax? ( >=app-vim/puppet-syntax-3.0.1 )
+ >=app-portage/eix-0.18.0
+ acct-user/puppet
+ acct-group/puppet"
+PDEPEND="emacs? ( >=app-emacs/puppet-mode-0.3-r1 )"
+
+all_ruby_prepare() {
+ # Avoid spec that require unpackaged json-schema.
+ rm spec/lib/matchers/json.rb $( grep -Rl matchers/json spec) || die
+
+ # fix systemd path
+ epatch "${FILESDIR}/puppet-systemd.patch"
+
+ # Avoid specs that can only run in the puppet.git repository. This
+ # should be narrowed down to the specific specs.
+ rm spec/integration/parser/compiler_spec.rb || die
+
+ # Avoid failing spec that need further investigation.
+ rm spec/unit/module_tool/metadata_spec.rb || die
+}
+
+each_ruby_install() {
+ each_fakegem_install
+# dosym "/usr/$(get_libdir)/ruby/gems/$(ruby_get_version)/gems/${P}" "/usr/$(get_libdir)/ruby/gems/$(ruby_get_version)/gems/${PN}"
+}
+
+all_ruby_install() {
+ all_fakegem_install
+
+ # systemd stuffs
+ insinto /usr/lib/systemd/system
+ doins "${WORKDIR}/all/${P}/ext/systemd/puppet.service"
+
+ # tmpfiles stuff
+ insinto /usr/lib/tmpfiles.d
+ newins "${FILESDIR}/tmpfiles.d" "puppet.conf"
+
+ # openrc init stuff
+ newinitd "${FILESDIR}"/puppet.init-4.x puppet
+
+ keepdir /etc/puppetlabs/puppet/ssl
+
+ keepdir /var/lib/puppet/facts
+ keepdir /var/lib/puppet/files
+ fowners -R puppet:puppet /var/lib/puppet
+
+ fperms 0750 /var/lib/puppet
+
+ fperms 0750 /etc/puppetlabs
+ fperms 0750 /etc/puppetlabs/puppet
+ fperms 0750 /etc/puppetlabs/puppet/ssl
+ fowners -R :puppet /etc/puppetlabs
+ fowners -R :puppet /var/lib/puppet
+
+ if use ldap ; then
+ insinto /etc/openldap/schema; doins ext/ldap/puppet.schema
+ fi
+
+ # ext and examples files
+ for f in $(find ext examples -type f) ; do
+ docinto "$(dirname ${f})"; dodoc "${f}"
+ done
+}
+
+pkg_postinst() {
+ elog
+ elog "Please, *don't* include the --ask option in EMERGE_EXTRA_OPTS as this could"
+ elog "cause puppet to hang while installing packages."
+ elog
+ elog "Portage Puppet module with Gentoo-specific resources:"
+ elog "http://forge.puppetlabs.com/gentoo/portage"
+ elog
+ elog "If updating from puppet 5 to 6, keep in mind that webrick (server/master)"
+ elog "suppert was removed for >=6.x, please migrate to puppetserver if you have"
+ elog "not already done so."
+ elog
+}