summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2021-10-31 06:53:19 +0100
committerHans de Graaff <graaff@gentoo.org>2021-10-31 06:57:10 +0100
commit743b89948d1e2fe68c665e285265b8d2d797b744 (patch)
treebf3298ad01abf1555134afff0aed2ef368aead22
parentdev-ruby/ferret: EAPI 8; fix extension install (diff)
downloadgentoo-743b89948d1e2fe68c665e285265b8d2d797b744.tar.gz
gentoo-743b89948d1e2fe68c665e285265b8d2d797b744.tar.bz2
gentoo-743b89948d1e2fe68c665e285265b8d2d797b744.zip
dev-ruby/google-protobuf: cleanup
Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Hans de Graaff <graaff@gentoo.org>
-rw-r--r--dev-ruby/google-protobuf/Manifest2
-rw-r--r--dev-ruby/google-protobuf/google-protobuf-3.12.4.ebuild40
-rw-r--r--dev-ruby/google-protobuf/google-protobuf-3.13.0.ebuild40
3 files changed, 0 insertions, 82 deletions
diff --git a/dev-ruby/google-protobuf/Manifest b/dev-ruby/google-protobuf/Manifest
index 67d612efd6bb..d8f8fde360af 100644
--- a/dev-ruby/google-protobuf/Manifest
+++ b/dev-ruby/google-protobuf/Manifest
@@ -1,3 +1 @@
-DIST google-protobuf-3.12.4-ruby.tar.gz 5310348 BLAKE2B 2630941672963165467221843c10079a0ed966f2fdfcbc970b0b41e1ed3c7f78734496c1fbd3ec509c68999a14f637fff267b309cf82a8acf2bb5a948484f79b SHA512 c5d24502b9a6be0a606a19213186fe462e0de6830547003636f0897781f36d0bd7e4e7d9689d96390a0399ce04b6438cda3a0fe6f97f0feb700a110e90beef0c
-DIST google-protobuf-3.13.0-ruby.tar.gz 5277913 BLAKE2B 168aaa5beef83be675cd2543ca8efeaf5174f5e7fd861a056b04b01c8c781dc7b1fcbd05068ae89f051dfacfdc47c34b19cc33c8d09dd3212d3827746e3408f2 SHA512 514efa65fc8a36bc0791e6d39bdfb07b2689e9c2a4b82536c657859b800e7bc1e1a0ae86a7ee33f30c43a473a49b5c346ce830ac0057b6da104ed37f90b8b0fd
DIST google-protobuf-3.14.0-ruby.tar.gz 5319779 BLAKE2B cea083eea4d7fec441536effdfe2bf1811913154b0cc0da2f14f4edeb0efb200236da102c36700e24fab73fd9883aa90576ad64603a7f175ebf5cef0dc29aae5 SHA512 9dabba81119cb6196ef5de382a1032c57f6e69038f4dce0156f8671b98e51bb5095915fb6d05bb5a8ad8b17b559e652e1e9a392dd30c7ed8dcf1d986c137be11
diff --git a/dev-ruby/google-protobuf/google-protobuf-3.12.4.ebuild b/dev-ruby/google-protobuf/google-protobuf-3.12.4.ebuild
deleted file mode 100644
index 3787f73873a7..000000000000
--- a/dev-ruby/google-protobuf/google-protobuf-3.12.4.ebuild
+++ /dev/null
@@ -1,40 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-USE_RUBY="ruby25 ruby26 ruby27"
-
-RUBY_FAKEGEM_EXTRADOC="README.md"
-
-RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
-
-inherit ruby-fakegem
-
-DESCRIPTION="Protocol Buffers are Google's data interchange format"
-HOMEPAGE="https://developers.google.com/protocol-buffers"
-SRC_URI="https://github.com/protocolbuffers/protobuf/archive/v${PV}.tar.gz -> ${P}-ruby.tar.gz"
-RUBY_S="protobuf-${PV}/ruby"
-
-LICENSE="BSD"
-SLOT="3"
-KEYWORDS="~amd64"
-IUSE=""
-
-DEPEND+=" test? ( >=dev-libs/protobuf-3.12.0 )"
-
-all_ruby_prepare() {
- sed -e '/extensiontask/ s:^:#:' \
- -e '/ExtensionTask/,/^ end/ s:^:#:' \
- -e 's:../src/protoc:protoc:' \
- -e 's/:compile,//' \
- -i Rakefile || die
-}
-
-each_ruby_configure() {
- ${RUBY} -Cext/google/protobuf_c extconf.rb
-}
-
-each_ruby_compile() {
- emake -Cext/google/protobuf_c V=1
- cp ext/google/protobuf_c/protobuf_c.so lib/google/ || die
-}
diff --git a/dev-ruby/google-protobuf/google-protobuf-3.13.0.ebuild b/dev-ruby/google-protobuf/google-protobuf-3.13.0.ebuild
deleted file mode 100644
index c61f42fc155a..000000000000
--- a/dev-ruby/google-protobuf/google-protobuf-3.13.0.ebuild
+++ /dev/null
@@ -1,40 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-USE_RUBY="ruby25 ruby26 ruby27 ruby30"
-
-RUBY_FAKEGEM_EXTRADOC="README.md"
-
-RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
-
-inherit ruby-fakegem
-
-DESCRIPTION="Protocol Buffers are Google's data interchange format"
-HOMEPAGE="https://developers.google.com/protocol-buffers"
-SRC_URI="https://github.com/protocolbuffers/protobuf/archive/v${PV}.tar.gz -> ${P}-ruby.tar.gz"
-RUBY_S="protobuf-${PV}/ruby"
-
-LICENSE="BSD"
-SLOT="3"
-KEYWORDS="~amd64"
-IUSE=""
-
-DEPEND+=" test? ( >=dev-libs/protobuf-3.12.0 )"
-
-all_ruby_prepare() {
- sed -e '/extensiontask/ s:^:#:' \
- -e '/ExtensionTask/,/^ end/ s:^:#:' \
- -e 's:../src/protoc:protoc:' \
- -e 's/:compile,//' \
- -i Rakefile || die
-}
-
-each_ruby_configure() {
- ${RUBY} -Cext/google/protobuf_c extconf.rb
-}
-
-each_ruby_compile() {
- emake -Cext/google/protobuf_c V=1
- cp ext/google/protobuf_c/protobuf_c.so lib/google/ || die
-}