summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexandra Parker <alex.iris.parker@gmail.com>2022-01-07 23:09:42 -0800
committerMarek Szuba <marecki@gentoo.org>2022-01-11 18:38:14 +0000
commit743f726479d8f20dc7e13f6d54f83bab4d71c70f (patch)
treedf02255360821c9dcba000528559376e02892d76
parentdev-python/python-engineio: add 4.3.1 (diff)
downloadgentoo-743f726479d8f20dc7e13f6d54f83bab4d71c70f.tar.gz
gentoo-743f726479d8f20dc7e13f6d54f83bab4d71c70f.tar.bz2
gentoo-743f726479d8f20dc7e13f6d54f83bab4d71c70f.zip
net-p2p/syncthing: support cross compilation
Closes: https://github.com/gentoo/gentoo/pull/23693 Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Alexandra Parker <alex.iris.parker@gmail.com> Signed-off-by: Marek Szuba <marecki@gentoo.org>
-rw-r--r--net-p2p/syncthing/syncthing-1.18.5.ebuild6
1 files changed, 4 insertions, 2 deletions
diff --git a/net-p2p/syncthing/syncthing-1.18.5.ebuild b/net-p2p/syncthing/syncthing-1.18.5.ebuild
index c7614a65ba08..097eb15a959f 100644
--- a/net-p2p/syncthing/syncthing-1.18.5.ebuild
+++ b/net-p2p/syncthing/syncthing-1.18.5.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -828,8 +828,10 @@ src_prepare() {
}
src_compile() {
- go run build.go -version "v${PV}" -no-upgrade install \
+ go run build.go -version "v${PV}" -no-upgrade build \
$(usex tools "all" "") || die "build failed"
+ mkdir bin || die
+ mv "${PN}$(go env GOEXE)" bin/ || die
}
src_test() {