summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-08-05 07:28:16 +0200
committerMichał Górny <mgorny@gentoo.org>2023-08-05 07:30:04 +0200
commit7449947abdd9e1a00287467f0f834d4d1c7ed4b3 (patch)
treefa8547ea7213d8d44ac2f3769e0d4a9c56cf5618
parentdev-python/libnacl: Bump to 1.9.0 (diff)
downloadgentoo-7449947abdd9e1a00287467f0f834d4d1c7ed4b3.tar.gz
gentoo-7449947abdd9e1a00287467f0f834d4d1c7ed4b3.tar.bz2
gentoo-7449947abdd9e1a00287467f0f834d4d1c7ed4b3.zip
dev-python/referencing: Bump to 0.30.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/referencing/Manifest1
-rw-r--r--dev-python/referencing/referencing-0.30.1.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/referencing/Manifest b/dev-python/referencing/Manifest
index e727fdc1e023..3210b373a532 100644
--- a/dev-python/referencing/Manifest
+++ b/dev-python/referencing/Manifest
@@ -1,2 +1,3 @@
DIST referencing-0.30.0.tar.gz 35259 BLAKE2B fe26f83ae6752b35976627c9584980c9f5ee094ce7340ff1724039f641492a6d52eb8031b733256d5a91976a8e6cc545f2e8ae05aa8df3978dc9199117ef2dc2 SHA512 afc709140706f37a6baad5e2293fe3e7f4e214867020ac962e1ee1282777d4e6864037d6d545a0429dd11fd1eb2f91b633192cb0752f4ad4b8d138897ba2a573
+DIST referencing-0.30.1.tar.gz 53193 BLAKE2B 10bb0c85cee6e0ec4c399477b6b06a8e015efbdf1adf5cd32ba5c785711656012d416a7074602b00252e40d3f18375f5b29e8f8fe196126c95a8e7616629d63a SHA512 3da75977003cc950a520af053ec9c83e42704a5566cf74714d977da4316ccf7c89b2d18b8bdc28351b4fe2e992e6812dc214f9c9dcd716dab774b1060382fe7c
DIST referencing-suite-6e126a9fc8f243c4948feb11a7b66efda9d71098.gh.tar.gz 18291 BLAKE2B 89b1ca81ad66b4f89dae37d39cd3d0953ce3cea540d736fa81abff87ad199a5e9e6860c24efbc609c24feb4892331791d6adafeb4fa3c9acea564aff84ee5443 SHA512 5aed034c66c711e9b89280ea1adf08af9aad3d381376f29c4d7a33d69658190d742b51e1b42aef0ec6dd7c8ddbadc3f2c7b09c697f4267fc072a97d750ce5772
diff --git a/dev-python/referencing/referencing-0.30.1.ebuild b/dev-python/referencing/referencing-0.30.1.ebuild
new file mode 100644
index 000000000000..2ae008615109
--- /dev/null
+++ b/dev-python/referencing/referencing-0.30.1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Cross-specification JSON referencing (JSON Schema, OpenAPI...)"
+HOMEPAGE="
+ https://github.com/python-jsonschema/referencing/
+ https://pypi.org/project/referencing/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~riscv ~x86"
+
+RDEPEND="
+ >=dev-python/attrs-22.2.0[${PYTHON_USEDEP}]
+ >=dev-python/rpds-py-0.7.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/hatch-vcs[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pytest-subtests[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest