summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-05-12 15:18:35 +0200
committerMichał Górny <mgorny@gentoo.org>2022-05-12 15:36:21 +0200
commit7497ec96919bc35112d7bb8c49f7a89b020a2357 (patch)
tree300b4f82bc9c20c93e594812cd1fc80dafe02d3a
parentsys-kernel/linux-firmware: add 20220509 (diff)
downloadgentoo-7497ec96919bc35112d7bb8c49f7a89b020a2357.tar.gz
gentoo-7497ec96919bc35112d7bb8c49f7a89b020a2357.tar.bz2
gentoo-7497ec96919bc35112d7bb8c49f7a89b020a2357.zip
dev-python/mistune: Use PEP517 build
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/mistune/mistune-2.0.2-r1.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/dev-python/mistune/mistune-2.0.2-r1.ebuild b/dev-python/mistune/mistune-2.0.2-r1.ebuild
new file mode 100644
index 000000000000..91c5e2c23b43
--- /dev/null
+++ b/dev-python/mistune/mistune-2.0.2-r1.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="The fastest markdown parser in pure Python"
+HOMEPAGE="
+ https://github.com/lepture/mistune/
+ https://pypi.org/project/mistune/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos"
+
+distutils_enable_tests pytest