summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2018-08-18 17:56:10 -0700
committerZac Medico <zmedico@gentoo.org>2018-08-18 23:37:56 -0700
commit74a3dfaa9ad44fbf2f8bba4e33ca9e0f1e5b2a91 (patch)
tree170538e44f8799c6717ae0480d11d5a46789dc0b
parentdev-go/go-tools: version bump to 0_pre20180817 (diff)
downloadgentoo-74a3dfaa.tar.gz
gentoo-74a3dfaa.tar.bz2
gentoo-74a3dfaa.zip
dev-go/go-text: version bump to 0.3.0
Package-Manager: Portage-2.3.47, Repoman-2.3.10
-rw-r--r--dev-go/go-text/Manifest1
-rw-r--r--dev-go/go-text/go-text-0.3.0.ebuild46
2 files changed, 47 insertions, 0 deletions
diff --git a/dev-go/go-text/Manifest b/dev-go/go-text/Manifest
index 8a92b506344d..b2c4e9e89ff8 100644
--- a/dev-go/go-text/Manifest
+++ b/dev-go/go-text/Manifest
@@ -1,2 +1,3 @@
+DIST go-text-0.3.0.tar.gz 6102619 BLAKE2B c92e68014a8c157d76741c02acd708771d66bd3dda5b19285f5aa3e073e0fe3fccb9054744d35ea62b681ae4421bb7489238d6868f9314fb26f88e002287abe8 SHA512 bd60dfaa7d9dbfca171a3ba40b51f5663c01257cf3b12b618d35689a97ab2212d316d5716ff09681bf40b099f7e20a0e0df8cfc065699cb6a07ad1dc2e2bc189
DIST go-text-0_pre20150806.tar.gz 3736536 BLAKE2B afc6a95116426f9b981432c772c374cb3c84d300e81af1599383be74d00830556d36ff614d88e8952b89974ecb238b77725a3d1a83dc65a0f85dafa3d29a2dff SHA512 dd0fc8b5abdfa6f005316bb7828c03a081485e0bd33cbf86c0b83f8bf9240973a7b0a2e6f52ef75f48ec00fc922be21a6c65ff9eb4080f28cb3f280bd4c4f5c6
DIST go-text-0_pre20160211.tar.gz 4015547 BLAKE2B ad85f27761e2fd91a6acff497fe9b720484d51c6d75032c02fe21784dff78b4b900ac95aab394a6db1f7b2c9fb5a3d1cbde8db2aaa4c099b19357d82f747eb89 SHA512 066e53f6e094a6cf3effe1a9376f7bde41c3059099381bb5adf8c84589de4dab9115ce3c8cb7f89f90e2601422f79e3906f8f498d66e364da9f830ede1f7f05f
diff --git a/dev-go/go-text/go-text-0.3.0.ebuild b/dev-go/go-text/go-text-0.3.0.ebuild
new file mode 100644
index 000000000000..84a3b008c103
--- /dev/null
+++ b/dev-go/go-text/go-text-0.3.0.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+EGO_PN=golang.org/x/text/...
+
+if [[ ${PV} = *9999* ]]; then
+ inherit golang-vcs
+else
+ KEYWORDS="~amd64 ~arm ~x86"
+ EGIT_COMMIT="v${PV}"
+ SRC_URI="https://github.com/golang/text/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
+ inherit golang-vcs-snapshot
+fi
+inherit golang-build
+
+DESCRIPTION="Go text processing support"
+HOMEPAGE="https://godoc.org/golang.org/x/text"
+LICENSE="BSD"
+SLOT="0/${PVR}"
+IUSE=""
+DEPEND=">=dev-go/go-tools-0_pre20180817"
+RDEPEND=""
+
+src_compile() {
+ # Create an isolated golibdir in order to avoid an
+ # "use of internal package not allowed" error when
+ # and older version is installed.
+ mkdir -p "${T}/golibdir/src/golang.org/x" || die
+ ln -s "$(get_golibdir_gopath)/src/golang.org/x/tools" "${T}/golibdir/src/golang.org/x/tools" || die
+ GOPATH="${S}:${T}/golibdir" \
+ go install -v -work -x ${EGO_BUILD_FLAGS} "${EGO_PN}" || die
+}
+
+src_install() {
+ golang_install_pkgs
+ exeopts -m0755 -p # preserve timestamps for bug 551486
+ exeinto "$(go env GOROOT)/bin"
+ doexe bin/*
+}
+
+src_test() {
+ GOPATH="${S}:${T}/golibdir" \
+ go test -v -work -x "${EGO_PN}" || die
+}