summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2024-05-19 07:32:18 +0200
committerHans de Graaff <graaff@gentoo.org>2024-05-19 07:33:34 +0200
commit74af98041931e10c0e266ad886377cd9901f17bb (patch)
tree4008feef2b7ee8fa20d9fa725c7ed82c2ab00eca
parentdev-ruby/minitest: add 5.23.0 (diff)
downloadgentoo-74af98041931e10c0e266ad886377cd9901f17bb.tar.gz
gentoo-74af98041931e10c0e266ad886377cd9901f17bb.tar.bz2
gentoo-74af98041931e10c0e266ad886377cd9901f17bb.zip
dev-ruby/rb-inotify: add 0.11.1
Signed-off-by: Hans de Graaff <graaff@gentoo.org>
-rw-r--r--dev-ruby/rb-inotify/Manifest1
-rw-r--r--dev-ruby/rb-inotify/rb-inotify-0.11.1.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/dev-ruby/rb-inotify/Manifest b/dev-ruby/rb-inotify/Manifest
index a8dc2f0fc559..d7258fc4aca5 100644
--- a/dev-ruby/rb-inotify/Manifest
+++ b/dev-ruby/rb-inotify/Manifest
@@ -1 +1,2 @@
DIST rb-inotify-0.10.1.gem 15872 BLAKE2B 1ddf4fe8de7cdd348e007ac29ab7b41667092439f9b70eeae49d7e917351c73512e43a7ccf6679af1c9225b19efadb6a1581f63e1958d2a31d61f2bce5a13664 SHA512 7831a6228f2d6363e634b8d6b4a12206f19b96098e5dfba1d27b1e994a7284a5cb58cd0299d861a6ff275fc8248c0e68faaaf786d6222ad68f3e6b43ccea29ec
+DIST rb-inotify-0.11.1.tar.gz 12136 BLAKE2B 3a1dc507589c02cd07903f33546d9a222bf2fad6afc283dd1a463549fdb38c8b1aadc00ab4abfe3f7e63d1a138bec0f8ac8a4bbe7c66282a9a7007e9f7012805 SHA512 46966609686878d99c5a6623f5a3f55ef203ae32e48d0efbef295f97cc728c6938759360d445e052b82206322c7bf6f995db3007c7f3c0b2818549b8088be9bf
diff --git a/dev-ruby/rb-inotify/rb-inotify-0.11.1.ebuild b/dev-ruby/rb-inotify/rb-inotify-0.11.1.ebuild
new file mode 100644
index 000000000000..26ddd7c62cf3
--- /dev/null
+++ b/dev-ruby/rb-inotify/rb-inotify-0.11.1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+USE_RUBY="ruby31 ruby32 ruby33"
+
+RUBY_FAKEGEM_EXTRADOC="README.md"
+RUBY_FAKEGEM_GEMSPEC="rb-inotify.gemspec"
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A thorough inotify wrapper for Ruby using FFI"
+HOMEPAGE="https://github.com/guard/rb-inotify"
+SRC_URI="https://github.com/guard/rb-inotify/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~ppc-macos ~x64-macos ~x64-solaris"
+IUSE=""
+
+ruby_add_rdepend "dev-ruby/ffi:0"
+
+ruby_add_bdepend "test? ( dev-ruby/concurrent-ruby )"
+
+all_ruby_prepare() {
+ sed -e "s:_relative ': './:" \
+ -e 's/git ls-files/find * -print/' \
+ -i ${RUBY_FAKEGEM_GEMSPEC} || die
+
+ # Remove mandatory markup processor from yard options, bug 436112.
+ sed -i -e '/maruku/d' .yardopts || die
+
+ sed -i -e '/bundler/ s:^:#:' -e '1irequire "pathname"' spec/spec_helper.rb || die
+}