summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHanno Böck <hanno@gentoo.org>2023-02-18 17:00:02 +0100
committerHanno Böck <hanno@gentoo.org>2023-02-18 17:00:11 +0100
commit74b9a5dfa437e0286ad8e7bac5963dfdbc7c11cf (patch)
treeb05eb43b9b560f6a8a3c3b417e3ceee87f2da352
parentRevert "app-editors/emacs: Allow either of webkit-gtk:4.1 and :4" (diff)
downloadgentoo-74b9a5df.tar.gz
gentoo-74b9a5df.tar.bz2
gentoo-74b9a5df.zip
dev-python/pyClamd: Support python 3.11, EAPI 8, PEP517.
Signed-off-by: Hanno Böck <hanno@gentoo.org>
-rw-r--r--dev-python/pyClamd/files/pyClamd-0.4.0-remove-obsolete-bugtrack_url.diff11
-rw-r--r--dev-python/pyClamd/pyClamd-0.4.0-r4.ebuild27
2 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/pyClamd/files/pyClamd-0.4.0-remove-obsolete-bugtrack_url.diff b/dev-python/pyClamd/files/pyClamd-0.4.0-remove-obsolete-bugtrack_url.diff
new file mode 100644
index 000000000000..446c215ba518
--- /dev/null
+++ b/dev-python/pyClamd/files/pyClamd-0.4.0-remove-obsolete-bugtrack_url.diff
@@ -0,0 +1,11 @@
+diff -Naurp a/setup.py b/setup.py
+--- a/setup.py 2017-08-28 00:05:52.000000000 +0200
++++ b/setup.py 2023-02-18 16:57:08.911936472 +0100
+@@ -27,7 +27,6 @@ setup (name = 'pyClamd',
+ author_email = 'norman@xael.org',
+ keywords='python, clamav, antivirus, scanner, virus, libclamav',
+ url = 'http://xael.org/pages/pyclamd-en.html',
+- bugtrack_url = 'https://bitbucket.org/xael/pyclamd',
+ include_dirs = ['/usr/local/include'],
+ description = 'pyClamd is a python interface to Clamd (Clamav daemon).',
+ long_description = 'pyClamd is a python interface to Clamd (Clamav daemon). By using pyClamd, you can add virus detection capabilities to your python software in an efficient and easy way. Instead of pyClamav which uses libclamav, pyClamd may be used by a closed source product.',
diff --git a/dev-python/pyClamd/pyClamd-0.4.0-r4.ebuild b/dev-python/pyClamd/pyClamd-0.4.0-r4.ebuild
new file mode 100644
index 000000000000..4f0d7151688f
--- /dev/null
+++ b/dev-python/pyClamd/pyClamd-0.4.0-r4.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9,10,11} )
+DISTUTILS_USE_PEP517=setuptools
+
+inherit distutils-r1
+
+PATCHES=( "${FILESDIR}/${P}-remove-obsolete-bugtrack_url.diff" )
+
+DESCRIPTION="python interface to Clamd (Clamav daemon)"
+HOMEPAGE="https://xael.org/pages/pyclamd-en.html"
+SRC_URI="mirror://pypi/p/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="amd64"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="${DEPEND}"
+
+# Tests need clamd running and we cannot rely on that being
+# true during build
+RESTRICT="test"