summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJimi Huotari <chiitoo@gentoo.org>2019-03-08 00:49:51 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2019-03-10 23:45:50 +0100
commit74b9aa9da20ed7aa467d26fc54a7053acf6685a1 (patch)
tree6413d1c938a53a15266dae137d8eb9dafbf27bc9
parentx11-misc/screengrab: version bump to 1.101 (diff)
downloadgentoo-74b9aa9da20ed7aa467d26fc54a7053acf6685a1.tar.gz
gentoo-74b9aa9da20ed7aa467d26fc54a7053acf6685a1.tar.bz2
gentoo-74b9aa9da20ed7aa467d26fc54a7053acf6685a1.zip
media-sound/pavucontrol-qt: version bump to 0.14.1
Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Jimi Huotari <chiitoo@gentoo.org> Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
-rw-r--r--media-sound/pavucontrol-qt/Manifest1
-rw-r--r--media-sound/pavucontrol-qt/pavucontrol-qt-0.14.1.ebuild34
2 files changed, 35 insertions, 0 deletions
diff --git a/media-sound/pavucontrol-qt/Manifest b/media-sound/pavucontrol-qt/Manifest
index 6b17bfe31696..a97eff728a23 100644
--- a/media-sound/pavucontrol-qt/Manifest
+++ b/media-sound/pavucontrol-qt/Manifest
@@ -1 +1,2 @@
+DIST pavucontrol-qt-0.14.1.tar.xz 94948 BLAKE2B e0bbbaa2410220c0e34ff77cb84c783ba682587311eaf20eca286a142e122827b6294e9d0409f2ea5b18d80c06d822bbaed49d60d1402a4a97b7f7210ee2cacd SHA512 55a8bceb31e07ceac7ab1fbb5f20101dfb087e58578039a238677e77f858e0564dca46efee2d5513a247c0be474f24d31e3afa9cf3cea0734feb0e56c33d5494
DIST pavucontrol-qt-0.4.0.tar.xz 34916 BLAKE2B f42f560b125e292ae3a8ab76e2020d1a899019e8ed40d6f4d3e90fe1baa0cc044093310fe9ac11c6529f9cc1abc41d475aa2d445de8f19e6f89ed456525aa7d9 SHA512 62e0c909c98acc4605556ba63981e4599d37b592b99ee16301dc0ba154f3066708a31562e158c042b3530c11603cc43de930080770f027bb998cbb6f79f0f3fb
diff --git a/media-sound/pavucontrol-qt/pavucontrol-qt-0.14.1.ebuild b/media-sound/pavucontrol-qt/pavucontrol-qt-0.14.1.ebuild
new file mode 100644
index 000000000000..24871a2f6a28
--- /dev/null
+++ b/media-sound/pavucontrol-qt/pavucontrol-qt-0.14.1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake-utils
+
+DESCRIPTION="A Pulseaudio mixer in Qt (port of pavucontrol)"
+HOMEPAGE="https://lxqt.org/"
+
+if [[ ${PV} = *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/lxqt/${PN}.git"
+else
+ SRC_URI="https://downloads.lxqt.org/downloads/${PN}/${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+fi
+
+LICENSE="GPL-2+"
+SLOT="0"
+
+BDEPEND="
+ dev-qt/linguist-tools:5
+ >=dev-util/lxqt-build-tools-0.6.0
+ virtual/pkgconfig
+"
+DEPEND="
+ dev-libs/glib:2
+ dev-qt/qtcore:5
+ dev-qt/qtdbus:5
+ dev-qt/qtwidgets:5
+ media-sound/pulseaudio[glib]
+"
+RDEPEND="${DEPEND}"