summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakov Smolic <jakov.smolic@sartura.hr>2021-02-01 12:32:45 +0100
committerBen Kohler <bkohler@gentoo.org>2021-02-09 10:59:23 -0600
commit74d0b0bc8fa86c64faedfea5624116e94076913e (patch)
tree1fe5c60c01473f1a32690bb6a6e150b7c4587549
parentgames-fps/quake2-icculus: Fix build with gcc-10 (diff)
downloadgentoo-74d0b0bc.tar.gz
gentoo-74d0b0bc.tar.bz2
gentoo-74d0b0bc.zip
net-proxy/squirm: Port to EAPI 7
* Fix build with gcc-10 Closes: https://bugs.gentoo.org/709648 Signed-off-by: Jakov Smolic <jakov.smolic@sartura.hr> Signed-off-by: Ben Kohler <bkohler@gentoo.org>
-rw-r--r--net-proxy/squirm/files/squirm-1.26-fno-common.patch25
-rw-r--r--net-proxy/squirm/files/squirm-1.26-gentoo.patch5
-rw-r--r--net-proxy/squirm/metadata.xml2
-rw-r--r--net-proxy/squirm/squirm-1.26-r1.ebuild8
4 files changed, 32 insertions, 8 deletions
diff --git a/net-proxy/squirm/files/squirm-1.26-fno-common.patch b/net-proxy/squirm/files/squirm-1.26-fno-common.patch
new file mode 100644
index 000000000000..01e6b25f59d1
--- /dev/null
+++ b/net-proxy/squirm/files/squirm-1.26-fno-common.patch
@@ -0,0 +1,25 @@
+https://bugs.gentoo.org/709648
+--- a/lists.c
++++ b/lists.c
+@@ -38,6 +38,8 @@
+
+
+ extern int dodo_mode;
++struct pattern_file *pattern_head;
++struct subnet_block *subnet_head;
+
+
+ void init_lists(void)
+--- a/lists.h
++++ b/lists.h
+@@ -45,8 +45,8 @@
+
+
+ /* the two chief lists */
+-struct subnet_block *subnet_head;
+-struct pattern_file *pattern_head;
++extern struct subnet_block *subnet_head;
++extern struct pattern_file *pattern_head;
+
+
+
diff --git a/net-proxy/squirm/files/squirm-1.26-gentoo.patch b/net-proxy/squirm/files/squirm-1.26-gentoo.patch
index 16b6e21c7aa2..1f823d9e525c 100644
--- a/net-proxy/squirm/files/squirm-1.26-gentoo.patch
+++ b/net-proxy/squirm/files/squirm-1.26-gentoo.patch
@@ -1,6 +1,5 @@
-diff -Nru squirm-1.26.orig/Makefile squirm-1.26/Makefile
---- squirm-1.26.orig/Makefile 2005-08-19 09:31:06.000000000 +0200
-+++ squirm-1.26/Makefile 2009-06-20 14:58:18.000000000 +0200
+--- a/Makefile
++++ b/Makefile
@@ -1,7 +1,7 @@
# $Id$
diff --git a/net-proxy/squirm/metadata.xml b/net-proxy/squirm/metadata.xml
index 6f49eba8f496..7a38bb900964 100644
--- a/net-proxy/squirm/metadata.xml
+++ b/net-proxy/squirm/metadata.xml
@@ -1,5 +1,5 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<!-- maintainer-needed -->
+ <!-- maintainer-needed -->
</pkgmetadata>
diff --git a/net-proxy/squirm/squirm-1.26-r1.ebuild b/net-proxy/squirm/squirm-1.26-r1.ebuild
index e5e323ec0781..d20f275a0c5b 100644
--- a/net-proxy/squirm/squirm-1.26-r1.ebuild
+++ b/net-proxy/squirm/squirm-1.26-r1.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
inherit toolchain-funcs
@@ -12,7 +12,6 @@ SRC_URI="http://squirm.foote.com.au/${P}.tgz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ppc x86"
-IUSE=""
RDEPEND="net-proxy/squid"
DEPEND="${RDEPEND}"
@@ -20,6 +19,7 @@ DEPEND="${RDEPEND}"
PATCHES=(
"${FILESDIR}"/${P}-gentoo.patch
"${FILESDIR}"/${P}-gcc5.patch
+ "${FILESDIR}"/${P}-fno-common.patch
)
src_compile() {
@@ -27,7 +27,7 @@ src_compile() {
}
src_install() {
- emake PREFIX="${ED%/}/opt/squirm" install
+ emake PREFIX="${ED}/opt/squirm" install
}
pkg_postinst() {