summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-04-25 09:20:15 +0000
committerSam James <sam@gentoo.org>2021-04-25 09:39:56 +0000
commit74fad3d399ed17cc72a718bf12fbe6a7bf545ecc (patch)
tree1b32e0f01825bcf509edb1db3201c7e722ab4438
parentprofiles/package.mask: some java last-rites (diff)
downloadgentoo-74fad3d3.tar.gz
gentoo-74fad3d3.tar.bz2
gentoo-74fad3d3.zip
sci-mathematics/wxmaxima: run unit tests manually
The full test suite fails even with virtualx, no error given. Let's run some of the unit tests manually for now as a compromise. Bug: https://bugs.gentoo.org/736695 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--sci-mathematics/wxmaxima/wxmaxima-21.01.0.ebuild31
1 files changed, 29 insertions, 2 deletions
diff --git a/sci-mathematics/wxmaxima/wxmaxima-21.01.0.ebuild b/sci-mathematics/wxmaxima/wxmaxima-21.01.0.ebuild
index a76a6aeeb045..72cf6098d523 100644
--- a/sci-mathematics/wxmaxima/wxmaxima-21.01.0.ebuild
+++ b/sci-mathematics/wxmaxima/wxmaxima-21.01.0.ebuild
@@ -2,6 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
+
WX_GTK_VER="3.0-gtk3"
PLOCALES="ca cs da de el en es fi fr gl hu it ja kab nb pl pt_BR ru tr uk zh_CN zh_TW"
inherit cmake wxwidgets l10n xdg
@@ -9,12 +10,13 @@ inherit cmake wxwidgets l10n xdg
DESCRIPTION="Graphical frontend to Maxima, using the wxWidgets toolkit"
HOMEPAGE="https://wxmaxima-developers.github.io/wxmaxima/"
SRC_URI="https://github.com/wxMaxima-developers/wxmaxima/archive/Version-${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}"/${PN}-Version-${PV}
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~x86"
-IUSE=""
-S="${WORKDIR}"/${PN}-Version-${PV}
+IUSE="test"
+RESTRICT="!test? ( test )"
DEPEND="
dev-libs/libxml2:2
@@ -45,6 +47,31 @@ src_prepare() {
l10n_for_each_disabled_locale_do rm_po
}
+src_configure() {
+ local mycmakeargs=(
+ -DWXM_UNIT_TESTS=$(usex test)
+ )
+
+ cmake_src_configure
+}
+
+src_test() {
+ # Just run the unit tests manually for now as tests fail in a non-descriptive
+ # way even with virtualx
+ # bug #736695
+ cd "${BUILD_DIR}/test/unit_tests" || die
+
+ local tests=(
+ AFontSize
+ CellPtr
+ ImgCell
+ )
+
+ for test in "${tests[@]}" ; do
+ ./test_${test} || die "Unit test ${test} failed!"
+ done
+}
+
src_install() {
docompress -x /usr/share/doc/${PF}
cmake_src_install