summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHank Leininger <hlein@korelogic.com>2020-12-28 18:12:10 -0700
committerSam James <sam@gentoo.org>2021-09-28 04:34:53 +0100
commit74fca1f794ce6bf84cb6354cc31d5f307508e155 (patch)
tree9169bb435e646b373e682ee9faf19cafe1a89cc0
parentapp-text/ghostscript-gpl: add more upstream parallel build patches to 94.0-r1 (diff)
downloadgentoo-74fca1f7.tar.gz
gentoo-74fca1f7.tar.bz2
gentoo-74fca1f7.zip
net-ftp/ftp: version bump, EAPI bump, fix segv
Sync to a more recent Debian version (netkit-ftp-ssl_0.17.34+0.2-5.1.dsc), and fix longstanding segv when the server goes away. Updated Gentoo patches for the current Debian version. Tested with gcc-10. Signed-off-by: Hank Leininger <hlein@korelogic.com> Closes: https://bugs.gentoo.org/662684 Package-Manager: Portage-3.0.12, Repoman-3.0.2 Closes: https://github.com/gentoo/gentoo/pull/18862 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--net-ftp/ftp/Manifest2
-rw-r--r--net-ftp/ftp/ftp-0.17.34.0.2.5.1.ebuild66
2 files changed, 68 insertions, 0 deletions
diff --git a/net-ftp/ftp/Manifest b/net-ftp/ftp/Manifest
index 248624ad48cf..58a4a0349d67 100644
--- a/net-ftp/ftp/Manifest
+++ b/net-ftp/ftp/Manifest
@@ -1,3 +1,5 @@
DIST netkit-ftp-0.17-patches-2.tar.bz2 4307 BLAKE2B d7febb30807dab2dd66b6fe1991675b37cdea63703769f228895d7722f46b56dd2f5a7774d92740ff3f9ff7797a64660a580cb231582d2b9b912da35c209746a SHA512 6a9adfd33eae4ac2e1a9e070ed89467804dc484eda084694398bb7e3ebbaf04bf70d00ffaa637bace078c4c0024115ba3620fd75d4a3558a44dc991798885461
+DIST netkit-ftp-0.17-patches-3.tar.bz2 4082 BLAKE2B d70c0340641647ab993a7b2aa1c49be2a1ff16e7b6b3038ebe9eff329bf4796cfa21d8c8d88f123c2f633cc1ba3b5ecdd4b1be78a7fda63b77ece077d643fca5 SHA512 083796f89c6d02f2b094616a6b7c9ef8ef7d0edbe337521cf311deb03f1af2000f12b85e3978a5eb1c56c64f2a2a105c0b7735fd6ea31d626d171a047cd858c3
DIST netkit-ftp-0.17.tar.gz 53934 BLAKE2B 451f90f26cd5cc1a6693fea7c31d47127d8b89b4b00a2f863af61d46d87f6e416141db1c6f6bb320021665a99f0d9e00dc4a5c3b0bb209df0ae74aad97a45f20 SHA512 ba8e411d0230c78e9e4555c03dc1036c6e506ef8edb72ecee4d6a7559d85143721bffbe8b8a6e42918b3098072ac8f207584be9e3a241f6bd31e361c92de6554
DIST netkit-ftp-ssl_0.17.23+0.2-1.debian.tar.gz 48189 BLAKE2B 7894f64308ae14c72e2fcf7e18225fa36680d2d88a3e59c4b7edac3669e051e3196a2acda3f8da083bd3d8405e9f28f67be10d70684854e8bbc7008f8189cb8d SHA512 c2fa882c185987298a73e7cef8c073ab0aee7627b60b412be90eef8619bf02d97721c15197fe4f443eab53bcca87876633924872f3102ef9e92dc7511c065228
+DIST netkit-ftp-ssl_0.17.34+0.2-5.1.debian.tar.xz 48976 BLAKE2B 30c867a3a8fabc55ba05603c54b5e4153d198e8e92d55353bf02cbf0494a41de1362c945aef013edfa3a6f0b1c78e5041ec7127db5eb99bac5351f57bb526c2d SHA512 6061b9b22fe8463a7d4542988685e108b282b6d2908d67cc70951fc23b1d842a70aee44af989d1e683e80c050ffe284fbfa776581e0120439bec98d479672718
diff --git a/net-ftp/ftp/ftp-0.17.34.0.2.5.1.ebuild b/net-ftp/ftp/ftp-0.17.34.0.2.5.1.ebuild
new file mode 100644
index 000000000000..5c394dd064b5
--- /dev/null
+++ b/net-ftp/ftp/ftp-0.17.34.0.2.5.1.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit flag-o-matic toolchain-funcs
+
+PATCH_VER="3"
+MY_PN="netkit-ftp"
+MY_PV="$(ver_cut 1-2)"
+MY_P="netkit-${PN}-${MY_PV}"
+DEB_PN="${MY_PN}-ssl"
+DEB_PV="$(ver_cut 1-3)+$(ver_cut 4-5)-$(ver_cut 6-7)"
+DESCRIPTION="Standard Linux FTP client"
+HOMEPAGE="http://www.hcs.harvard.edu/~dholland/computers/netkit.html"
+SRC_URI="ftp://sunsite.unc.edu/pub/Linux/system/network/netkit/${MY_P}.tar.gz
+ mirror://debian/pool/main/n/${DEB_PN}/${DEB_PN}_${DEB_PV}.debian.tar.xz
+ https://dev.gentoo.org/~sam/distfiles/${CATEGORY}/${PN}/${MY_P}-patches-${PATCH_VER}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86"
+IUSE="ipv6 readline ssl"
+
+RDEPEND="
+ >=sys-libs/ncurses-5.2:=
+ readline? ( sys-libs/readline:0= )
+ ssl? ( dev-libs/openssl:0= )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="sys-apps/grep"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ local p
+ for p in $(grep -v "^#" "${WORKDIR}"/debian/patches/series || die); do
+ eapply "${WORKDIR}/debian/patches/${p}"
+ done
+
+ eapply "${WORKDIR}"/patch
+
+ sed -i \
+ -e 's:echo -n:printf %s :' \
+ configure || die
+
+ default
+}
+
+src_configure() {
+ append-lfs-flags #101038
+ tc-export CC
+ # not an autoconf script
+ ./configure \
+ --prefix=/usr \
+ $(use_enable ipv6) \
+ $(use_enable readline) \
+ $(use_enable ssl) \
+ || die
+}
+
+src_install() {
+ dobin ftp/ftp
+ doman ftp/ftp.1 ftp/netrc.5
+ dodoc ChangeLog README BUGS
+}