summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-03-20 05:51:30 +0000
committerSam James <sam@gentoo.org>2021-03-20 05:51:30 +0000
commit750d560d0eca8df04773751790971c7b376402f3 (patch)
treecc3f755fed3d431df3c0eb2ac109b0a03db8fbf9
parentsys-apps/plocate: add explanatory note to systemd unit patch (diff)
downloadgentoo-750d560d0eca8df04773751790971c7b376402f3.tar.gz
gentoo-750d560d0eca8df04773751790971c7b376402f3.tar.bz2
gentoo-750d560d0eca8df04773751790971c7b376402f3.zip
sys-apps/plocate: minor style changes
Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--sys-apps/plocate/plocate-1.1.5.ebuild14
1 files changed, 7 insertions, 7 deletions
diff --git a/sys-apps/plocate/plocate-1.1.5.ebuild b/sys-apps/plocate/plocate-1.1.5.ebuild
index 33f9170db162..4aaa46baf9c4 100644
--- a/sys-apps/plocate/plocate-1.1.5.ebuild
+++ b/sys-apps/plocate/plocate-1.1.5.ebuild
@@ -28,16 +28,16 @@ CONFIG_CHECK="~IO_URING"
ERROR_IO_URING="required for USE=io-uring"
PATCHES=(
- "${FILESDIR}/${PN}"-1.1.5-no-systemd-check.patch
+ "${FILESDIR}"/${PN}-1.1.5-no-systemd-check.patch
)
src_prepare() {
- # pretend liburing dep doesn't exist when USE flag off
+ # Pretend liburing dep doesn't exist when USE flag off
if ! use io-uring; then
sed -i "s/dependency('liburing/dependency('/" meson.build || die
fi
- # we'll install the manpage ourself to locate.1
+ # We'll install the manpage ourself to locate.1
sed -i "/install_man('plocate.1')/d" meson.build || die
default
@@ -53,7 +53,7 @@ src_configure() {
src_install() {
meson_src_install
dodoc README NEWS
- newman "${S}/${PN}.1" locate.1
+ newman "${S}"/${PN}.1 locate.1
dosym plocate /usr/bin/locate
insinto /etc
@@ -65,15 +65,15 @@ src_install() {
newins "${FILESDIR}"/plocate.cron plocate
fperms 0755 /etc/cron.daily/plocate
- systemd_dounit "${BUILD_DIR}/${PN}"-updatedb.service "${S}/${PN}"-updatedb.timer
+ systemd_dounit "${BUILD_DIR}"/${PN}-updatedb.service "${S}"/${PN}-updatedb.timer
}
pkg_postinst() {
- if [[ -z ${REPLACING_VERSIONS} ]]; then
+ if [[ -z "${REPLACING_VERSIONS}" ]] ; then
elog "The database for the locate command is generated daily by a cron job,"
elog "if you install for the first time you can run the updatedb command manually now."
elog
- elog "Note that the /etc/updatedb.conf file is generic,"
+ elog "Note that the ${EROOT}/etc/updatedb.conf file is generic,"
elog "please customize it to your system requirements."
fi
}