summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2022-09-06 02:02:54 +0200
committerMaciej Barć <xgqt@gentoo.org>2022-09-06 02:07:01 +0200
commit7517d5c97c728904f2a3a304284cf06878b54c5f (patch)
tree973c9f1ff3dea2fb79689f84e4633987d781ebad
parentwww-servers/nginx: bump njs module to 0.7.7 (diff)
downloadgentoo-7517d5c9.tar.gz
gentoo-7517d5c9.tar.bz2
gentoo-7517d5c9.zip
app-emacs/js2-mode: new package; add version 20220710
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
-rw-r--r--app-emacs/js2-mode/Manifest1
-rw-r--r--app-emacs/js2-mode/files/50js2-mode-gentoo.el12
-rw-r--r--app-emacs/js2-mode/js2-mode-20220710.ebuild23
-rw-r--r--app-emacs/js2-mode/metadata.xml27
4 files changed, 63 insertions, 0 deletions
diff --git a/app-emacs/js2-mode/Manifest b/app-emacs/js2-mode/Manifest
new file mode 100644
index 000000000000..89ab57750e00
--- /dev/null
+++ b/app-emacs/js2-mode/Manifest
@@ -0,0 +1 @@
+DIST js2-mode-20220710.tar.gz 166051 BLAKE2B f23f122f9002a38d1d6221f2f0f85efd9a9be92f7c5a242da3b3706abb9ec93e27e2f277e4cb1b7cd3ed616974add9f5ffd1abcf1ced6c7131d91b66320bd0e7 SHA512 7a30903114f81fe66bc76eecb01f8d96737f4be84c652f1083054ffdcda299d84c7d7fea387c87f719e2dc372459fcc180dde0513ed3006b8f12557e24002727
diff --git a/app-emacs/js2-mode/files/50js2-mode-gentoo.el b/app-emacs/js2-mode/files/50js2-mode-gentoo.el
new file mode 100644
index 000000000000..12daf0e43291
--- /dev/null
+++ b/app-emacs/js2-mode/files/50js2-mode-gentoo.el
@@ -0,0 +1,12 @@
+(add-to-list 'load-path "@SITELISP@")
+(autoload 'js2-imenu-extras-setup "js2-imenu-extras")
+(autoload 'js2-imenu-extras-mode "js2-imenu-extras"
+ "Toggle Imenu support for frameworks and structural patterns." t)
+(autoload 'js2-highlight-unused-variables-mode "js2-mode"
+ "Toggle highlight of unused variables." t)
+(autoload 'js2-minor-mode "js2-mode"
+ "Minor mode for running js2 as a background linter." t)
+(autoload 'js2-mode "js2-mode"
+ "Major mode for editing JavaScript code." t)
+(autoload 'js2-jsx-mode "js2-mode"
+ "Major mode for editing JSX code in Emacs 26 and earlier." t)
diff --git a/app-emacs/js2-mode/js2-mode-20220710.ebuild b/app-emacs/js2-mode/js2-mode-20220710.ebuild
new file mode 100644
index 000000000000..1d502b22e198
--- /dev/null
+++ b/app-emacs/js2-mode/js2-mode-20220710.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+NEED_EMACS=24.1
+
+inherit elisp
+
+DESCRIPTION="Improved JavaScript editing mode for GNU Emacs"
+HOMEPAGE="https://github.com/mooz/js2-mode/"
+SRC_URI="https://github.com/mooz/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DOCS=( NEWS.md README.md )
+SITEFILE="50${PN}-gentoo.el"
+
+src_test() {
+ emake test
+}
diff --git a/app-emacs/js2-mode/metadata.xml b/app-emacs/js2-mode/metadata.xml
new file mode 100644
index 000000000000..2983ab1f4170
--- /dev/null
+++ b/app-emacs/js2-mode/metadata.xml
@@ -0,0 +1,27 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+ <maintainer type="project">
+ <email>gnu-emacs@gentoo.org</email>
+ <name>Gentoo GNU Emacs project</name>
+ </maintainer>
+ <longdescription>
+ This JavaScript editing mode supports: 1. strict recognition of the
+ Ecma-262 language standard 2. support for most Rhino and SpiderMonkey
+ extensions from 1.5 and up 3. parsing support for ECMAScript for XML (E4X,
+ ECMA-357) 4. accurate syntax highlighting using a recursive-descent parser
+ 5. on-the-fly reporting of syntax errors and strict-mode warnings 6.
+ undeclared-variable warnings using a configurable externs framework 7.
+ "bouncing" line indentation to choose among alternate indentation points 8.
+ smart line-wrapping within comments and strings 9. code folding: 9.1. show
+ some or all function bodies as {...} 9.2. show some or all block comments
+ as /*...*/ 12. context-sensitive menu bar and popup menus 13. code browsing
+ using the `imenu' package 14. many customization options
+ </longdescription>
+ <stabilize-allarches />
+ <upstream>
+ <bugs-to>https://github.com/mooz/js2-mode/issues/</bugs-to>
+ <remote-id type="github">mooz/js2-mode</remote-id>
+ </upstream>
+</pkgmetadata>