summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAkinori Hattori <hattya@gentoo.org>2018-07-27 23:19:26 +0900
committerAkinori Hattori <hattya@gentoo.org>2018-07-27 23:19:26 +0900
commit752b7f32691128aa70c1acdf146c75ac490b1752 (patch)
tree53bd02bda43bfe8df412b637a9774d980436779e
parentapp-emacs/yatex: update patches (diff)
downloadgentoo-752b7f32.tar.gz
gentoo-752b7f32.tar.bz2
gentoo-752b7f32.zip
app-emacs/yatex: update to EAPI 6
Package-Manager: Portage-2.3.40, Repoman-2.3.9
-rw-r--r--app-emacs/yatex/metadata.xml32
-rw-r--r--app-emacs/yatex/yatex-1.77.ebuild29
2 files changed, 31 insertions, 30 deletions
diff --git a/app-emacs/yatex/metadata.xml b/app-emacs/yatex/metadata.xml
index d82c1ecb87c7..809a13113afc 100644
--- a/app-emacs/yatex/metadata.xml
+++ b/app-emacs/yatex/metadata.xml
@@ -1,20 +1,20 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<maintainer type="project">
- <email>gnu-emacs@gentoo.org</email>
- <name>Gentoo GNU Emacs project</name>
-</maintainer>
-<maintainer type="project">
- <email>cjk@gentoo.org</email>
- <name>Cjk</name>
-</maintainer>
-<longdescription lang="en">
- YaTeX is an intelligent, acquisitive and integrated package which reduces
- your efforts of composing LaTeX source on Emacs. And yahtml is the honest
- and bright YaTeX-compatible major-mode package for writing HTML. If you have
- noticed the power of YaTeX, you can drive yahtml over the HTML files quickly
- and steadily. And vice versa, of course.
-</longdescription>
-<stabilize-allarches/>
+ <maintainer type="project">
+ <email>gnu-emacs@gentoo.org</email>
+ <name>Gentoo GNU Emacs project</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>cjk@gentoo.org</email>
+ <name>Cjk</name>
+ </maintainer>
+ <longdescription lang="en">
+ YaTeX is an intelligent, acquisitive and integrated package which reduces
+ your efforts of composing LaTeX source on Emacs. And yahtml is the honest
+ and bright YaTeX-compatible major-mode package for writing HTML. If you have
+ noticed the power of YaTeX, you can drive yahtml over the HTML files quickly
+ and steadily. And vice versa, of course.
+ </longdescription>
+ <stabilize-allarches/>
</pkgmetadata>
diff --git a/app-emacs/yatex/yatex-1.77.ebuild b/app-emacs/yatex/yatex-1.77.ebuild
index 7b7534cc7785..3909baa70f86 100644
--- a/app-emacs/yatex/yatex-1.77.ebuild
+++ b/app-emacs/yatex/yatex-1.77.ebuild
@@ -1,20 +1,21 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI="6"
-inherit elisp eutils
+inherit elisp
DESCRIPTION="Yet Another TeX mode for Emacs"
HOMEPAGE="http://www.yatex.org/"
-SRC_URI="http://www.yatex.org/${P/-/}.tar.gz"
+SRC_URI="http://www.${PN}.org/${P/-}.tar.gz"
KEYWORDS="amd64 ppc ~ppc64 x86"
SLOT="0"
LICENSE="YaTeX"
IUSE="l10n_ja"
-S="${WORKDIR}/${P/-/}"
+S="${WORKDIR}/${P/-}"
+
ELISP_PATCHES="${PN}-1.76-gentoo.patch
${PN}-1.76-direntry.patch
${PN}-1.77-texinfo-5.patch"
@@ -25,27 +26,27 @@ src_compile() {
# that are only available under X
cd docs
- makeinfo yatexe.tex yahtmle.tex || die
+ makeinfo {${PN},yahtml}e.tex || die
if use l10n_ja; then
- iconv -f WINDOWS-31J -t UTF-8 yatexj.tex >yatex-ja.texi || die
- iconv -f WINDOWS-31J -t UTF-8 yahtmlj.tex >yahtml-ja.texi || die
- makeinfo yatex-ja.texi yahtml-ja.texi || die
+ iconv -f WINDOWS-31J -t UTF-8 ${PN}j.tex > ${PN}-ja.texi || die
+ iconv -f WINDOWS-31J -t UTF-8 yahtmlj.tex > yahtml-ja.texi || die
+ makeinfo {${PN},yahtml}-ja.texi || die
fi
}
src_install() {
- elisp-install ${PN} *.el || die
- elisp-site-file-install "${FILESDIR}/${SITEFILE}" || die
+ elisp-install ${PN} *.el
+ elisp-site-file-install "${FILESDIR}"/${SITEFILE}
insinto ${SITEETC}/${PN}
doins help/YATEXHLP.eng
- doinfo docs/yatex.info* docs/yahtml.info*
+ doinfo docs/{${PN},yahtml}.info*
dodoc docs/*.eng
if use l10n_ja; then
doins help/YATEXHLP.jp
- doinfo docs/yatex-ja.info* docs/yahtml-ja.info*
- dodoc 00readme install docs/{htmlqa,qanda} docs/*.doc
+ doinfo docs/{${PN},yahtml}-ja.info*
+ dodoc 00readme install docs/{htmlqa,qanda,*.doc}
fi
}